Jump to content

After reboot (win7) torrent files are downloaded via svchost.exe


Recommended Posts


I want all torrent traffic to go via a VPN-connection.

For Comodo FW I have defined a network zone "Anonine" that covers the IP-range of the VPN-connection.

I have created rules in Comodo that states that uTorrent can only send and receive traffic from "Anonine" network.

That works fine and when I close the VPN connection to the "Anonine" network, uTorrent can not download/upload anymore as the Comodo FW rules says uTorrent application can only communicate to/from network "Anonine".

When I connect to the VPN to "Anonine" the uTorrent traffic starts again to flow.

BUT, when I reboot the win7 PC, and uTorrent is started at boot, and VPN is NOT started, torrent files seems to be downloaded to uTorrent VIA svchost.exe!!!!???

I see this in Comodo FW's "Active Connections" window, as a lot of traffic goes via svchost.exe but none to uTorrent. Despite this uTorrent UI shows that it downloads files.

So uTorrrent app itself does not get any traffic directly from internet, instead it seems to be routed via svchost.exe.

So, even if I have forbidden, in Comodo fw rules list, uTorrent to download files when VPN is down, uTorrent downloads via svchost.exe (this occurs after PC reboot).

Why is this happening and how should I handle it?

Link to comment
Share on other sites


Thanks. I disabled IPv6 in registry (http://www.addictivetips.com/windows-tips/how-to-disable-ipv6-in-windows-7/)

and also the IPv6 network adapter (driver), and rebooted.

Strangely still one torrent continues to download via svchost.exe, and the other 3 torrents was stopped.

How was that possible?

Is it possible to also disable use of IPv6 in uTorrent?

Anyhow, i again googled on how to disable IPv6 and learned that the guide I read (see above) was a bit wrong.

The parameter shall not be set to "0" as the guide I mention above, instead read microsofts guide at http://support.microsoft.com/kb/929852 . the aparmeter in registry shall be set to 0xffffffff .

Now with VPN down uTorrent does not download anything at all. And also after reboot and uTorrent automatically started (VPN down) still no traffic is going to uTorrent neither directly to app uTorrent nor via svchost.exe.

When i connect the VPN uTorrent starts to down/upload. But it took quite long time before it was up to full speed. I wondre why. Maybe I should reinstall uTorrent to make it adapted from beginning to non-IPV6 support?

Link to comment
Share on other sites

I have disabled IPv6 as described above. Also reinstalled uTorrent. BUT still 1 torrent (of 5) are downloaded via svchost.exe after reboot of PC.

Also uTorrent says after reinstall (in the log) that IPv6 is installed and Teredo adress is aquired.

This is really annoying. How is it possible after I have disabled IPv6? Sigh!

I now checked the value in the registry (after reinstall of uTorrent) and that was changed from 0xffffffff to 941fffff. I wonder if uTorrent installation did that? I did not check before reinstall unfortunately.

How can I disable uTorrent to use IPv6 and prevent it to aquire Teredo adress?

Greatful for help.

Link to comment
Share on other sites

Thanks for your help GTHK.

I did according to the ms guide http://support.microsoft.com/kb/929852 .

After that done I also ran "cmd /k netsh interface ipv6 uninstall" but got the error message:


The following command was not found: interface ipv6 uninstall.



This error message implies, I think, that IPv6 is unistalled or disabled (by following the MS guide), but STILL uTorrent log says:

[2010-01-11 22:02:42] IPv6 is installed

[2010-01-11 22:02:42] Got Teredo Address: 2001:0:d5c7:a2d6:1ca7:ae75:ae13:eb4f

So the Win7 OS says that IPv6 is uninstalled or disabled (I do not know which) but uTorrent says it is installed.

And torrents is downloaded via svchost.exe.

This really confuses me.

Update of above


I now seem to have succeeded in disabling ipv6. When running ipconfig no ipv6 interfaces shows up.

Still uTorrent says in the log that IPv6 is installed.

So, I will see if this lasts..... ;-)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...