Jump to content

raising the upload limit chokes the download rate


Recommended Posts

About a week ago I suddenly started experiencing a conflict of sorts between my download and upload speeds in uTorrent. Specifically, the higher I raise the limit on my upload speed the slower my downloads go regardless of what the download limit is. If I lower my upload limit to around 10kB/s or lower, then downloads rates will climb right up to the cap which I typically set at 500kB/s. (In fact, if I lower the upload limit all the way to 1kB/s and totally uncap my download speed it easily pulls down several hundred kB/s with surges up to 1.0MB/s and it will run like this for hours on end.) However, once I start to raise the upload limit again, say, in steps of 5kB/s, the download rate is proportionately reduced with each step. And by the time I get up to around 40kB/s I'm lucky if I can pull down 100kB/s from a torrent with thousands of peers that otherwise downloads at upwards of 1.0MB/s.

Additionally, when I raise the upload cap to 40kB/s or higher it doesn't just crash download speeds in uTorrent, it negatively affects all traffic in my home network. For example, web browsing on all computers in the house becomes extremely slow. However, it's not just WAN connections that are negatively affected, but LAN traffic also slows down drastically. That is to say, connecting to either Google or the router's login page both can take as long as two minutes.

I have duplicated this behavior with more than a dozen different torrents from more than a dozen different trackers (including OpenOffice.org, etc.) and it occurs in both the v1.8.5 client and the v2.0 client (which I'm currently using as of writing this).

To start with I tried all the basic measures: rebooting the gateway and my computer (many, many, MANY times); checking that the light is green in the client's status bar; verifying that port forwarding is set up correctly via Speed Guide; deleting settings.dat and settings.dat.old; as well as reinstalling with a copy of v1.8.1 of the client I had in my archives on the off chance that I was experiencing some bizarre issue unique to v1.8.5 and v.2.0 Beta.

Obviously, the basic measures didn't work, so here's all the current specs/config for my system and network along with notes on different settings I have tried:


-CPU: Pentium Dual-Core 2.60MHz


-mobo: Asus P5KPL-CM

-OS HDD: Western Digital 80GB PATA

-P2P HDD: Western Digital 200GB PATA

-LAN: Atheros AR8121 onboard Ethernet

-OS: Windows XP Professional SP3

-AV/firewall: BitDefender 2009 (also tried temporarily disabling firewall)

-IP Address: (static)

-Subnet Mask:

-Default Gateway:

-DNS Server: (also tried OpenDNS servers at and

-NetBIOS: enabled (also tried disabling it)

-IPv6/Teredo: not installed (it was installed prior to the problems starting, but I have since uninstalled it)

-TCPIP.SYS: 10 half-open connections (was patched to 100 when problems started, but I repatched to 10)


-ISP: Time Warner Road Runner, Cincinnati, OH

-gateway: SMC 8014WG

-dslreports Speed Test: 7025 kbps / 475 kbps / 25 ms ping

-Road Runner Speed Test: 9422 kbps / 486 kbps / 20 ms ping

-Speedtest.net: 9820 kbps / 490 kbps / 33 ms ping

-Speakeasy Speed Test: 9594 kbps / 491 kbps

-Glasnost: found no evidence of BT throttling/blocking


-Listening port: 20420 (verified that the port is properly forwarded with Speed Guide)

-Global upload limit: 40kB/s

-Global download limit: 500kB/s

-Global max connections: 250 (also tried 100 as per Switeck's conservative settings)

-Max peers per torrent: 90 (also tried 40 as per Switeck's conservative settings)

-Upload slots per torrent: 4

-Max active torrents: 3

-Max active uploads: 2

-Protocol encryption: enabled (also tried disabling it)

-UPnP: disabled (also tried enabling it)

-NAT-PMP: disabled (also tried enabling it)

-IPv6/Teredo: not installed (it was installed prior to the problems starting, but I have since uninstalled it)

-bt.connect_speed: 20 (also tried 10 and 5)

-bt.transp_disposition: 0 (also tried enable, force and disable)

-net.max_halfopen: 8 (also tried 4 and 2)

-peer.lazy_bitfield: true

-peer.resolve_country: false

I think that's pretty much everything. Any help would be *greatly* appreciated. Thanks.

Link to comment
Share on other sites

My guess is either your unknown router or BitDefender 2009 is to blame. (Most software firewalls have to be completely uninstalled to remove their influence.)

Try these settings (any settings not mentioned, leave at previous values):

-Global download limit: set back to unlimited

-Global max connections: 60

-Max peers per torrent: 30

-Max active torrents: 2

-Max active downloading torrents: 2 (clearly, your settings there were "backwards" before)

-bt.connect_speed: 1 (only attempt 1 new peer/seed outgoing connection per second)

-net.max_halfopen: 4 (only have 4 concurrent outgoing TCP connection attempts at once)

Disable DHT, LPD, Resolve IPs...and possibly even uTP peer/seed connections.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...