Jump to content

Seems like uTorrent rendered my external USB hard drive inaccesible.


Recommended Posts

After completing a ".rar" archive download, Winrar gave an "unexpected end of archive" error.

So I decided to redownload it. As there is no way to do this in the program (and avoiding seeding a corrupted file) I opened the folder where the downloaded achive was an simply deleted it.

Upon reopening uTorrent, a message like "missing files... " appeared. Than I right clicked the torrent and chose "Force start".. My external drive started buzzing... I thought that it worked.. and uTorrent was allocating space for the download...

Then when I opened "Windows Explorer" my external drive's letter was there but WinXP asked me if I would like to format my drive! as it seemed like an unformatted drive.


What did I do? Is there a way to recover all the data in my external drive?


Link to comment
Share on other sites

You might be able to do a recovery, but it does sound like your hard drive either died or the partition table corrupted itself. It doesn't really have anything to do with uTorrent, it's just a coincidence.

See if you can use an app like Testdisk to do a virtual partition recovery. If the drive is totally inaccessible, take it out of the enclosure and put it into your PC, then try again. Failing that, you're screwed.

Link to comment
Share on other sites

Testdisk worked. Thank you very much.

It turned out that this was a FAT error. Testdisk fixed it by copying the backup.

I saved everything important to an internal harddrive.

But, I have no longer confidence with this Maxtor One Touch drive... It keeps corrupting itself. During the copying hassle I had moved a directory into another and the directory became inaccessible. Luckly it wasn't important...

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...