Jump to content

New torrents will not download at full speed until I restart uTorrent


Recommended Posts

I've searched and seen the other threads with the same issue. Tried to resolve the issue on my own but am having no luck. I had a similar issue with the 1.8 series on Win XP, but since then I've put together a new rig, so I thought I'd start my own thread.

When I add a new torrent for download, uTorrent takes anywhere from 2-15 minutes to start downloading. When it does start it picks up seeds and peers very slowly, and never picks up the full amount as set by maximum number of connections per torrent. The end result being very slow download speed. I've left uTorrent alone to see if things got better over time and it does not. The newly added torrent will just sit there, acting retarded.

To get things to work right I have to restart uTorrent. To do that I pause all my torrents, wait a bit to let the traffic slow down, close the program, wait a bit, then launch uTorrent again.

Everything works fine upon restart. The recently added torrent immediately picks up seeds, peers, and downloads right to my max.

This is a fresh PC running Win7 x64 Ultimate and Version 2.0 (build 17920).

My net is 240 kb/s dwn 60 kb/s up, Netggear WNR-3500 + SB4100.

I use settings very close to Switeck's conservative settings for my speed: ║56│4║25│100║7│3║

UPnP, NAT-PMP, DHT, PEX, Local Peer Discovery, IP resolving, uTP (bandwidth management) all disabled.

Encryption enabled with allow incoming legacy connections.. No advanced settings changed. Only private trackers.

I do not have any port forwarding, firewall rule, or isp torrent traffic issues.

No additional anti-virus or firewall software installed.

Additional details to take note of. The delay I experience before a download ever starts seems to vary depending on the tracker, some start faster than others but the delay is there none the less.

Newly added torrents for download however are always screwed up no matter the tracker, until I restart uTorrent.

Link to comment
Share on other sites

Disabling IPv6 is possible, but note the method for re-enabling it (to change back later):



Try changing to ║60│4║30│150║5│3║

...This gives 30 connections out of the global max to EACH torrent.

Please tell me if you're seeing more than 5 torrents start at once, especially if they get peers/seeds connected but just download/upload really slowly.

Link to comment
Share on other sites

I changed to ║60│4║30│150║5│3║

When I start uTorrent I don't see any more than 5 start, or whatever you set the max active to, everything else queue's up.

Now you want me to uninstall IPv6 and disable Teredo? Or just uninstall IPv6? Or just disable IPv6?

Sorry I want to be clear because IPv6/Teredo I'm not familiar with, so I tend not to mess with it.

Link to comment
Share on other sites

Then the last resort is to blame Windows background automatic processes that are using the Internet. In this case, the latest newest process run by the user will get most of the bandwidth. After your torrents ended, the background processes began to use the bandwidth, and when you restart utorrent, its update checker works faster and took over the bandwidth for the process.

Link to comment
Share on other sites

I did start -> run and then these commands, one then the other;

netsh interface ipv6 set teredo disable

netsh interface ipv6 uninstall

Restarted my pc and I still get an IPv6 is installed message but nothing about Teredo anymore.

Next thing I did was go to my network cards properties and unchecked IPv6.

Tested on a couple torrents from different trackers and indeed, the delay now before the torrent actually starts is only a few seconds on some trackers, to one minute on others. Seeds and peers are also picked up much quicker than before. With in a minute or so on a downloading torrent there will be max number of peers connected.

Thanks much Switeck and GTHK, maybe you can help me with another issue.

I wish I could tell you when exactly this started but I can't. I noticed it before I disabled IPv6/Teredo, and it's no different with IPv6/Teredo disabled. I do know what I'm about to describe did not happen with 1.8.5 (17414) before I upgraded.

When uTorrent is running, and uploading steadily, my net goes to hell. To put it simply.

If I let uTorrent upload to 5 torrents at 50 kb/s and try to surf the web, download a small file like firefox, update window, etc, from any pc on the lan including the one uTorrent is running on everything is horribly slow.

Download speeds in uTorrent it self are also really slow.

If I throttle back the upload limit a little bit at a time, starting at 50 kb/s and working my way down, things get better and better as I go down. Once I get to about 30 kb/s or lower things are sort of normal. My ping rates and download speeds get better and better as I cut uTorrent off.

Before with 1.8.5 I could be uploading at 56 kb/s and run a speed test on another pc on the lan and get my full download speed, a 16ms ping, and the upload would show whatever uTorrent wasn't using. I could also with 1.8.5 be downloading at my max speed and uploading at my max speed (minus about 15-20%) at the same time.

Now if I let uTorrent have even 50 kb/s I can't download anything, and my ping is up in the the 400's or more. Now I have to throttle back uTorrent to about 35 kb/s to get 100 kb/s down. If I go lower to 25 kb/s I get up close to my max download speed.

I've tried restarting any pc on the lan, the modem, the router. Tried to go back to 1.8.5, tried to delete the settings files and start over, nothing. Went back to 2.0 and tried new settings files, nothing. Tried going back to with IPv6/Teredo enabled, verified they were enabled again in the log, nothing. Don't know why I thought that would work because I noticed this all before I uninstalled them.

So at the moment I'm back to where I was at the beginning of this post. Running 2.0 with IPv6/Teredo disabled and the settings Switeck recommended last.

Link to comment
Share on other sites

With uTorrent stopped, I get 200 kilobytes/sec down and 56 kilobytes/sec up with online speeds tests like SpeakEasy and SpeedTest.

If I run the built in speed test that's now in uTorrent 2.0 it says my connection is a little faster at 220 kilobytes/sec down and 64 kilobytes/sec up.

Right now the setting "max upload rate" should be called "how slow do you want your net".

The max upload rate and my internet usability are inversely proportional at the moment.

The higher I set the rate the slower everything becomes, the lower I set it the more things return to normal.

Link to comment
Share on other sites

Well, I've tried everything I can think of with in reason. Nothing I've tried helps.

I used to be able to upload at 50 kilobytes/sec and download at 180 kilobytes/sec at the same time, now I definitely can not.

I have to lower my upload cap to 30 just to get 50-80 down. If I let uTorrent upload at my full speed, or even close to it, I can't download any faster than 10-20. This is true for any application, on any pc on my lan, not just uTorrent.

I don't have the technical expertise or experience to diagnose this problem any further than the trial and error procedure I've been using so far. So I guess I'm just going to have to wait until I have the time, and patience, to reinstall Windows.

When ever I do get things working back to the way they used to, I might just swear off upgrading uTorrent ever again.

Oh, my router logs just shows peers connecting to my lan through the port I have forwarded for uTorrent.

I don't know what to do about the SB4100, my request to my isp to come out and upgrade it has been denied twice. So unless I go out and buy a new one myself I'm kind of stuck with it.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...