Jump to content

New Version 1.8.5 slows down everything else


Recommended Posts

I downloaded my previous version of uTorrent on 5/4/2008

All has worked well since. I have a 12Mbps adsl connection, and a Linksys WRT54G2 router. The uTorrent computer is connected by wire to the router.

Until last Friday, when (who knows why...) I downloaded the latest version of uTorrent 1.8.5

Now, after just a couple of minutes of utorrent running, browsing for all users in the network slows to a halt! This for all users, wired and wireless.

uTorrent keeps downloading/uploading at whatever speed the swarm allows, even up to close to the max of 1300KBps on download. But the problem is still there even if only one download at 10KBps is active.

I downloaded and installed the latest firmware, to no avail.....

I also minimized the setup so that wireless is disabled, and only one wired computer is connected. Worked the computer for hours w/o a problem. Started uT and bingo! browsing is very v e r y slow. Sometiomes stoping uT and the service fixes the problem, sometimes I need to restart the router to fix the problem.

So I had to stop using utorrent in order to keep all users happy. Pitty because I seed at 500 kbps.

Before I switch to another client, I'd like to try and find the solution.

Any help/tips are much appreciated!

Thanks in advance,


Link to comment
Share on other sites

Installed 2.0

Followed all suggested points as per http://www.utorrent.com/documentation/connection-setup except for port forwarding and static IP, since it complicates everything.

At any rate, please notice, the speed issues are NOT with uT, but with all other applications. Even 2 uT clients on the network will work at good speed, but soon after the uT client starts, all other web applications slow down, including mail clients pop/smtp and web browsing, yuotube, etc.

More info as per the documents...

Using WIndows Firewall, and Eset NOD32 V 4.0.474. uT was already excluded from the web browsing list since before this problem. The router is WRT54G2 firmware 1.0.04 which means the hardware version is 1.0

I lookd at the documents you poimnt put, 100%, and my head is spinninig. I don't know what other info to give you. I disabled Eset's Web Access Protection and the problem is somewhat less critical (although still very slow) on the PC running uT but the same for all other PCs on the LAN. mmhmmmm.

Thanks Again,


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...