Jump to content

Download speeds ok(ish) but upload unbelievably slow!


Recommended Posts


I have been using µTorrent for several years without any major problems.

Recently I signed up for Be's Unlimited Package (24M/1.3M). I was told that my local exchange would only support 20Mbps, which is fine for me.

Dslreports show a download speed of max. 3.5Mbps (although I have reached speeds of about 9Mbps downloading well-seeded torrents) and an upload speed of around 900kbps so quite close to the 1.3 stated by my provider.

When I upload a torrent, the speed never exceeds 25kbps - in fact it varies a lot and often is far below that, in the 2-10k range. I have tried all the suggestions (having visited this forum on a number of occasions in the past) but without any success.

- I applied the speed guide settings for 768k

- encryption is enabled (although Be are said not to use traffic shaping)

- when downloading popular torrents my connection maxes out at over 8Mbps but with no difference to the U/L speed

- the network status light is green

- I have forwarded the ports correctly (confirmed by port checker)

- I have tried various uTP settings

- peer.lazy_bitfield is enabled

- Glasnost tells me that there is no indication that my ISP throttles traffic

- according to the net.max_halfopen patch tool my tcpip.sys doesn't need patching because there is no limit (set in µTorrent to 80)

- I have added an exception to the Windows Firewall

- I don't use a 3rd party firewall or antivirus software, just occasionally scan with Malwarebytes

- I have tried both µTorrent 1.8.3 & 1.8.5 and with DHT both enabled and disabled

My system specs are:

- Gigabyte EG31MF-S2 motherboard

- Pentium E5200

- 2GB DDR2 RAM (800MHz)

- Vista 64 Home Premium with SP2

- Thomson TG585v7 wireless router (signal strength: good to excellent)

My provider is Be Broadband.

Please can someone help me with this issue, as it has persisted since I changed to Be several weeks ago and I have tried absolutely everything I could think of and have followed all the suggestions I could find (except for changing the DHCP settings because I couldn't find a configuration menu - could this be the reason?).


Unbelievable - why did I never think of disabling NAT-PMP port mapping? Everything fine now, UL'ing with >800kbps! :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...