Jump to content

Error: Bad file descriptor (0.9.2. mac)


Recommended Posts


I always get this error (Bad file descriptor) when I first decide to skip the download of some files (I right-click the files and select "Don't Download") and after a while I decide to download them (I right click on them and select "Normal priority" or "high priority" or "low priority").

After two seconds I get the error and the torrent stops (with a red X next to the name).

The only way to get it working again is to select "Don't Download" on the files that I had "Skipped" downloading, and click on the Start button.

This is annoying because sometimes I download TV shows but I want to download just a few episodes at a time and then delete them and download the rest... for disk space reasons.

Link to comment
Share on other sites

Awesome how the moderators here always assume the problem is on the side of the person posting the issue.

I have the EXACT same issue, don't you think it can be a Utorrent issue if this ONLY happens when you modify the download priority of single files within the torrent ?

example :

download 1 torrent full season 1 friends

(it starts downloading everything to start with because the mac version does not come up with the file selection box yet)

you stop the torrent and change all priorities to 'do not download' and just select the first file (episode) as ' normal priority' and hit start

it happily downloads the episode

now you change the priority of the second file / episode to ' normal' and it tries to start, but instead you end up with an error

you check the status / log message and it says

Error: Bad file descriptor

I am also using 0.9.2 17267

Link to comment
Share on other sites

Awesome how the moderators here always assume the problem is on the side of the person posting the issue.

Perhaps its because We know what error messages mean? And when its one person having the error message, its natural to assume that the message means exactly what it says.

Now, since you've said you can reproduce the problem where the error message shows up at a time it shouldn't, thats a different story. And yes, a bug. Does the bug still happen with 0.9.3?

Link to comment
Share on other sites

I have not upgraded to 0.9.3 yet ... will do that after my torrents have finished today and perform a new test.

I think what is going wrong is that Utorrent is in fact corrupting the .dat file because the only way to get the torrent working again is to delete this file, force recheck and then start the download again ... This combined with the meaning of the error message suggests Utorrent is corrupting something.

will test with latest version and post here

Link to comment
Share on other sites

  • 1 month later...

I have the same problem.

I run the Disk Utility and repaired the volume.

But the problem still exists. And at least for me it is related to the not enough free space on the drive when the program tries to create a new file for the content.

I've uploaded 2(two) screenshots here with the situation: http://img59.imageshack.us/gal.php?g=screencapture1q.png

The first screen shows the torrent client. You can see that the file: Ghost_in_the_shell_2.0xxxxxx has a 1.83MB downloaded (By my observation the client will create the file in the destination folder when 2MB are downloaded) . But dew to not enough free disk space it creation failed ones. You can see this from screenshot 2. I've freed some space and tried to remove the tmp file and to rechecked the torrent from the client with the "Force Re-Check" option. But I could not find a way to null this 1.83MB or two recreate the target file.

After this the behavior is the same as described: as long the problem file is "do not download" the client works fine.

I hope you can reproduce this.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...