Jump to content

Version 2.0 is killing my router!


Recommended Posts

When I upgraded to my utorrent v1.8.5 I noticed drastic speed decrease, especially upload. No difference if I set limits/unlimited so far.

But that's not the main problem. I can live with 50% speed decrease. But when I am running utorrent 2.0 I cannot browse at all or use any other network program. Pages just won't load. I started windows 7 network troubleshooting. It said there is DNS server problem. When I pause my utorrent everything works instantly well.

I noticed when I turn off Bandwith Management in utorrent 2.0 settings, pages will load. I can browse, however it doesn't feel as smooth as in version 1.8.5. I could browse with no problems having 4 MB/s download in old version, in this version however, even ~1MB/s seems to overload my network and browsing is not smooth(with Bandwith Management turned off).

My download speed is ~6.4 MB/s, upload ~1MB/s And it is not burst speed, i tested it on many websites including Speedtest. When I am downloading World of Warcraft Client via Blizzard Downloader(it is p2p based) I have ~6MB/s over 30 min or so, it basically maxes out my internet connection.

I reinstalled windows 7 twice and I am 100% sure no programs are interfering with utorrent 2.0 I was setting windows firewall on/off/editing rules manually. By the way when you choose during installation of utorrent 2.0 not to add firewall rules, it still adds them no matter what(installer bug?) I have all latest windows updates installed.

My ISP is Comhem AB. I don't think they are limiting p2p traffic, and if they are, why version 1.8.5 and below worked flawlessly? I cannot be a coincidence they started limiting me all of the sudden when I intalled utorrent 2.0(sounds stupid and like a fairytale, right?)

I am sharing my net connection with my friend, also running windows 7. When he is using utorrent 1.8.5(he refused to upgrade after he saw what's happening with v2.0) I have no problems surfing. When I launch utorrent 2.0 I can hear him swearing from another room and then knocking my door :)) Nothing like that happened in 1.8.5

I was resetting router to factory defaults/rebooting. There is no newer firmware available on Dlink tech support pages than the one installed on my router. No router firewall is active with default settings.

So my theory is utorrent 2.0 is overloading/not compatible with my router. My router is D-Link DIR-120(it's wired router, I hate wireless since I'm gaming a lot).

So guys/admins/moderators/developers do you agree that I make a valid points saying utorrent 2.0 is not compatible with my router? And are you going to resolve the issue, with a hotfix perhaps in the nearest future? The router is not old, only 4 months old. The router model is not the newest one, but tell me that, do you honestly think majority of utorrent users are using latest model routers buying a new one every year? This needs to be fixed asap, I really like utorrent for it's lightweight feel, but it isn't "lightweight" anymore, overloading my network while 10% of my max speed is running? This is unbelievable...

I am sorry if it sounded harsh to you. I am just frustrated user who wants the things working. And right now I am on the edge of switching to another torrent client, if don't get a hotfix this week.

Link to comment
Share on other sites

If the router's broke-by-design, there's not much uTorrent developers can do to fix it. :(

In uTorrent v2.0, go to Preferences, BitTorrent and disable Bandwidth Management. This stops uTorrent from making OR accepting uTP connections...but won't disconnect existing uTP connections. So you may have to restart uTorrent (or at least the affected torrents) to do that.

Link to comment
Share on other sites

Try disabling whatever firewall the D-Link has.

As I said, it is disabled by default.

If the router's broke-by-design, there's not much uTorrent developers can do to fix it.

It is not "broke by design" it is "incompatible". At the time router was created no one was thinking about some uTP. You cannot fix it? Make a list of utorrent 2.0 compatible routers,make "Bandwidth management" disabled by default and give users warning when they click that option, to visit page with a list of compatible routers. It will save thousands people a lot of frustration.

In uTorrent v2.0, go to Preferences, BitTorrent and disable Bandwidth Management.

It would be nice if before giving advices/looking for solutions you would actually read the initial post ^^

D-Links seem to be hatin' on uTP:

My DoS protection is off(which is default)

Guys, this is such a mess, I have to break my head reading all these faqs/guides(most of stuff in there is nothing new to me and designed for total noobs), all these bt.tcp_rate_control, fiddling with settings, jesus christ. This reminds me 1st days switching to windows vista... Everything worked fine in 1.8.5 and now all of the sudden i have to trash my router or change client...

Link to comment
Share on other sites

My bad about you already trying Bandwidth Management on/off/sideways.

A router's design can be a failure for UDP traffic regardless of how new it is. D-Link has a very poor track record for fixing long-standing issues: DMZ Data Destroyer mode and UPnP failure to name 2 exceptionally bad cases.

Is Teredo/IPv6 enabled in your Windows?

I've heard of it absolutely hammering routers as well.

uTorrent will attempt to use Teredo/IPv6 if available -- probably even says so when it first starts in Logger window/tab.

Link to comment
Share on other sites

What bt.transp_disposition setting do you have set?


Is Teredo/IPv6 enabled in your Windows?

I've heard of it absolutely hammering routers as well.

uTorrent will attempt to use Teredo/IPv6 if available -- probably even says so when it first starts in Logger window/tab.

It is enabled, however, router is "Windows Vista Certified" and as you know, Vista had IPv6 as well. Also utorrent 1.8.5 had IPv6 connections working perfectly. If there would be an option in utorrent to ignore IPv6, I would gladly try it out(but there isn't one), and by disabling IPv6 globally I will have to mess with the registry and also disabling it messes up windows 7 Homegroup, which I might use in the future. Most of my registry windows tweaks ended up with format C: in the past(couldn't remember what did I change and where) - nay, won't do it this time :<

As I said guise I can browse while "Bandwidth management" is disabled, but I still feel something is missing to be disabled to get my old 1.8.5(and below) stability/speeds back :(

Link to comment
Share on other sites

I thought you might've had IPv6 before, but quite frankly I don't have any "low-hanging fruit" solutions left for you to try. So I mention unlikely longshots that may or may not be easy to check. :(

For what it's worth, I asked the devs if they'd add a checkbox to disable IPv6...the answer was no.

I doubt it'd help, but try these advanced settings:

bt.connect_speed = 1

net.max_halfopen = 4

This should have little effect on uTorrent's apparent speed, except the first minute after a cold startup...unless you're firewalled.

Link to comment
Share on other sites

What bt.transp_disposition setting do you have set?


Hmm, very confusing ... why 5 ...

From the Utorrent 2.0 user manual

bt.transp_disposition: This option controls µTorrent's level of bias towards using TCP or uTP for transporting data (assuming the peer at the other end of the connection supports both transport protocols). The following is a list of the accepted values:

1 allows µTorrent to attempt outgoing TCP connections

2 allows µTorrent to attempt outgoing uTP connections

4 allows µTorrent to accept incoming TCP connections

8 allows µTorrent to accept incoming uTP connections

16 tells µTorrent to use the new uTP header. This is an improved communication header, but is not backwards compatible with clients that do not understand it.

This option is interpreted as a bitfield, so values can be added together to obtain a combination of behaviors. Setting this value to 255 guarantees that all behaviors are enabled.


So can we assume this is old? >>>

How to enable and disable it:

Preferences > Advanced, change bt.transp_disposition. This is now a bitfield, so you can add up the following numbers to get your desired setting.

1 - outgoing TCP

2 - outgoing uTP

4 - incoming TCP

8 - incoming uTP

Specific combinations:

255 - both TCP and uTP, incoming + outgoing (future-proof setting, always will mean this)

15 - both TCP and uTP, incoming + outgoing (default)

I just upgraded to 2.0 and the standard settings for bt.transp_disposition still is 15. :/

Link to comment
Share on other sites

Here's something to test:

If you connect your computer directly to the ISP (not passing through the router), does utorrent 2.0 work ok? (no 50% speed decrease)

I don't need to do this since I already know it's a router. When I have utorrent 2.0 running at default settings, I tried to go to the router config page - it didn't let me in, conclusion - router hangs/overloads, since I can access that page even with no internet at all.

Hmm, very confusing ... why 5 ...

Lol guise. bt.transp_disposition = 5 is with "Bandwith management" off. I turned that thing off, what's confusing about it?

Link to comment
Share on other sites

Thanks Switeck and pikezeppelin,

Confusing cause it isn't in the manual, I like manuals that give all possible settings. :P

Missing in the 2.0 manual:

bt.transp_disposition =

5 disables uTP and only uses TCP.

15 - both TCP and uTP, incoming + outgoing (default) (is the same as 255 although 2.0 uses 15 as default setting)

Link to comment
Share on other sites

I'm having the same issues with µtorrent 2.0. When I disable bandwidth management and set bt.transp_disposition to 5 the issues are fixed. Maybe my router or modem doesn't like utp? I'd like to be able to use utp but with that enabled my browsing the internet is impossible and my speeds drop to about 100-200 kB/s and with it disabled its 1.5 MB/s and no impact on my browsing. I tested this with an anime torrent with over 2000 seeds and 3000 peers. If anyone knows how to make utp work with my setup please let me know.

OS: Windows 7 Professional 64-bit

NIC: Marvell Yukon 88E8053 PCI-E Gigabit Ethernet Controller (on motherboard)

Router: Linksys WRT54G firmware version 8.00.7

Modem: Motorola Surfboard SB6120 firmware SB6120-

ISP: Comcast Cable

Link to comment
Share on other sites

Here's some pictures of the same torrent download:

1st: bt.transp_disposition set to 5 : (download maxed at 1.8MB/s)


2nd: bt.transp_disposition set to 15: (download maxed at 235kB/s) *I had to stop it because my mother couldn't browse her facebook on the other computer and was getting angry - but I stopped it at the same time the first one finished at*


Obviously my router can't handle utp for some reason because of said mother getting angry. Is there a router setting I'm missing or anyone recommend a good router that can handle utp?

Link to comment
Share on other sites

Same situation here with Utorrent 2.0 build 17920: Slow Internet browsing and torrent transfer.

Here's my torrent box setup:

DFI Nvidia Nforce2 chipset mainboard

Nvidia MCP onboard 10/100 NIC

AMD Athlon XP

Win XP SP3 fully updated

No software or registry hack, plain Windows only.

Microsoft security essential AV

D-link DIR-655 REV 3 Firmware 1.21

Webstar DPX2100 Cable modem Hardware V1.1, software V2.0.1r1142-050302

ISP: Videotron (Quebec, Canada)

Connection type: Cable, 7Mb/s down, 0.8Mb/s up



No port forwarding used (UPnP and random port in Utorrent instead)


Traffic shaping ENABLED

Automatic Classification ENABLED

Dynamic Fragmentation ENABLED



Multicast Streams: ENABLED

With Utorrent 1.85, no problem at all. Installed 2.0 and instantly, torrent and browsing went super sluggish. Internet pages would take minutes to load completely and torrent speed was slashed 30 to 60% from its former speed. Note that I only tested with 10 torrents seeding, no download, and that scheduler was ON with a 75Kb/s upload cap out of 100Kb/s available.

The router log and statistics page shows noting out of the ordinary. In fact, the only thing that is as speedy as before are the pages loading from the router. Access to the Internet from other computers on the LAN have also been affected, but it didn't felt nearly as dramatic as the computer Utorrent is running on.

After a while of doing testing (over 45 mutes I would say), I've noticed the extreme lag had subdued considerably. Page were slower, as in not as instantaneous as with 1.85, but no where close to the minute range. Torrent now reaches the maximum 75Kb/s upload, with some fluctuations. Much better, but far from perfect.

As soon as I close Utorrent 2.0,the Internet is ultra snappy again. Next, I've disabled "enable bandwidth management" and noticed that by doing this, "bt.transp_disposition" is automatically set to 5. So I don't understand why some says that they need to "both" since doing the former also adjust the later. After doing this modification, the speed was back, but not immediately. It seems it took a while for the effect of the bandwidth management to "dissipate". In fact, I went as far as to re-install 1.85, do some torrent for 30 minutes, and then install 2.0 again. Then the speed was flawless right of the bat.

I'm now running 2.0 with bandwidth management disabled and I have the same overall quality experience as with 1.85...

CONCLUSION: Bandwidth management should come disabled by default until this situation is resolved and/or more compatible router firmware are available, as I can see many were plagued by this issue. Linksys and D-link router might not be Cisco enterprise grade, but there are not Belkin or no name, ultra cheap router either. What's the market share, or more to the point, what is the proportion of the installed base of both brand (Linksys and D-link) using Utorrent right now? My bet? At least 60%, probably more like 70-75%.... If both of those brand fail the new uTP, then what is the point of having it enabled by default in the first place?



Link to comment
Share on other sites

I had the same problem on Linksys WRT54G2 router. Connection dropping and upload speed very low. Web browsing and IM programms dead. I have compared same settings in 1.8.5 and 2.0. As you know 1.8.5 works great. You can even play online games without lag. 2.0 chokes my router. I have connected directly to my Cable modem and 2.0 works fine. But I have WiFi at home so I need my router back.

As you mentioned everything works fine with "enable bandwidth management" option disabled.

Screens to show connection problems.

(I know problem is solved but I found this topic after I made screenshots, so I will post it ^_^)

Thanks for help.



Link to comment
Share on other sites

Just wanted to post in this thread, which resolved my issues.

I am directly connected to an Ambit cable modem using Charter's internet service. I used to have random internet connection drops though my network icon in the taskbar never detected them. I'd know I was disconnected only because utorrent traffic would stop, and all other applications (ie: browser) wouldn't function. And, despite my network icon thinking I was still connected just fine, I wouldn't even be able to connect, via input of IP address, to my cable modem through the browser. The only fix was turning my modem off and back on. As it only occurred when running utorrent, I always felt it had to be utorrent related.

After turning Bandwidth Management off, I have gone two days now without a single drop in my internet connection, using the predefined settings for someone with an upload speed of 2.8 Mbit/s (minus Bandwidth Management of course). I'm willing to believe this has solved my problems, as I couldn't go an hour (many times, not even 5 minutes) without a disconnect previously, and it was driving me crazy.

I thought I'd go ahead and post as my situation doesn't involve a router.

Link to comment
Share on other sites

  • 3 weeks later...

I experimented and put dd-wrt on my router and that seems to have fixed downloading torrents with utp enabled but then I would notice periodically it would hose up and I would have to manually restart it (maybe it was overheating because of the strain of udp packets? I also switched it back to its original firmware after this). I still think you guys should have utorrent disable bandwidth management by default when you install it and for the people who have badass routers/servers they can enable it if they wish. When i think of utorrent, I think of a very lightweight torrent application designed to be used on older equipment but also have some new features that the tech-savvy can take advantage of.

Link to comment
Share on other sites

I have a pirelli DRG A225G firewall. It looks like uTorrent creates a lot of UDP flood message on the router (finally it blocks the IP):

03/07/2010 14:01:35 **UDP Flood Stop** (from PPPoE1 Outbound)

03/07/2010 14:01:34 **UDP flood**, 49424->>, 80 (from PPPoE1 Outbound)

03/07/2010 14:01:32 **UDP flood**, 44400->>, 49697 (from PPPoE1 Inbound)

03/07/2010 14:01:32 **UDP flood**, 13425->>, 49432 (from PPPoE1 Inbound)

03/07/2010 14:01:32 **UDP flood**, 16014->>, 49536 (from PPPoE1 Inbound)

03/07/2010 14:01:30 **UDP flood**, 52496->>, 49714 (from PPPoE1 Inbound)

03/07/2010 14:01:30 **UDP flood**, 48579->>, 49485 (from PPPoE1 Inbound)

03/07/2010 14:01:28 **UDP flood**, 49424->>, 44993 (from PPPoE1 Outbound)

03/07/2010 14:01:27 **UDP flood**, 49424->>, 25231 (from PPPoE1 Outbound)

03/07/2010 14:01:27 **UDP flood**, 49424->>, 41405 (from PPPoE1 Outbound)

03/07/2010 14:01:27 **UDP flood**, 49424->>, 53495 (from PPPoE1 Outbound)

03/07/2010 14:01:27 **UDP flood**, 49424->>, 42683 (from PPPoE1 Outbound)

03/07/2010 14:01:25 **UDP flood**, 49424->>, 30063 (from PPPoE1 Outbound)

03/07/2010 14:01:25 **UDP flood**, 49424->>, 16881 (from PPPoE1 Outbound)

03/07/2010 14:01:25 **UDP flood**, 58733->>, 49687 (from PPPoE1 Inbound)

03/07/2010 14:01:21 **UDP flood**, 49424->>, 12022 (from PPPoE1 Outbound)

<a lot more>

uTorrent 2.0 build 17920, XP SP2 Pro with tcpip patch


bt.transp_disposition is set to 5

I have no any idea how to solve it.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...