Jump to content

The dreaded RED dot - DHT waiting for announcement issue


Recommended Posts

I really hate having to start threads asking for help. Unfortunately I know just enough to usually get by, but right now I have no idea what I'm doing. I also don't understand what the hell is UDP, TCP, DHT etc so I'll apologize in advance.

I've used utorrent successfully for ages now but have found recently I'm getting issues. I haven't changed any settings recently either.

I use Comodo and have successfully set the rules for utorrent, which have been fine and never an issue.

I use a D-link DSL-502T modem and a DI-524 router and have forwarded my ports.

I have current updated versions of XP. I'm using utorrent 2.0.2

I have the red dot and my downloads are working albeit slowly. I have 150 kb/ps connection but my downloads bounce from nothing up to 20 kb/ps. However with only low connection numbers to seeds and peers.

I tried the 'test network' function earlier and it said my port was open BUT I still had the red dot. I've allowed Upnp which seems to have helped, still red though.

I recently picked myself up a new router/modem and still have the same issues.

Could it be utorrent itself?

Link to comment
Share on other sites

  • 4 months later...


I'm having a DHT 0 nodes issue.

I have deleted DHT.dat etc. from apps/utorrent

I have patched my tcpip.sys file

I have redone my rules for my firewall - Comodo

I have allowed UDP in my router

I have downloaded a torrent from open office.

And I'm still stuck.

I see that there's tonnes of threads around and never a true fix for this issue. Please someone help me.

Link to comment
Share on other sites

As switeck said, your isp could be to blame. try a level 3 or 4 protocol encryption.

For level 3 go to preferences of uTorrent and then the bittorrent tab

there should be an option to allow incoming legacy

Default should be checked, change it to unchecked for level 3

for level 4 change the outgoing (disabled, enabled or forced) to forced.

See if that helps. its possible your iSP is one of the really restrictive ones, use this link to find out for sure http://wiki.vuze.com/w/Bad_ISPs and if so this should help explain http://wiki.vuze.com/w/Avoid_traffic_shaping

At this point I am unaware of any way to set uTorrent to a level 5 protocol encryption. Hopefully one of the mods will know if this is possible. I'm still using 1.8.1 so I wouldn't be surprised if it has been added since then.

As far as DHT goes it doesn't really help tons in speeding up torrents, it merely allows them to continue without the use of a tracker. There shouldn't be a huge difference between on and off with normal torrents as long as all the users aren't disabling the tracker list.

If your isp is not on that list give this a try and see if there is any noticeable degradation in bittorrent communication. http://broadband.mpi-sws.org/transparency/bttest.php

Link to comment
Share on other sites

Thank you for your replies.

I tried a 'rollback' to 1.8.5 and did the port forward test to find my port is closed :( I have followed the port forward instructions to the letter , several times and still no dice. Not sure where to go from that happening.

My ISP is not on the list but I will try your ideas paintball9, thank you

Link to comment
Share on other sites

If you connect to even a single unfirewalled peer that has both DHT and Peer Exchange enabled on a public torrent, then in <5 minutes you should get plenty of peer/seed connections...if they really exist! (I am assuming you're unfirewalled for at least TCP peer/seed connections.)

Link to comment
Share on other sites

I really must apologize and say thanks for everyone's help.

I fixed this by simply updating to Comodo 4 and followed this simple set-up from Comodo forum

First off close Utorrent. Then open CIs and go to firewall at the top. Then look for something called "stealth port wizard", open it up and select the second setting " alert me to incoming..." and hit ok. Then open up utorrent and wait for the pop up from CIs asking if you want to allow an incoming connection, hit allow. There you go it should work just fine.

I have to say that I had the rules set up as mentioned on various threads for Comodo 3 and had never needed to change them - something must of changed somewhere for an issue to arise.

For anyone having issues like I have mentioned I strongly suggest you upgrade or totally remove Comodo (I had deactivated Comodo and still had issues - there is a Comodo clean up tool) so you can fix the problem. Link is here https://forums.comodo.com/empty-t36499.0.html

I have my green tick back and heaps of DHT nodes.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...