Jump to content

Almost all "d" flags and much faster upload than download


Recommended Posts

[Edit] Solved by itself after a week. Perhaps the Chinese ISP is experimenting with shaping torrent files. As of the last 48 hours, d/l speeds are back up to normal - fast :-)

FYI - I left everything alone as I suspected the ISP from the Glasnost reports. It cured itself.

I couldn't see a way to edit the title and it wouldn't allow me to repost - it said double posts are not allowed and I must edit my post!


Original message:



I have tried various setup options/speedtests etc.

Glasnost reports my Chinese ISP is throttling, but my friends down the road onthe same ISP have no problems and usual fast speeds. He hasn't tried glasnost, and is away for over a week.

Here is an image of the peer list.


You can see the upload speeds are far far higher than the download speeds. This torrent has been on for four days.

I am on a new ISP in a different part of the country. The only unknown is the Chinese ADSL modem, which looks old, and is firmware Chinese language. The same two laptops and wireless setup we had are unchanged.

So, is Glasnost 100% perfect at it's analysis - or could it be the ADSL modem and a setting in there. We are PPoE.

Thanks in advance to anyone who can help. I used to get full speed on torrents like this at my old place, so it's annoying and almost useless!


Link to comment
Share on other sites

Thanks for replying.

I'm not an expert at utorrent, but am competent with computers.

Utorrent has always been something that just works, so I have never used another program or got heavily into settings.

I've had my hardware at three locations. each with a different but similar looking Chinese router.

I always do the speed-test and set utorrent to the suggested settings as in the FAQ. I'm currently randomising each port, enabling UPnP and NAT-PMP port mapping with a windows firewall exception. I have the green tick to tell me port-forwarding is ok, as usual.

I'm running version 2.0 to see if it solves the problem, but my wife is running 1.8.5 and we have the same problem. This makes me think it's possibly the setting in a router. I suspect the ISP would cap/shape uploads as well as downloads.

For the first time, I'm enabling and/or forcing encryption with little success.

My computer experience goes back to the Amiga days, but only as a user. I've had to solve my fair share of problems over time but, as I said, utorrent just always worked so this is a new issue for me.

My own Chinese D-Link modem is screwed after I tried to reflash it with English language firmware (It worked with the Asus wireless router) and I'm not in a position to buy a new one this month. (Starting a new job next week.)

Again, thanks for replying and any pointers you can give would be much appreciated.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...