Jump to content

Uplink/Downlink speed limit still not working [2.0]


Recommended Posts

Hi guys,

The up and downlink speed limitation still not working in uTorrent 2.0, when the source is from a locally forwarded port.



There are plenty of people out there (as I am), who needs to use Putty and SSH acting proxies to get the torrent protocol working inside a NAT, corporate LAN etc.

When the SSH connection and the local port forward, and the utorrent setup done and "more clients from the same IP" option enabled, there are several peers on the peerlist, who seems to use the same IP (e.g. because of the active local portforward.

It seems that the active uplink and/or downlink speed limits are not applied to this type of peers (connected through the local portforward), and these peers can download/upload as fast as they can despite the restrictions.

I think these locally forwarded connections (utorrent sees the loopback address "" as the peer's source IP) can somehow pass the speed limiting part before they reach the protocol stack.

Anyway, this was an issue with previous versions, and in the current version, and it need to be fixed.

I reported this issue several months ago, so first of all, an acknowledge from the developers would be a great start.

I'am happy to help you with testing and further investigating this issue, so if you need help, just tell what to do.

Thanks anyway, the new uTP protocol is performing well on our high speed network nodes.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...