Jump to content

uTorrent constantly lagging


Recommended Posts

I've been having major problems with uTorrent constantly and consistently lagging for the past month or two. I'm not sure if it was directly due to an update or what, but I have been using this same program on the same computer for years without problems until recently.

Basically, it is always in a "Not responding..." state, then snaps out of it every 90 seconds or so and allows me to click on the GUI. Then it goes right back into that "Not responding" state again, over and over. It still downloads fine in the background, it's just that the GUI is unusable because of the terrible lag or whatever you want to call it. Even when trying to open the program up or exit out of it via the taskbar, it will take over a minute for anything to happen.

I have tried reinstalling, updating Java, deleting the files in %appdata%, exiting out of my antivirus/firewall software...nothing works, it's driving me crazy. Drove me to the point of downloading Deluge, which is a decent program, but I already miss uTorrent. I am running Windows Vista.

Any troubleshooting steps would be greatly appreciated. Like I said, I'm not sure if this is due to an update or not, but it very well may have been. I also do not recall making any changes to uTorrent or to my computer. I am not having problems with any other software, either.

Link to comment
Share on other sites

Funky. When you clear %appdata%\uTorrent, you do reconfigure everything from scratch afterwards, right? Does it happen even if you do minimal configuration (just selecting the proper upload rate and forwarding the port)?

a) get HijackThis from www.trendmicro.com, run it, view the log, and post the contents here

B) get Process Explorer from www.sysinternals.com, run it, Ctrl+D (to show the lower DLL pane), select the µTorrent process from the list, Ctrl+S (and save the list somewhere you'll find easily -- like the Desktop), then post the contents of the saved process list in the .txt file here

Link to comment
Share on other sites

Actually, I haven't even configured it since I reinstalled...that would take a very, very long time with the lag as I can only execute one "click" every 90 seconds or so on the GUI. But anyway, here are the logs:

Logfile of Trend Micro HijackThis v2.0.3 (BETA)

Scan saved at 10:45:28 AM, on 3/6/2010

Platform: Windows Vista SP1 (WinNT 6.00.1905)

MSIE: Internet Explorer v7.00 (7.00.6001.18385)

Boot mode: Normal

Running processes:




C:\Program Files\Microsoft Office\Office12\GrooveMonitor.exe

C:\Program Files\Microsoft Security Essentials\msseces.exe

C:\Program Files\COMODO\COMODO Internet Security\cfp.exe

C:\Program Files\iTunes\iTunesHelper.exe

C:\Program Files\Common Files\Java\Java Update\jusched.exe

C:\Program Files\Mozilla Firefox\firefox.exe

C:\Program Files\uTorrent\uTorrent.exe



C:\Program Files\TrendMicro\HiJackThis\HiJackThis.exe

R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://today.ask.com/dvdvideosoft?gcht=SC&o=13162&l=dis

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896

R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157

R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant =

R0 - HKLM\Software\Microsoft\Internet Explorer\Search,CustomizeSearch =

R1 - HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings,ProxyOverride = *.local

R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName =

O1 - Hosts: ::1 localhost

O2 - BHO: AcroIEHelperStub - {18DF081C-E8AD-4283-A596-FA578C2EBDC3} - C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelperShim.dll

O2 - BHO: AskBar BHO - {201f27d4-3704-41d6-89c1-aa35e39143ed} - C:\Program Files\AskBarDis\bar\bin\askBar.dll (file missing)

O2 - BHO: Groove GFS Browser Helper - {72853161-30C5-4D22-B7F9-0BBC1D38A37E} - C:\Program Files\Microsoft Office\Office12\GrooveShellExtensions.dll

O2 - BHO: Google Toolbar Notifier BHO - {AF69DE43-7D58-4638-B6FA-CE66B5AD205D} - C:\Program Files\Google\GoogleToolbarNotifier\5.1.1309.3572\swg.dll

O2 - BHO: Java Plug-In 2 SSV Helper - {DBC80044-A445-435b-BC74-9C25C1C588A9} - C:\Program Files\Java\jre6\bin\jp2ssv.dll

O3 - Toolbar: Ask Toolbar - {3041d03e-fd4b-44e0-b742-2d9b88305f98} - C:\Program Files\AskBarDis\bar\bin\askBar.dll (file missing)

O4 - HKLM\..\Run: [Windows Defender] %ProgramFiles%\Windows Defender\MSASCui.exe -hide

O4 - HKLM\..\Run: [GrooveMonitor] "C:\Program Files\Microsoft Office\Office12\GrooveMonitor.exe"

O4 - HKLM\..\Run: [MSSE] "C:\Program Files\Microsoft Security Essentials\msseces.exe" -hide

O4 - HKLM\..\Run: [COMODO Internet Security] "C:\Program Files\COMODO\COMODO Internet Security\cfp.exe" -h

O4 - HKLM\..\Run: [iTunesHelper] "C:\Program Files\iTunes\iTunesHelper.exe"

O4 - HKLM\..\Run: [sunJavaUpdateSched] "C:\Program Files\Common Files\Java\Java Update\jusched.exe"

O4 - HKUS\S-1-5-19\..\Run: [sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /detectMem (User 'LOCAL SERVICE')

O4 - HKUS\S-1-5-19\..\Run: [WindowsWelcomeCenter] rundll32.exe oobefldr.dll,ShowWelcomeCenter (User 'LOCAL SERVICE')

O4 - HKUS\S-1-5-20\..\Run: [sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /detectMem (User 'NETWORK SERVICE')

O8 - Extra context menu item: Add to Google Photos Screensa&ver - res://C:\Windows\system32\GPhotos.scr/200

O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~2\Office12\EXCEL.EXE/3000

O9 - Extra button: Send to OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\PROGRA~1\MICROS~2\Office12\ONBttnIE.dll

O9 - Extra 'Tools' menuitem: S&end to OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\PROGRA~1\MICROS~2\Office12\ONBttnIE.dll

O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - C:\PROGRA~1\MICROS~2\Office12\REFIEBAR.DLL

O13 - Gopher Prefix:

O18 - Protocol: grooveLocalGWS - {88FED34C-F0CA-4636-A375-3CB6248B04CD} - C:\Program Files\Microsoft Office\Office12\GrooveSystemServices.dll

O18 - Protocol: skype4com - {FFC8B962-9B40-4DFF-9458-1830C7DD7F5D} - C:\PROGRA~1\COMMON~1\Skype\SKYPE4~1.DLL

O20 - AppInit_DLLs: C:\Windows\system32\guard32.dll

O22 - SharedTaskScheduler: Component Categories cache daemon - {8C7461EF-2B13-11d2-BE35-3078302C2030} - C:\Windows\system32\browseui.dll

O23 - Service: Ati External Event Utility - ATI Technologies Inc. - C:\Windows\system32\Ati2evxx.exe

O23 - Service: COMODO Internet Security Helper Service (cmdAgent) - COMODO - C:\Program Files\COMODO\COMODO Internet Security\cmdagent.exe

O23 - Service: Google Software Updater (gusvc) - Google - C:\Program Files\Google\Common\Google Updater\GoogleUpdaterService.exe

O23 - Service: iPod Service - Apple Inc. - C:\Program Files\iPod\bin\iPodService.exe


End of file - 5141 bytes

Process PID CPU Description Company Name

System Idle Process 0 88.22

Interrupts n/a 1.47 Hardware Interrupts

DPCs n/a 1.47 Deferred Procedure Calls

System 4

smss.exe 432

csrss.exe 500

wininit.exe 556

services.exe 636

svchost.exe 836

svchost.exe 896

cmdagent.exe 940

svchost.exe 1052

MsMpEng.exe 1164

Ati2evxx.exe 1252

Ati2evxx.exe 1616

svchost.exe 1292

audiodg.exe 1452

svchost.exe 1344

dwm.exe 652 Desktop Window Manager Microsoft Corporation

WUDFHost.exe 2388

svchost.exe 1360

taskeng.exe 700 Task Scheduler Engine Microsoft Corporation

taskeng.exe 3736

wuauclt.exe 2440 Windows Update Microsoft Corporation

SLsvc.exe 1480

svchost.exe 1520

spoolsv.exe 1816

svchost.exe 1844

svchost.exe 804

svchost.exe 1028

svchost.exe 2156

SearchIndexer.exe 2184

SearchProtocolHost.exe 3224

SearchFilterHost.exe 328

iPodService.exe 4068

TrustedInstaller.exe 3632

lsass.exe 648

lsm.exe 656

csrss.exe 564

winlogon.exe 600

explorer.exe 1200 Windows Explorer Microsoft Corporation

GrooveMonitor.exe 1944 GrooveMonitor Utility Microsoft Corporation

msseces.exe 1076 Microsoft Security Essentials User Interface Microsoft Corporation

cfp.exe 1928 COMODO Internet Security COMODO

iTunesHelper.exe 256 iTunesHelper Apple Inc.

jusched.exe 456 Java Update Scheduler Sun Microsystems, Inc.

firefox.exe 3264 5.88 Firefox Mozilla Corporation

procexp(3).exe 3204 1.47 Sysinternals Process Explorer Sysinternals - www.sysinternals.com

uTorrent.exe 2280 1.47 µTorrent BitTorrent, Inc.

Process: uTorrent.exe Pid: 2280

Name Description Company Name Version

ADVAPI32.dll Advanced Windows 32 Base API Microsoft Corporation 6.0.6001.18000

CLBCatQ.DLL COM+ Configuration Catalog Microsoft Corporation 2001.12.6931.18000

COMCTL32.dll User Experience Controls Library Microsoft Corporation 6.10.6001.18000

comdlg32.dll Common Dialogs DLL Microsoft Corporation 6.0.6001.18000

credssp.dll TS Single Sign On Security Package Microsoft Corporation 6.0.6001.18000

CRYPT32.dll Crypto API32 Microsoft Corporation 6.0.6001.18000

dhcpcsvc.DLL DHCP Client Service Microsoft Corporation 6.0.6001.18000

dhcpcsvc6.DLL DHCPv6 Client Microsoft Corporation 6.0.6001.18000

DnsApi.dll DNS Client API DLL Microsoft Corporation 6.0.6001.18000

FirewallAPI.dll Windows Firewall API Microsoft Corporation 6.0.6001.18000

fltlib.dll Filter Library Microsoft Corporation 6.0.6000.16386

GDI32.dll GDI Client DLL Microsoft Corporation 6.0.6001.18159

guard32.dll COMODO Internet Security COMODO 3.14.64351.586

iertutil.dll Run time utility for Internet Explorer Microsoft Corporation 7.0.6001.18385

IMM32.DLL Multi-User Windows IMM32 API Client DLL Microsoft Corporation 6.0.6001.18000




Iphlpapi.dll IP Helper API Microsoft Corporation 6.0.6001.18000

kernel32.dll Windows NT BASE API Client DLL Microsoft Corporation 6.0.6001.18215

kernel32.dll.mui Windows NT BASE API Client DLL Microsoft Corporation 6.0.6001.18000



LPK.DLL Language Pack Microsoft Corporation 6.0.6001.18000

mdnsNSP.dll Bonjour Namespace Provider Apple Inc.

MSASN1.dll ASN.1 Runtime APIs Microsoft Corporation 6.0.6001.18326

MSCTF.dll MSCTF Server DLL Microsoft Corporation 6.0.6001.18000

msctf.dll.mui MSCTF Server DLL Microsoft Corporation 6.0.6000.16386

msvcrt.dll Windows NT CRT DLL Microsoft Corporation 7.0.6001.18000

mswsock.dll Microsoft Windows Sockets 2.0 Service Provider Microsoft Corporation 6.0.6001.18000

napinsp.dll E-mail Naming Shim Provider Microsoft Corporation 6.0.6001.18000

NETAPI32.dll Net Win32 API DLL Microsoft Corporation 6.0.6001.18157

NLAapi.dll Network Location Awareness 2 Microsoft Corporation 6.0.6001.18000

Normaliz.dll Unicode Normalization DLL Microsoft Corporation 6.0.6000.16386

npmproxy.dll Network List Manager Proxy Microsoft Corporation 6.0.6000.16386

NSI.dll NSI User-mode interface DLL Microsoft Corporation 6.0.6001.18000

ntdll.dll NT Layer DLL Microsoft Corporation 6.0.6001.18000

NTMARTA.DLL Windows NT MARTA provider Microsoft Corporation 6.0.6001.18000

ole32.dll Microsoft OLE for Windows Microsoft Corporation 6.0.6001.18000

OLEACC.dll Active Accessibility Core Component Microsoft Corporation 4.2.5406.0

oleaccrc.dll Active Accessibility Resource DLL Microsoft Corporation 4.2.5406.0

oleaut32.dll Microsoft Corporation 6.0.6001.18000

pnrpnsp.dll PNRP Name Space Provider Microsoft Corporation 6.0.6001.18000

PSAPI.DLL Process Status Helper Microsoft Corporation 6.0.6000.16386


rasadhlp.dll Remote Access AutoDial Helper Microsoft Corporation 6.0.6000.16386

RASAPI32.dll Remote Access API Microsoft Corporation 6.0.6001.18000

rasman.dll Remote Access Connection Manager Microsoft Corporation 6.0.6001.18000

RPCRT4.dll Remote Procedure Call Runtime Microsoft Corporation 6.0.6001.18247

rsaenh.dll Microsoft Enhanced Cryptographic Provider Microsoft Corporation 6.0.6001.18000

rtutils.dll Routing Utilities Microsoft Corporation 6.0.6000.16386

SAMLIB.dll SAM Library DLL Microsoft Corporation 6.0.6001.18000

schannel.dll TLS / SSL Security Provider Microsoft Corporation 6.0.6001.18272

Secur32.dll Security Support Provider Interface Microsoft Corporation 6.0.6001.18272

sensapi.dll SENS Connectivity API DLL Microsoft Corporation 6.0.6000.16386

SHELL32.dll Windows Shell Common Dll Microsoft Corporation 6.0.6001.18167

shfolder.dll Shell Folder Service Microsoft Corporation 6.0.6000.16386

SHLWAPI.dll Shell Light-weight Utility Library Microsoft Corporation 6.0.6001.18000

TAPI32.dll Microsoft® Windows Telephony API Client DLL Microsoft Corporation 6.0.6000.16386

urlmon.dll OLE32 Extensions for Win32 Microsoft Corporation 7.0.6001.18385

USER32.dll Multi-User Windows USER API Client DLL Microsoft Corporation 6.0.6001.18000

USERENV.dll Userenv Microsoft Corporation 6.0.6001.18000

USP10.dll Uniscribe Unicode script processor Microsoft Corporation 1.626.6001.18000

uTorrent.exe µTorrent BitTorrent, Inc.

uxtheme.dll Microsoft UxTheme Library Microsoft Corporation 6.0.6001.18000

VERSION.dll Version Checking and File Installation Libraries Microsoft Corporation 6.0.6001.18000

wininet.dll Internet Extensions for Win32 Microsoft Corporation 7.0.6001.18385

WINMM.dll MCI API DLL Microsoft Corporation 6.0.6001.18000

WINNSI.DLL Network Store Information RPC interface Microsoft Corporation 6.0.6001.18000

winrnr.dll LDAP RnR Provider DLL Microsoft Corporation 6.0.6000.16386

WLDAP32.dll Win32 LDAP API DLL Microsoft Corporation 6.0.6001.18000

WS2_32.dll Windows Socket 2.0 32-Bit DLL Microsoft Corporation 6.0.6001.18000

wship6.dll Winsock2 Helper DLL (TL/IPv6) Microsoft Corporation 6.0.6001.18000

wshtcpip.dll Winsock2 Helper DLL (TL/IPv4) Microsoft Corporation 6.0.6001.18000

Link to comment
Share on other sites

I don't see anything obviously wrong with these lists... :S

When µTorrent hangs, does its CPU usage increase? Are you sure you set up the COMODO rules properly? That is, can you try removing the rules for µTorrent and recreating them? Are you using Defense+ in COMODO?

Link to comment
Share on other sites

I don't think that its CPU usage increases....

I'm not really sure how to set up the COMODO rules...but I am using defense+...both Defense+ and the Firewall are in "Safe mode" for the security level. The thing is, I figured that I eliminated the problem being Comodo since the same thing happens with uTorrent whether or not I have Comodo (or MSE) running in the background. I have tried closing uTorrent, closing bother Comodo and MSE, then opening uTorrent and the same type of thing happens...

Link to comment
Share on other sites

Well I did the Comodo configurations...no difference though.

I also tried reinstalling again...this time I ran CCleaner after again deleting the appdata, reinstalled, and still the same thing. One thing I noticed though, if this may be of help, is that the program only freezes up when there's a torrent loaded. If I remove the torrent and restart the program, the GUI works fine, there are no problems. It is only shortly after a torrent is loaded onto uTorrent.

Link to comment
Share on other sites

Yes, it has happened with dozens of files. I just tried the slackware, with no torrents loaded...what happens is that it works fine for about 30 seconds, I can see everything updating (seeds, peers, download speed, eta, etc.) normally and then about 30 seconds in it just stops (which obviously tells me it has frozen), and if I try to click anything it will say "Not responding".

I had the "General" tab selected always, so just in case, I switched to "Trackers" and the same thing. And like I said, every 90-120 seconds, it will snap out of it very briefly, and show updated data (i.e. the percent completion will jump from 9% to 22% to 35% and so on, basically showing where it is currently at when it "unfreezes" and the big jumps are a result of the lag in between). It's weird that it happens about 30 seconds after opening any torrent file..if no torrent is loaded in the program, it responds perfectly well.

What I have to do to remove torrents from the program is ctrl+alt+delete and use the task manager to shut down uTorrent. Then, I open it back up, get that 30 second window to use the GUI before it freezes up, and remove it during that window. After it's removed, the GUI is usable again.

Link to comment
Share on other sites

Reading your first post, I was thinking "wow, this guy took my exact problem and wrote it down". I think there is some sort of conflict with the new version of utorrent, or some windows update is wreaking havoc. I've read a lot of threads with people having speed/lag issues out of the blue, starting apx 1-2 months ago.

Link to comment
Share on other sites

Hmmm interesting. I'll get a hold of an earlier version (1.9 or something) and see if that solves the problems with the current installment. I'll let you know as soon as I try it.


Well, I guess it's my PC. Tried 1.9 first, same thing. Went all the way back to 1.7...same thing. It's really frustrating to just admit defeat and let this go...but I cannot spend any more time trying to figure this out. I tried out Azureus/Vuze, takes up about 65 MB downloading...ridiculous. Tried Deluge, a little better, less than half of Vuze but still, about double what I would get with uTorrent. Ahh well, now I gotta figure out how the hell to get Firefox to recognize Deluge as a valid application...the fun never ends.

Link to comment
Share on other sites

  • 1 month later...

I wanted to update this post as I was having the identical problem as this thread describes. The quick and dirty fix is once I disabled DHT everything worked properly again. I will list my system details and config so hopefully the internal reason for this bug is discovered.

Fresh install of Windows XP Pro SP3 + All available Windows updates up to right now (4/8/2010)

uTorrent 2.0 (Build 18934)

Dell Optiplex SX260

Intel Pentium 4 2.00 GHz


Intel Onboard Video + NIC

My computer is behind an ISA 2004 Firewall and is running the Microsoft Firewall Client for ISA Server

I have created a Port Forward Rule on the server

Settings I have changed that Differ from a default installtion:

Preferences -> Connection -> Enable UPnP port mapping = Unchecked

Preferences -> Connection -> Enable NAT-PMP port mapping = Unchecked

Preferences -> Connection -> Randomize port each start = Unchecked (My opened port is in the port field)

Preferences -> Connection -> Proxy Server Type = Socks5 (My server and port are in the text fields)

Preferences -> Connection -> Authentication = Checked (My username and password are in the text fields)

Preferences -> Connection -> Resolve hostnames through proxy = Checked

Preferences -> Connection -> Use proxy server for peer-to-peer connections = Checked

Preferences -> BitTorrent -> Enable DHT Network = Unchecked

Preferences -> BitTorrent -> Protocol Encryption = Enabled

Preferences -> BitTorrent -> Allow incoming legacy connections = Checked

I hope this helps to find a solution to the problem so I can use DHT once again. Enabling DHT instantly brings back the lag issues described in this thread.

Link to comment
Share on other sites

  • 2 weeks later...

If it is not necessarily a bug but a limitation of UDP packets (or something else) then it should at least fail gracefully when a connection cannot be made. As of right now it makes uTorrent unusable in the above scenarios.

Perhaps this thread can be moved to the "Found Bugs" forum?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...