Jump to content

Zero download speed


Recommended Posts

Help! After a week of endless problems with COMODO on my Win XP SP3 box, I bit the bullet and replaced COMODO. After plenty of frustrations with various firewalls, I am now running Agnitum's Outpost Free. COMODO's better (when it works) but this will have to do until COMODO fix their bugs. Trouble is that I am not getting any down speed. Up speed is max'ed out and good. But zippo down.

Here's my current setup:

Manual port forwarding in router. (No reason to believe it is not working. No entries in router firewall log. If I kill off uTorrent, plenty of splutters from Outpost which is still being hit by incoming requests on [myPort]. Looks ok.)

Windows Firewall OFF, Outpost ON.

In Outpost, I use the following (handcrafted) rules:

1 Allow Outbound UDP (all ports)

2 Allow Outbound TCP (all ports)

3 Allow Inbound UDP to 1024-65535 (*) - this range comprises [myPort]

4 Allow Inbound TCP to [myPort]

5 Block all UDP

6 Block all TCP

Now 5+6 are just for entertainment. They force pop-ups but I never see any (while uTorrent is active). (Outpost processes rules top-to-bottom and bails on first match.) Outbound to DNS, HTTP and HTTPS should all be covered by 1+2.

There's also a couple of global rules, mostly "Allow"s and the "Block"s all produce pop-ups.

There is no indication from Outpost of any security violations. Traffic seems well within the parameters of these rules. And yet...

When I click on the GREEN traffic icon in uTorrent to bring up the Setup Guide and run the Bandwidth test, I get (good Upload speed) and ZERO Download speed (which just confirms why I am seeing zero downspeed on my 1 current active download).

EDIT: Found out why the Speed Test is failing: I set Outgoing Encryption to "forced". It would seem that the corresponding testing server cannot handle that. Hence the failure. I am now seeing good results in the Setup but am still not actually receiving anything on my download. Trying OpenOffice now...

Where, please, am I going wrong?


(*) Is the uTorrent manual up to date on this? I set out to implement 1024-5000 but, boy, I just got hammered with pop-ups on ports > 5000.

Link to comment
Share on other sites

Yeah, set off OpenOffice before I went to bed. Nothing overnight. When I look into my Belkin router's firewall log this morning, I see this stuff:

03/13/2010 08:31:00 **UDP Flood Stop** (from ATM1 Outbound)

03/13/2010 08:31:00 **UDP flood**, 60051->>, 10552 (from ATM1 Inbound)

03/13/2010 08:30:59 **UDP flood**, 13887->>, 10552 (from ATM1 Inbound)

03/13/2010 08:30:59 **UDP flood**, 12333->>, 10552 (from ATM1 Inbound)

03/13/2010 08:30:58 **UDP flood**, 36541->>, 10552 (from ATM1 Inbound)

03/13/2010 08:30:58 **UDP flood**, 6881->>, 10552 (from ATM1 Inbound)

03/13/2010 08:30:58 **UDP flood**, 24929->>, 10552 (from ATM1 Inbound)

03/13/2010 08:30:58 **UDP flood**, 34869->>, 10552 (from ATM1 Inbound)

03/13/2010 08:30:58 **UDP flood**, 14998->>, 10552 (from ATM1 Inbound)

03/13/2010 08:30:58 **UDP flood**, 10552->>, 22023 (from ATM1 Outbound)

03/13/2010 08:30:58 **UDP flood**, 6881->>, 10552 (from ATM1 Inbound)

10552 is [myPort]. It looks to me as though the router has problems forwarding UDP packets to 10552. It's just that there aren't any corresponding messages from Outpost on All is quiet.

Any idea?

Link to comment
Share on other sites

Darned. (Should really have thought of this to try by myself...) Yes, this appears to remove the road-block. uTorrent now sucking stuff down full pelt. Any idea what's going on? According to port-forwarding instructions (for my Belkin router) navigated to via this site, all that's apparently necessary for manual port forwarding to work is to add one Virtual Server like so:

Description In Port Type Private IP Private Port

uTorrent 10552 TCP&UDP 10552

Seemed simple enough.

I learned most about uTorrent's port requirements from the COMODO section here: http://forum.utorrent.com/viewtopic.php?id=7862. And what intrigues most is COMODO Rule #3:

Action ............ : Allow

Protocol .......... : UDP

Direction ......... : In

Description ....... : Ephemeral Ports [iN] (UDP)

Source Address .... : Any

Destination Address : Any

Source Port ....... : Any

Destination Port .. : (A Port Range) 1024 - 5000

Late yesterday, I added a new rule to Outpost just like so:

2.5 Allow Inbound UDP to [myPort].

Outpost always reports the one rule that applies for any given traffic. Since I moved the new UDP rule on top, I only ever see

Allow Inbound UDP to [myPort]

and never anymore see

3 Allow Inbound UDP to 1024-65535

which used to flash up before all the time. This suggests to me that I only need to open UDP for [myPort] and nothing else. Is this correct? Begs the question, of course, why, given that I had punched a hole for [myPort] into Belkin's firewall, this traffic doesn't pass through. Mind, this latter statement is inaccurate anyway. Belkin DOES appear to have passed on this traffic because I saw the

Allow Inbound UDP to [myPort]

flashing across Outpost even BEFORE I disabled Belkin's firewall.

There's clearly some traffic going on here that I do not understand. Any suggestions?


Link to comment
Share on other sites

Don't worry about the Belkin firewall being off, since it's a retarded pos it doesn't matter anyway, NAT does plenty already to protect you.

I'm pretty sure the Comodo rule is a typo, if you look at the other firewall rules they don't match, and your listening port is the only port a peer should try to contact you (unless you had previously used another port and recently switched).

Link to comment
Share on other sites

Thanks for the confirmation. I've been working on these rules for some time now. I notice that when I lock down inbound UDP to [myPort] only, I do get the odd block for 6771 and 5351. 6771 is some multicast on the LAN according to http://forum.utorrent.com/viewtopic.php?id=37962 which seems a bit of a waste of time since there are guaranteed not to be any other peers doing file sharing (so where's the packet even coming from? myself sending to myself?). 5351 is UPnP, I think, and I am little unclear why I get these coming IN. There's also some inbound traffic occasionally on 1900. Not sure what that's all about. So on balance, an inbound UDP rule for ports 1900, 5351-53, 6771 and [myPort] should cover all bases.

Unfortunately, if anything, my problems are getting worse, not better. Any thoughts on this


I have just turned off Outpost (running ONLY Windows) and I turned off the Resident Shield in AVG 9. I have ZERO peers talking to me. Next step, will uninstall AVG. There's no mention on this forum of any incompatibilities but uTorrent is simply not breathing at all.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...