Jump to content

Noddy question re new torrent


Recommended Posts

Hi, I just created a new torrent, stuck the OBT on as a tracker, uploaded it on a popular index site, stuck it into Forced Seed, got a scrape of 1/0, went to the index site and downloaded it into Opera, Opera does the pre-download file check, gets to 100% now sits there, doing nothing. Any idea why Opera and uTorrent fail to hook up? Thanks.

Link to comment
Share on other sites

No - Opera is trying to pull (it sits at 0% d/l after the successful initial file check), uTorrent is supposed to be pushing. The scrape is 0(1)/0(9) at the mo - there's other folks trying to pull. Thanks.

EDIT #1: Forget it - looks like we've got action. Not sure why it took 15 mins but them two are rolling at last. Cheers.

EDIT #2: Actually, don't forget it. So I successfully manage to talk to myself. Great. Why am I not talking to the other 8 dudes? Looks a little suspect...

EDIT #3: Scrapes at (0)2/(0)24. Quick, DreadWingKnight, help!! BTW, I allocated "High" bandwidth to the torrent. Good thing, no?

EDIT #4: Could of course be that, per chance, all those 20 people queuing are in my ipconfig.dat. Not likely, but possible I suppose...

Link to comment
Share on other sites

Those could all be fake/dead/firewalled ips that you can't really connect to.

Fact they've increased yet you've connected to none...hints to that.

Did you try enabling logging (right-click in window) in the Logger window/tab?

Maybe at least see if uTorrent is even TRYING to make outgoing connections or getting any incoming connections.

Lastly, try 1st and 2nd links in my signature.

Link to comment
Share on other sites

Alright, Switeck. I shall leave it to run overnight and investigate some more tomorrow. Cheers.

Update #1:

Still no bites. I see lots of these...

[2010-03-22 11:42:53] Incoming connection from for torrent 'UNKNOWN'

Is this the normal noise?

Link to comment
Share on other sites

Not sure what's up, Switeck. I restarted the Opera download some 7 hours ago (*) - Opera still has not managed to hook up with uTorrent. The index site shows 1 seed - which is good, coz that's me. My scrape shows 17 peers but no-one's hooking up (**). Unfortunately, Ultima's Troubleshooting guide does not concern itself with initial seeding and your Speed Guide I implemented many moons ago. (Things have been going well since I disabled DHT a few days ago.) Any other ideas?

(*) I suspended Opera after the (ultimately) successful initial handshake.

(**) There is no evidence of any connection attempt in the logger window (but that only covers 1hr or so). uTorrent is meanwhile uploading tons of other stuff.

Link to comment
Share on other sites

Opera's been sitting there for 2 days not finding my seed. It doesn't even manage a scrape - always shows 0 seeds / 1 peer. (It download OpenOffice alright.) The index site sees at least the seed right - it sees me, 1 seed. It reports only 1 peer, whereas my uTorrent scrapes 1 seed and 10 peers - none connecting. What have I done wrong in configuring this torrent?

Link to comment
Share on other sites

I don't know what the rest of uTorrent is doing. If it's at or close to global max connections, your extra torrent may get ignored.

I don't know your line speeds (down AND up), or uTorrent's settings...some combos can cause it to sit dumb and do nothing for days.

Link to comment
Share on other sites

Here's a quick snap of my torrent:


uTorrent correctly shows it as "Initial-Seeding". The main panel also gives the impression that there are 7 peers out there. Interestingly, the tracker panel shows no peers at all. Since DHT is disabled, that would imply that those 7 peers connected via PEX.

Why am I not uploading?

The Logger tab shows these unfamiliar entries:

[2010-03-27 09:43:37] IO Error:1168 line:395 align:-99 pos:-99 count:51712 actual:47104

[2010-03-27 09:43:37] ReadFile error: Cover\Thumbs.db:0:51712:263546:3

The last error is interesting. It stands to reason, since no such file exists in my entire torrent catalogue. Any chance of figuring out what prompted that message?

Link to comment
Share on other sites

that last message indicates that there's a thumbs.db in the torrent but not in the folder.

Went thru all my catalogue and found the offending torrent. I had apparently (and sensibly) decided not to download the Cover directory but since that makes uTorrent burp ... downloading it now.

As for your issue, are you trying to test this with two clients from behind the same router?

Yes ... originally ... though I looked at Opera as the client and uTorrent as the server. Downloading (in Opera) worked ONCE and never again. I have since killed the Opera experiment and uTorrent is the only p2p program running. There's just no action. Mind, at the moment uTorrent reports zero peers, so that would at least justify the inactivity. I was more bewildered recently when uTorrent reported 7 peers and there was no uploading. To date, I have never once managed to seed a new torrent. And it's supposed to be so easy...

Why isn't he using a http tracker for that torrent?

I asked myself the same question. But a more detailed look at the Properties of the torrent resolves the mystery: OBT has taken it upon itself to generate a tracker entry like so





and uTorrent does not report the fall-backs unless it uses them, I think. (I did wonder though whether Opera supports UDP trackers. Mind, I would guess that, if not, it would use the HTTP fall-back and still find to me, no?)

Given the discrepancy between the #peers reported by uTorrent v those reported by OBT, I was led to conclude that 6 peers must have found me via PEX.

Link to comment
Share on other sites

And here's tonight's picture:


Can someone please tell me what I have to do to make this torrent upload to those 13 peers? Also, is there anyway of finding out whether these 13 peers are real? And how they might have found me? What logging to I have to enable? What am I looking for?


PS: I re-downloaded the torrent from the tracker - no change.

Link to comment
Share on other sites

  • 2 weeks later...

Those trackers are trying to throw off anti-p2p groups by putting in random IP:port combinations in announce responses.

I know these are words chosen from an English dictionary but ... what might they mean? That OBT is pretending to me that there are 12 peers when there aren't? How does this help in the fight against anti-p2p groups?

I was trying with both clients from behind the same internet connection. It worked once only, and never again. I have since given up. My question remains unanswered: Is there an easy test that I could carry out to test uTorrent's readiness to upload?

NEWS FLASH: Just restarted uTorrent (doing some maintenance on the box) and a couple of peers have now connected. So it does appear to be working. Eureka!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...