Jump to content

PC reboots very often


DavidGGG

Recommended Posts

I've been running this constellation for years without problems: uTorrent, eMule, Firefox, Opera, VPN, Avira, Spyware Terminator, Kerio firewall v2.1.5, Netlimiter 2 Pro, VPNetMon, all on Win XP. But since yesterday, if I start all of the above, the PC crasches and reboots, at least once per hour. Before the crash, uT and eM are up at decent speeds (uT 300kB/s up&down, eM 100).

I tried shutting down the real time shields of Avira and ST, and running without VPNetMon, but it didn't help. I also tried lowering speed to 100kB/s up&down for uT (to make sure it wasn't my PC getting overheated) but that didn't help either. What did help was to shut down uT. Has been running for 30 hours now, so it's definitely uT related.

One thing has happened to my PC lately (after the last time I could run uT without these crashes): I did a Windows Update (I don't use automatic updates, instead I allow updates with a few months interval). Also, after that update, there was an annoyance with svchost accessing Akami sites which made me frustrated until I found out it was "background intelligent transfer service" that did this, so I disabled it (it's mainly used for windows update anyway, so I don't need it on). At the same time I also disabled the service "webclient" since it sounded like something I'd prefer to have shut down. Because of this, I'm wondering if uT relies on any of these services, so that it might explain the crashes? Other services of possible interest which are disabled: net.tcp, network DDE, Routing and remote access, Telnet, windows user mode drivers. (Note: most of these are disabled by default, and I also disabled a bunch of the real security holes way back, like remote registry)

Can't think of anything else that's new on my PC lately, besides that I installed Adobe Reader and a few weeks back there was a new version of uT that was automatically installed.

Update - I tried 3 more things:

- Tried running all of the programs above including uT but with all torrents stopped. Ran it for 2½ hours, did not crash.

- Then tried installing the previous version of uT (v1.8.5) and started it with all torrents. It crashed my PC after less than 3 minutes.

- Then re-enabled the 3 services "Webclient", "windows user mode driver framework", and "routing and remote access", and then started the P2P programs including uT. uT crashed my PC to reboot after 2½ minutes.

My best guess right now is that the latest updates of Windows caused this and that I just can't use uTurrent anymore..... :(

Link to comment
Share on other sites

Sounds lika a useful tool - I know where to find system dumps but I've never been able to read them. There is no visible blue screen, it just reboots, but Bluescreen View in mode "Blue screen in XP style" says:

---

A problem has been detected and Windows has been shut down to prevent damage to your computer.

The problem seems to be caused by the following file: tcpip.sys

SYSTEM_THREAD_EXCEPTION_NOT_HANDLED

If this is the first time you've seen this stop error screen, restart your computer. If this screen appears again, follow

these steps:

Check to make sure any new hardware or software is properly installed. If this is a new installation, ask your hardware or software manufacturer for any Windows updates you might need.

If problems continue, disable or remove any newly installed hardware or software. Disable BIOS memory options such as caching or shadowing. If you need to use safe mode to remove or disable components, restart your computer, press F8 to select Advanced Startup Options, and then select Safe Mode.

Technical Information:

*** STOP: 0x1000007e (0xc0000005, 0xf3bda448, 0xf7cbab34, 0xf7cba830)

*** tcpip.sys - Address 0xf3bda448 base at 0xf3bd7000 DateStamp 0x485b99ad

--- End of log ---

Update: I thought I'd re-run the LVLLORD patch since I think it changes tcpip.sys. I had the latest version (v2.23d) since long and I've used it before. To my surprise I get a pop-up error message "Reference (handle) is incorrect".

Link to comment
Share on other sites

The network adapter is on the motherboard of my old PC (Dell OptiPlex GX240); from clicking in Windows in network connections it seems to be a "3Com 3C920 Integrated Fast Ethernet Controller (3C905C-TX Compatible)". The security SW I already mentioned: Latest (of course) Avira and Spyware Terminator (and as I said I tried disabling their real time shields), and the free firewall Kerio 2.1.5. Have had this setup for years.

Update: The LVLLORD patch is working ok, I just had to turn the real-time protection off in Spyware Terminator, I forgot ST protects tcpip.sys from changes.

And apparently someone else had the same issues 1½ months ago: http://www.techspot.com/vb/topic143029.html

And possibly also here: http://forums.whirlpool.net.au/forum-replies-archive.cfm/1039730.html since it says utorrent in the log of the cause. (I don't have any interesting events to report prior to the crash though.)

Link to comment
Share on other sites

Yeah well, all security apps (including the biggest & best ones like Norton and Kaspersky) are known to have caused loads of severe problems for bunches of platforms and apps. I've used Kerio for years, it has never caused any problems, and firewalls aren't very prone to becoming outdated. The only respect in which it's not up-to-date is that it can't handle IPv6 very well, which is no big problem for me yet.

I tried some more things:

- Enabling "background intelligent transfer service" - still crashes (this means I've tries enabling all services I disabled after the windows update)

- Changed max conn with LVLLORD from 50 to 1000, uT is set to max 200 and eM to max 24 - still crashes

- Tried with Kerio disabled - still crashes

- At the moment I'm trying to download the torrents 1 or 2 at a time (the rest stopped), seems like this might work so far, but it's no real solution

Update:

I've solved the problem for now by switching to another torrent program (Deluge), which has worked fine now at full speed for over 24h. uT is slighly better (Deluge is like a slightly scaled-down uT but despite that it uses significantly more CPU :( ) but I can't live with the constant crashes.. I'll check back in a few days to see if anyone has any good tips, and if more people are having this problem. To me it seems I shouldn't have updated windows... Thanks for your efforts.

Link to comment
Share on other sites

I have EXACTLY the same problem.

BSOD with 0x07 (0xc0000005, 0xf3bda448, 0xf7cbab34, 0xf7cba830) tcpip.sys

If I start more than 1 torrent to download..utorrent latest ver crashed my PC form yestreday.

PC crach after aprox 5min with this BSOD!

I have all win update have not any antivirus,but have Windows firewall.

What can I do?

Link to comment
Share on other sites

A lot of people here on these forums have the same problem.

I have this problem for over a year now. First (twice) on Vista and now on a clean Windows 7 64bit install. I have no ralink (wireless) Ethernet connection as I seen a few other people have on this forums. I just use a gigabit line from my Asus motherboard and have been using torrents on it since I bought it January 2008.

Computer freezes only when uTorrent is running, sometimes with a bluescreen... other times just a "normal" freeze. BlueScreenViewer gives these two errors:

PFN_LIST_CORRUPT and IRQL_NOT_LESS_OR_EQUAL

I won't upload an whole registry or hijackthis list, since this is a clean Windows 7 install (ultimate) with only windows update and the latest Nvidia driver. No firewalls OR anti virus programs running, nor have I ever had one.

Link to comment
Share on other sites

PFN_LIST_CORRUPT is normally to with memory issues. Either the physical ram or when using virtual memory on the hard disk.

Normal remedy is to first unseat/reseat the memory on the motherboard. If the problem exists and its not flakey memory sticks, you should start looking at swap files/virtual memory/similar hard disk related stuff.

Link to comment
Share on other sites

Nice to at least know there are more than me with similar problems. Not nice but.. nice not to be alone with it.

I actually tried uninstalling the firewall. It was no prime suspect of mine, and uninstalling/reinstalling firewalls also is begging for trouble so I don't want to do it if I can avoid it. But when I looked through all minidumps, most were tcpip.sys but some were fwdrv.sys "DRIVER_IRQL_NOT_LESS_OR_EQUAL" which is my firewall. Well I installed Kerio 3 years ago and back then it was the best option and Comodo wasn't very good then, but I think Comodo would be my first choice today for a new firewall install. So I uninstalled Kerio (from add/remove programs) then looked through the registry to make sure all was gone. I didn't install any new firewall yet.

Result: I first set a limit i NetLimiter for uTorrent to 50kB/s up&down (limit inside uT set to 500 down/400 up), and it ran like than for ½ hour. Then I removed the NetLimiter limit. Crash after 1 minute.. So it's back to Deluge for me, sad to say.

I also tried Memtest but had limited time (didn't run the last test yet). No errors. But I have run Memtest several runs a couple of years back when I added RAM and the Pc has been sitting where it is since then so it really is on the far-fetched list for me.

I wish I hadn't updated Windows. It seems it must be one of the latest Win updates that doesn't agree with the rest of the programs (which are older and used for a long time, as mentioned).

Edit: Does anyone know if it's possible to get some more information from the bluescreenview log? Besides a crash being caused by tcpip.sys, is it e g possible to see what application was involved?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...