Jump to content

Found Great Speedup Tweak for uTorrent !!! (and I'm a bit angry)


Recommended Posts

This tweek sped up all my torrent downloads to near maximum download speed (16 Mbit in my case) with this:

In the status bar of the mail uTorrent window, the current dowload speed is shown.

- Right click on that and a menu opens to set the maximum download speed

The default is 0 == unlimited (NOT!).

- Now select a speed that is much higher than your actual maximum download speed.

You might have to right-click a few times because the options are relative to the current max.

At voila: Torrent download speeds will increase to your maximum bandwith.

Works great for me and my friend. Does is work for you?

And I'm a bit angry because I've been using uTorrent for a few years now at slow download speeds.

Developers, are you reading this?? This should be the *DEFAULT* behavior !!

Phew, ok, I can rest a bit now :-).

Happy sharing, Cheers, Richard

Link to comment
Share on other sites

This is going to sound weird but I was just curious and I took my download off unlimited and set it to 1000K and my downloads shot up from 500 to 800. Went back to unlimited and my downloads went back down to 500. Could be just my imagination but for some odd reason that worked for me lol.

Link to comment
Share on other sites

Hi Switeck,

I've looked at the trouble shooting guide but it does'n seem to apply.

A bit more info:

- We tested it on a newly opened, heavily seeded torrent. (so upload bandwith was near 0)

- This was the only active torrent (so # of connections was low)

- The speedup / slowdown was reproducable 3 times within ~ 10 seconds

by ' setting to high' / 'unlimiting (0)' the max download speed respectively.

- It seems that hobbit25 is the 4th confirmation of the problem.

So, happy debugging :-),



Link to comment
Share on other sites

This is interesting, after the recent utorrent update, I started getting horrible speeds on all my torrents. I finally come here, find this thread and dismiss BlaDiBla's post as the ravings of a computer illiterate, but still, against common sense I try it. Now I've got all my speed back. I believe there is something wrong with the recent version update.


I put everything back the way it was and the speeds dropped. I then installed the previous version, and the speed went back up. There is obviously something wrong with the latest version.

Link to comment
Share on other sites

I was one of the unlucky ones(that updated to the latest version), and i worked forever on trying to fix the problem with only half my download speed being used with solutions posted in the forum. none helped. I downgraded to 1.8.6, then updated to 2.0, but the speed problem still didn't go away.

After trying most of the steps in the forum again, i still didnt have any luck.

After a lot of messing around, i was finally able to get my old speed back by lowering the number of upload slots to 3, and maximum number of connections to 50 per torrent.

It may be that that those 2 last settings were not the only thing that fixed it. i also set my download speed to way above my actual speed, and disabled bandwidth management and DHT network.

It almost seems as though i can't have as many peers connected as before the update to 2.0.1.

Guess it might be some setting somewhere that as been carried along when downgrading.

My operating system is W7 x64

I was downloading 2 new torrents with many thousand seeds and peers while testing this.

This does not seem to have fixed the problem on all the torrents. some still refuse to use more than 1/5 of my max speed, but it's a step in the right direction.

Link to comment
Share on other sites

I am using uTorrent 2.0.1 and W7 x 64. Downloading my first set of torrents and things seem to be working fine. The last four torrents 2 of them have 1 seed and 5 to 10 peers, the other two have no seeds and 6 or 7 peers. I understand why the last two are not downloading, but the first two should still be downloading and they are not. They have quit downloading at 72% and 89%. I'm seeding several other files but why is it not downloading my last two torrents? Don't mind seeding but I feel like my computer is just being held hostage to seed. How do I get the last to files to finish downloading, this has been going on for 3 days. I read all the help, and faq's plus other blogs I haven't seen my problem, or anything that seems to help my problem.

Thank you,

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...