Jump to content

Massive speed boost, then slow down


Recommended Posts

Thanks to excellent help from this forum I recently got my copy of uTorrent set up on my PC, system settings organized and ports forwarded. Sadly it didn't improve my slow download speeds, which maxxed at around 15-30 kB/s.

Last week I downloaded a copy of uTorrent 1.4.2b (build 427) and was amazed to see my download speed leap to 200 kB/s on one particular file. Sadly, again, since then I have seen speeds drop back to their original levels and below. As a torrent noob I am aware that download speeds vary with different files - but at this sort of level?

Reading other posts here I am also aware that some ISPs cap download rates. I'm wondering whether mine is one of them. Here are my specs:

ISP - BT/Yahoo! Broadband (UK)

Bandwidith - 2Mb

Windows XP Home SP2

Windows Firewall on (uTorrent is accepted and I have disabled 'Startup Type' in its properties)

Belkin Wireless Modem Router F5D7633-4

The 'NAT Error' warning, which I used to get all the time, now only appears after several minutes of download. Still haven't seen 'Network OK' yet.

If anyone can make any sense of this situation I'd be very grateful. Thanks.

Link to comment
Share on other sites

It means somewhere in your modem/router there's an option to forward either TCP, UDP or both. Choose both. Sometimes it will only let you forward one type at once, if this is the case, then you need to add them seperately. Of course, I cannot walk you through the process as every modem/router is completely different - I'm sure you can understand. For more information please visit PortForward.com, choose your modem/router (or a model close to it) and follow their detailed instructions. ;)

Link to comment
Share on other sites

Thank you again, and I fully understand you being unable to help with every modem/router on the market. However, I am still having trouble finding where to forward TCP and UDP on my modem/router (Belkin F5D7633-4). The only place I can find them mentioned in setup is in the Client IP Filter section of Firewall options. Here they are included in the Protocols column of the filter name. At present nothing is set up in the area. Am I looking in the right place?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...