Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 2.2 "Griffin" beta 22538

Recommended Posts

22328 SOCKS 5 proxy appears to be working on my win 7 machine. I am using btguard proxy. I really like the new privacy proxy features. From what I can tell, I can now safely use DHT without leaking my IP address?? netstat seems to indicate this. Thanks for the hard work

edit: there may be an upload bug, too soon to say for sure

Share this post


Link to post
Share on other sites

Good afternoon dear sirs here throughout several builds 2.2 speed of return simply awfully is low users with rutracker.org as well as I wrote that simply not probably this program to use therefore all now sit on 2.0.4 you make though something with a beta 2.2 that return would be on it also as on 2.0.4 or it is better than nothing about speed I will tell all in norm.

Share this post


Link to post
Share on other sites

Hi guys

Ive updated to the latest beta and utorrent still loads the torrent automatically without asking where to save to.

Can i change this? I have already ticked the checkbox in Preferences --> UI Settings called "Show a window that displays files inside torrents. and still no box pops up.

Any thoughts?

Thanks

Share this post


Link to post
Share on other sites

Here is a thought: the bug is that uT still remembers the old setting from 2.04 in the directories dialog.

Make a backup of setting.dat, delete it and settings.old, start uT again check this checkbox and try again...

Share this post


Link to post
Share on other sites
ut stop freezing at startup, with sock5 proxy enable, in Version 2.2 Beta (build 22328) ..

i've just a little bug, incoming connection stop working !!!

incoming connection coming to ut in cosonle log, but ut don't opening the transfert .

[2010-10-06 09:41:58] Incoming connection from 127.0.0.1:2092

[2010-10-06 09:41:58] Incoming connection from 127.0.0.1:2094

[2010-10-06 09:41:59] Incoming connection from 127.0.0.1:2102

[2010-10-06 09:41:59] Incoming connection from 127.0.0.1:2103

[2010-10-06 09:41:59] Incoming connection from 127.0.0.1:2104

[2010-10-06 09:42:01] Incoming connection from 127.0.0.1:2119

...

my incoming connection working now, when "disable connections unsupported by the proxy" is deselected

Share this post


Link to post
Share on other sites

There is utorrent griffin beta 22328, utorrent 3.0Falco alpha 22329, and utorrent 2.04 so I was wondering which I should download.

A little confused since I do not know which is better.

Thanks you for the help.

Share this post


Link to post
Share on other sites

Depends on where you want to use it. For example on a tracker where you need registration, you should ALWAYS use the stable, so 2.0.4 version (at the moment).

On public trackers, you can always experiment with the newer versions.

For example 2.2 gives me a huge performance boost, but I just can't use it yet. So I'm waiting for the team to fix all the remaining release-critical bugs and release it into the wild.

(And 3.0/alpha ..yes, that's really just for experiment.)

Share this post


Link to post
Share on other sites

Thank you for the help.

Also like is 2.0.4 as safe and secure as 2.2 and 3.0 alpha.

Also like whats type of critical bugs does the 2.2 have?

Pretty much looking to download safely.

So are you going to like use 2.2 when it has the stable lable on it then switch to 3.0 alpha when its stable too?

Thank you for the help.

Share this post


Link to post
Share on other sites

uTorrent beta (2.2 build 22117) under wine-1.3.4 freezes at startup and loads CPU, shows no GUI. Some previous beta version worked OK, but I can not recall its number. The log:

fixme:heap:HeapSetInformation 0x110000 0 0x4b23b0 4

fixme:heap:HeapSetInformation 0x2c4000 0 0x4b23b0 4

fixme:hnetcfg:fw_app_get_Enabled 0x1324d8, 0x7dfa94

fixme:hnetcfg:fw_app_put_ProcessImageFileName 0x1324d8, L"D:\\prg\\uTorrent\\utorrent.exe"

fixme:hnetcfg:fw_app_put_Name 0x1324d8, L"\00b5Torrent"

fixme:hnetcfg:fw_apps_Add 0x14ea28, 0x1324d8

fixme:winsock:WS_setsockopt Unknown IPPROTO_IPV6 optname 0x00000017

fixme:winsock:WS_setsockopt Unknown IPPROTO_IPV6 optname 0x00000017

err:winediag:WSASocketW Failed to create a socket of type SOCK_RAW, this requires special permissions.

err:winediag:WSASocketW Failed to create a socket of type SOCK_RAW, this requires special permissions.

err:ole:CoGetClassObject class {ae1e00aa-3fd5-403c-8a27-2bbdc30cd0e1} not registered

err:ole:CoGetClassObject class {ae1e00aa-3fd5-403c-8a27-2bbdc30cd0e1} not registered

err:ole:create_server class {ae1e00aa-3fd5-403c-8a27-2bbdc30cd0e1} not registered

fixme:ole:CoGetClassObject CLSCTX_REMOTE_SERVER not supported

err:ole:CoGetClassObject no class object {ae1e00aa-3fd5-403c-8a27-2bbdc30cd0e1} could be created for context 0x17

err:ole:CoGetClassObject class {ae1e00aa-3fd5-403c-8a27-2bbdc30cd0e1} not registered

err:ole:CoGetClassObject class {ae1e00aa-3fd5-403c-8a27-2bbdc30cd0e1} not registered

err:ole:create_server class {ae1e00aa-3fd5-403c-8a27-2bbdc30cd0e1} not registered

fixme:ole:CoGetClassObject CLSCTX_REMOTE_SERVER not supported

err:ole:CoGetClassObject no class object {ae1e00aa-3fd5-403c-8a27-2bbdc30cd0e1} could be created for context 0x17

err:ntdll:RtlpWaitForCriticalSection section 0x4c0c88 "?" wait timed out in thread 001d, blocked by 001c, retrying (60 sec)

err:ntdll:RtlpWaitForCriticalSection section 0x4c0c88 "?" wait timed out in thread 0009, blocked by 001c, retrying (60 sec)

The last 2 lines are repeated many times.

Share this post


Link to post
Share on other sites
Ah.. that's probably Firon' date=' doing half the work ... :P;)Latest is - build 22328

Tried. Same problem. Also "wineserver" loads CPU, if it matters.

Can you move your settings out of the way to see if it loads then? Keep them somewhere just in case.

If it then loads correctly, can you send us your settings? If it still hangs, then let us know.

Share this post


Link to post
Share on other sites
Can you move your settings out of the way to see if it loads then?

I've cleaned the directory where utorrent.exe lives and "/home/${USER}/.wine/drive_c/windows/profiles/${USER}/Application Data/uTorrent". Hangs after the "Choose Language" window, "settings.dat.old" and "settings.dat" have been created.

If you have an archive of beta releases, I can try them to locate a release when the problem was introduced.

Share this post


Link to post
Share on other sites

I have the same problem under wine 1.2 where the recent builds are not displaying. The most recent build that works for me is 2.2-21738. I try each new beta, and all I get is a flicker on the screen as it attempts to load, then nothing. I have to go in and end the process, replace the executable with the above version, and everything is good again. What shows up in the process list under Waiting Channel is "futex_wait_queue_me", using about 4.1MB ram. Not sure if that helps, but if you know what else to look for let me know and I will get it for you. Thanks for a great product!

Share this post


Link to post
Share on other sites

BTW, my problem does not depend on the version of wine. I have done all tests under wine-1.2.4 also. Under recent wine-1.3.4, commands in the context menu do not work, but I assumed you had enough problems at hand.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.