Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 2.0.3 released

Recommended Posts

too bad not even uTP can defeat my ISPs traffic shapping techniques :(

i'm limited to 30kb/s with torrent but in http it goes over 700kb/s

Share this post


Link to post
Share on other sites

uTP isn't to circumvent throttling, just solve the problem the ISPs report as their reason for throttling in the first place, in hopes they'll relax their attitudes in the future. Encrpytion on the other hand..

Share this post


Link to post
Share on other sites

What about add The Yes Man strings into µTS?

What about make a frame Global Rate Options (or other title) into Bandwidth Preferences for new options?

globalrateoptions.th.png

Do not forget: "Use additional upload slots..." ovelaps text box "Number of upload slots..."

Already reported by another user.

Solution follows...

234 DIALOGEX 0, 0, 285, 195STYLE DS_FIXEDSYS | DS_CONTROL | WS_CHILDEXSTYLE WS_EX_CONTROLPARENTCAPTION ""LANGUAGE LANG_SWEDISH, 0x1FONT 8, "MS Shell Dlg"{   CONTROL "", -1, BUTTON, BS_GROUPBOX | WS_CHILD | WS_VISIBLE, 0, 0, 280, 40    CONTROL "", -1, STATIC, SS_LEFT | WS_CHILD | WS_VISIBLE | WS_GROUP, 6, 11, 224, 8    CONTROL "", 1031, EDIT, ES_LEFT | ES_AUTOHSCROLL | ES_NUMBER | WS_CHILD | WS_VISIBLE | WS_BORDER | WS_TABSTOP, 237, 10, 36, 12    CONTROL "", 1162, BUTTON, BS_AUTOCHECKBOX | WS_CHILD | WS_VISIBLE | WS_TABSTOP, 13, 26, 220, 8    CONTROL "", 1165, EDIT, ES_LEFT | ES_AUTOHSCROLL | ES_NUMBER | WS_CHILD | WS_VISIBLE | WS_BORDER | WS_TABSTOP, 237, 25, 36, 12    CONTROL "", -1, BUTTON, BS_GROUPBOX | WS_CHILD | WS_VISIBLE, 0, 40, 280, 26    CONTROL "", -1, STATIC, SS_LEFT | WS_CHILD | WS_VISIBLE | WS_GROUP, 6, 51, 225, 8    CONTROL "", 1037, EDIT, ES_LEFT | ES_AUTOHSCROLL | ES_NUMBER | WS_CHILD | WS_VISIBLE | WS_BORDER | WS_TABSTOP, 237, 49, 36, 12    CONTROL "", 1462, BUTTON, BS_AUTOCHECKBOX | WS_CHILD | WS_VISIBLE | WS_TABSTOP, 13, 76, 220, 8    CONTROL "", 1461, BUTTON, BS_AUTOCHECKBOX | WS_CHILD | WS_VISIBLE | WS_TABSTOP, 13, 89, 220, 8    CONTROL "", -1, BUTTON, BS_GROUPBOX | WS_CHILD | WS_VISIBLE, 0, 102, 280, 75    CONTROL "", -1, STATIC, SS_LEFT | WS_CHILD | WS_VISIBLE | WS_GROUP, 7, 116, 224, 8    CONTROL "", 1050, EDIT, ES_LEFT | ES_AUTOHSCROLL | ES_NUMBER | WS_CHILD | WS_VISIBLE | WS_BORDER | WS_TABSTOP, 237, 115, 36, 12    CONTROL "", -1, STATIC, SS_LEFT | WS_CHILD | WS_VISIBLE | WS_GROUP, 7, 132, 224, 8    CONTROL "", 1047, EDIT, ES_LEFT | ES_AUTOHSCROLL | ES_NUMBER | WS_CHILD | WS_VISIBLE | WS_BORDER | WS_TABSTOP, 237, 131, 36, 12    CONTROL "", -1, STATIC, SS_LEFT | WS_CHILD | WS_VISIBLE | WS_GROUP, 7, 148, 224, 8    CONTROL "", 1043, EDIT, ES_LEFT | ES_AUTOHSCROLL | ES_NUMBER | WS_CHILD | WS_VISIBLE | WS_BORDER | WS_TABSTOP, 237, 147, 36, 12    CONTROL "", 1161, BUTTON, BS_AUTOCHECKBOX | WS_CHILD | WS_VISIBLE | WS_TABSTOP, 13, 163, 260, 10    CONTROL "", -1, BUTTON, BS_GROUPBOX | WS_CHILD | WS_VISIBLE, 0, 66, 280, 36 }

Share this post


Link to post
Share on other sites
Just curious, but does this problem and changed setting respectively affect Teredo traffic or only users with pure IPv6 connections? Teredo seems to be initialised either way.

Disables all use of IPv6 in µTorrent.

Share this post


Link to post
Share on other sites

Hi all,

Has someone noticed a weird behaviour in the 'Transfer History' graph?

What I see is that the graphic doesn't update, froze.

It happen for the first time the day I updated from 2.0.2.19648 to 2.0.3.20664. Then, other day it works again (I mean, the values were updated at the end of the day), but now, for 2 days is freezed again, no matter if I download or not.

I'm using Win XP SP2 (32 bits).

Regards.

Share this post


Link to post
Share on other sites

I wrote about this in the 2.0.2 thread, but nobody believed me, so here's a video of what happens - when restoring uTorrent from the tray, after its first start, the taskbar icons are refreshed:

http://mm.pl/~paralemptor/icons.avi (h264, 447kB)

Is 2.0.3 also doing that? Or am I really, really weird?

OS is Windows 7 x64 with all updates installed.

Share this post


Link to post
Share on other sites

why does Version 2.0.3 (build 20664) sends Completed event to tracker sometimes when i start to seed already downloaded torrent? i believe it wasn't like this in 2.0.2 stable

+ it sends Completed flag just for 1st tracker out of 3 which are in tracker-list for torrent, for rest 2 it sends no event at all, not even Started one which it should?

so i stop torrent and start it again and now it sends Started event for 1st tracker and still nothing for rest 2

and it sends Stopped event like it should for all 3 trackers in torrent

bug?

Share this post


Link to post
Share on other sites
i found 2.0.3 build 20683 but is not on the site, whats new in this build?

new viruses

Share this post


Link to post
Share on other sites

I've gone back to this version.. the newest 2.2 interface is awful.. reminds me of all the fancy bloated clients out there.. I'm not for eye candy but functionality and 2.2 looks like too much eye candy for me.

Share this post


Link to post
Share on other sites

Welcome back, molitar :) but... why don't you report about that in the 2.2 thread ? ... :P

Share this post


Link to post
Share on other sites

The code for the new sidebar is actually smaller than the old one. :P And it's a native listview now, too.

Share this post


Link to post
Share on other sites
i found 2.0.3 build 20683 but is not on the site, whats new in this build?

i downloaded 20683 off of the main site on July 24th, but they have since rolled back to 20664 so i assume that 20683 created more problems than it solved.

Share this post


Link to post
Share on other sites

I can't seem to get uTP to work right. Our ISP do not throttle or have CAPs as I've always gotten full speed, but uTP seems to work on the ISPs behalf (and for their benefits) by throttling my d/l speed even though it is in the middle of the night and I should be getting full speed (the speed I an paying). I started several torrents but still getting low speeds. I'm just curious as to why use it or turn it ON by default when it has such high overheads and lousy speeds.

My router seems to shape my traffic MUCH better than the uTP. I've used a simple Tomato, OpenWRT, and pfsense, etc... and they all seem to prioritize and de-prioritize traffic consistently and almost instantly (shown by the bandwidth graphs).... and fine tuning them is easy.

I hope you'll consider "disabling uTP" as the default in future releases..

Share this post


Link to post
Share on other sites
I hope you'll consider "disabling uTP" as the default in future releases..

Don't hope about that, that's surely not the plan of the devs. When you add a new important feature, you don't disable it by default.

Share this post


Link to post
Share on other sites

I just don't think it's the job of uTorrent to perform "Traffic Management"/"Taffic Cap". Virtually all the good, yet free router software manage traffic extremely well. Limiting traffic based on one of several critera, and even shutting down a connection once you've reached the "total" cap is much more reliable than the transfer cap in uTorrent (as it ONLY counts uTorrent's data).

Share this post


Link to post
Share on other sites
(as it ONLY counts uTorrent's data).

Right. It should count global data... I've opened a feature request for that ...

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.