Jump to content

Something is throttling my speeds, but what?


Recommended Posts

I've been using utorrent with great success for a while now and when the odd issue cropped up, I've usually been able to find a solution by searching these forums. So let me first say a big thank you to everybody for such a great resource.

Now onto my problem:

For the last week, my download speeds have dipped dramatically - up to 80%. I suspect the upload speed is impacting on this because though I am connected to the same average seeds and peers as before, the upload speed during downloading peaks between 5 - 10 Kb/s, well short of the 47Kb/s I've set in utorrent. This happens for all torrents I've tried. Interestingly, once downloading is complete and I am just seeding, the figures increase somewhat, but still not to the levels I had before. FYI, I am listed as connectable at the private BT sites I use.

I've used the utorrent network wizard to assign the settings for me, so I doubt the problem lies there.

As a test, I disabled all firewalls, connected my DSL directly to my PC ethernet network card (no router); still no joy. I even uninstalled cfosspeed just in case it was dong something wierd (worked like a dream before) just to see if that was affecting things, but no. I've tried rebooting and FWIW, the first torrent I download reaches acceptable download speeds even if well short than before. Once I download a second or third torrent, however, the speeds drop steeply. I used TCP optimizer to tweak latency, MTU etc. I tried the latest utorrent beta build, no dice. As a last resort, I contacted my ISP who were helpful enough but couldn't explain what was happening because when downloading non-BT stuff and using the web browser, I get exactly the speeds I'm supposed to. They assure me that no traffic-shaping is beiing performed from their end.

If I were to guess, my upload speed is being somehow throttled and that in turn is impacting on the download speed (or vice-versa). I can connect to as many peers as before but its as if something is actively refusing to upload to to each indvidual peer beyond fractions of a kB.


Realtek RTL8139/810x Family Fast Ethernet NIC

utorrent 1.4

TCP patched to 100 half-open connections

DSL broadband 6M line (640kB/s down; 64kB/s up)

Global max. upload rate = 47kB/s

Global max. download = unlimited

Global max. connections = 250

Connected peers per torrent = 90

Upload slots per torrent = 4

Additional upload slots if <90% = checked

Assuming similar number of seeds/peers, typical speeds BEFORE:

300kB/s down; 46kB/s up

Seeding only = 60kB/s and upwards


50kB/s down; 6kB/s up

Seeding only = 15kB/s

Any suggestions?

Link to comment
Share on other sites

Firon - thanks.

It has improved things though I'm still not getting the speeds I used too.

Is there any reason anyone can think of why the speeds plummeted so dramatically to begin with? I mean I'm connected to the web 24/7 and at the time I was downloading something on utorrent with no problems whatsoever. Then I added a new torrent a little later and the whole thing went to pot. As an aside, are than any Windows services (via Admin tools) that could impact this in any way? I can't imagine that I caused one of them to be changed, at least not knowingly. Still, is there something that I have on which should be disabled or the other way round with regards to BT protocol?

1c3d0g - According to the properties tab, I'm currently running in 'Ultra DMA mode 5'. Still, I uninstalled the driver and rebooted just in case to reset the parameters. Incidentally, in the policies tab should I have 'enable write caching on the disk' box checked or not? And do I need to alter the diskio_read_cache_size (currently disbaled, i.e. value=0)?


Link to comment
Share on other sites

Flak: nah, if you don't get a Disk Overloaded message (and since you've verified that you are indeed still in DMA mode), there's no need to adjust those values (unless of course you can't live with seeking/writing "noise" ;)). Hmm...everything looks "OK" so far to me...how big is your ISP? If it's a small one, the lines it leases could be throttled by a bigger ISP, but that's just a wild stab in the dark, really. :/

Edit: typo.

Link to comment
Share on other sites

Was going to post something extremely similar to this, out of interest, are you with Pipex?

Hmm, but anyway, even though I'm expericing the same problems, I've downloaded the beta version, gone to the 'Network' section and set the outgoing encryption to 'enabled' and I've also checked the box next to it for 'allow incoming legacy connections' - but I've had no luck, it's still going at awful speeds!

Link to comment
Share on other sites

I've got the same sorta problem (and am with Pipex).

However I can get good speeds with the OpenOffice torrent, but not with other things such as TV or music. I'd usually get download speeds of about 100kB/s with the new TV shows I download but for the last couple days they've only been going at around 10-20kB/s.

EDIT: Surprisingly since I first posted, download speeds are pretty much back to normal. :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...