Jump to content

uTorrent Overloads Win7 32/64 TCP-IP


Recommended Posts

I've seen a few posts on this board now, and carefully considered and tried various suggestions to fix an issue I am experiencing reproducably on all three of the computers I have set up at my place. After extensive testing, with the direct cooperation of my ISP, we gathered the following, details follow-


- Opening and Using uTorrent causes the Windows 7 32/64-bit TCP-IP stack to lock out all other programs except uTorrent itself

- By extension of that, the following become unusable (in our testing): Internet Explorer, Firefox, Ping, mIRC, Icechat, MSN Messenger, AOLIM, Steam, etc.

The problem is isolated to windows handling of network connections once uTorrent is opened, very extensive exhaustion of hardware changes were made, including but not limited to: new Broadband equipment/receivers, new routers, direct-switched routing over Dell Powerconnect direct via ISP, numerous PC and Macintosh devices.

Clarification of behavior:

- Only the PC running uTorrent is effected (rules out router, and upstream broadband hardware)

- Only uTorrent elicits this behavior

- Suggested fixes on the Forums do not fix the behavior

- PC Running uTorrent cannot use anything but uTorrent, but seperate PC or Macintosh on the same network can successfully use network, and speed test show ample speeds, of which uTorrent is only using a fraction, despite being the only thing that can use the net connection while it is open.

- Updating, installing, or retrograding Network drivers for any of the five network cards used for testing corrected the issue, again suggesting it is a software conflict between uTorrent and Windows 7's back-end handling of TCP-IP connections.

Hardware Used (Not exhaustive):

PC 1 - Custom Built, Intel Pentium Dual-Core E6600, XFX 750i Mainboard, 4096MB DDR2 SDRam, Gigabyte Geforce 9800GT

PC 2 - HP dv2990nr, Intel Core 2 Duo T5750, 3GB DDR2 SDRam, GeForce 8400M GS 256MB

PC 3 - Dell e310, Pentium D 930, 2048 MB DDR2 SDram, Intel Graphics, M-Audio Revo 5.1 Sound

PC 4 - (Used for non-OS co-testing) Macbook Pro

PC 5 - HP SR2150NX running Linux Mint 8 (Used for non-OS co-testing) and RHEL Centos (Also used for non-IS co-testing).

5 NICs (various manufacture)

Several Routers:

- WRT54GL (Factory Firmware)

- WRT54GL (Tomato)


- WRT54GS (Factory Firmware)


- WRT110 (Factory Firmware)

- Belkin (Forget the model sorry!)

- Dell Powerconnect 6024 IOS - Router Load (DHCP FROM ISP!)

- Dell Powerconnect 5324 (DHCP FROM ISP!)

I hope I have not been unclear, but there is no solution I see - this is only a problem with the last few recent versions of uTorrent and I did not try Vista or XP. Only win 7 32 and 64, it is easily reproducable on my end.

I hope someone can come up with a solution, I am a loyal fan of uTorrent, until now - I can't shut down everything else on my main desktop every time I try to run uTorrent, and it is cumbersome to make a server just for uTorrent to use.

Any help?

Link to comment
Share on other sites

Can you list the installed applications that are shared between all the affected machines? Does this happen on a clean install (no third-party software whatsoever)? Windows update used?

The reason I ask is that I am running Windows 7 and do not seem to have run into this problem. Yet many others including yourself have, so there has to be something linking all of the issues together. I for one do not use windows update and am still running a base RTM version, Firefox and mIRC are the only applications listed above that I also have installed. (possibly ruling those out as related)

Link to comment
Share on other sites

Well frack, now I'm not so certain, running testing again tonight, running uTorrent on any computer kills the connection for ALL computers, looking in the router, I see page after page of UDP port tries that are either half open/waiting, unplugging the router and plugging in PCs directly, I get the same thing, but can no longer inspect packet traffic, since I was doing so via the router, essentially, utorrent kills my connection.

My ISP has repeatedly indicated that they do not throttle torrent traffic, but they gather most of their connectivity via Qwest corporation, any chance Qwest is throttling upstream? Doesn't seem to matter what settings I change on uTorrent, or what I change on my router, or even if I'm directly connected, the behaviour is the same.

I have no idea what to do.

Link to comment
Share on other sites

I have fixed wireless HSI from a company called ZirkelWireless, a stationary antenna is used to connect uphill to a hub and their switching equipment.

Currently I'm using DD-WRT on a WRT54GS on a static IP

Here's the kicker, up until the last version or two updates of uTorrent, this worked, its only pretty recently I've been unable to torrent without it wiping my connection out.

And yet, even though everything else doesn't work, uTorrent keeps right on downloading....

Link to comment
Share on other sites

There is an issue with Win 7, MSSE (Microsoft Secirity Essentials) and uTorrent....this combination will slowly cause the computer and network to creep to a standstill.

I experienced the same...switching to another AV suite fixed the problem.

You did not specify your AV/Security SW...are you by chance running MSSE?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...