Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 2.0.4 released

Recommended Posts

There's nothing wrong with the current build of 2.0.4.
saintsoh, your ISP is partially to blame for your torrenting problems.

yeah, i know...crappy isp..... n crappy me too.

i felt tat way whenever i tried latest ver., dl speed were so miserable.

happier when i use ver 1.8.5 17414 with utp disabled.

i'm grateful to utorrent for providing free bittorrent client.

thank you.

Share this post


Link to post
Share on other sites

Just to be clear:

Does the malware exploit potentially affect all uTorrent versions prior to 2.0.4, or just the 2.x.x releases?

Reason I'm asking:

I just scanned my computer with the Secunia PSI, and that detected a backup copy of the uTorrent 2.0.4 build 21515 executable as insecure (which it shouldn't have). Buggy, yes, but not subject to the exploit (if I understand correctly).

The Secunia PSI scan did not detect backup copies of 1.8.1, 1.8.5, or 2.0.0 as insecure, which seems a little strange.

It (correctly) didn't complain about build 21586, which I'm currently using.

Share this post


Link to post
Share on other sites
Does the malware exploit potentially affect all uTorrent versions prior to 2.0.4, or just the 2.x.x releases?

ALL versions with a build number lower than 21515 are potentially vulnerable, not just 2.x.x lines.

It doesn't matter what version of uTorrent it is (windows only), if its build number is lower than 21515, it is potentially vulnerable to this exploit.

Share this post


Link to post
Share on other sites

ALL versions with a build number lower than 21515 are potentially vulnerable, not just 2.x.x lines.

It doesn't matter what version of uTorrent it is (windows only), if its build number is lower than 21515, it is potentially vulnerable to this exploit.

That's what I thought, but I wanted to confirm it before posting about this at Secunia's site. (I've seen some confusion about this in discussions on other forums.)

Thanks for the fast (and nice :) ) response.

Share this post


Link to post
Share on other sites

What really sucks is a lot of the tracker admins are freaking the hell out and banning anything before 2.0.4.21586.

2.0.2.19648 is the best version I've used in a while, works perfect 24/7.

2.0.3.20664 hangs all the time for me.

2.0.4.....who knows.

Share this post


Link to post
Share on other sites

With this new version (build 21586) I could not connect to trackers, with all previous versions I have no problem.

Seeds: 0

Peers: over 2300 ???

Trackers picture:

2uf6e6d.png

With build 21515, I have this situation (same torrent)

Seeds: 281

Peers: 630

And trackers picture:

i2vihe.png

Share this post


Link to post
Share on other sites

Just updated from 1.8.5 to 2.0.4, speed did drop bit but was still good for a day or 2.

Then it really took dive. I'm so conflicted go back to 1.8.5 or stay :(

With 1.8.5 speed was around 96kB/s-132kB/s

With 2.0.4 speed is around 23kB/s - 65kB/s

Share this post


Link to post
Share on other sites

Have you configured your firewall correctly for this build? You should allow all outgoing UDP traffic, as well as incoming on your listening port.

Share this post


Link to post
Share on other sites
*.thepiratebay.org trackers are dead for ages. You can remove them.

Problem is not in thepiratebay trackers - problem can be seen in first picture.

It is just an example, same problem is with ALL torrents, I used this one because it has more trackers than others.

I'm not using uTorent from yestreday, I have all versions from 1.7 up, and every version is working OK, except latest build 21586.

Have you configured your firewall correctly for this build? You should allow all outgoing UDP traffic, as well as incoming on your listening port.

My firewall is configured exactly same for both versions - TCP and UDP port exceptions are correct.

uTorrent connection configuration:

25p1g7b.png

McAfee Total Protection firewall configuration for uTorrent:

1zg7vut.png

Share this post


Link to post
Share on other sites

scanner- you should understand that such a problem (which I don't have) would have likly generate tons of posts. It must be a problem in your own local setup/config/gear.

Share this post


Link to post
Share on other sites
scanner- you should understand that such a problem (which I don't have) would have likly generate tons of posts. It must be a problem in your own local setup/config/gear.

Maybe is problem in My configuration, but why is uTorrent 2.0.4 (build 21515) WORKING and uTorrent 2.0.4 (build 21586) NOT WORKING, on same computer with exactly same configuration with exactly same torrents ???

What is different, what has changed ?

Only uTorent build from 21515 to 21586 !

And there MUST be difference.

Quote from changelog:

-- 2010-08-28: Version 2.0.4 (build 21586)

- Fix: tracker retry interval bug

Something that has changed in communication with trackers affected My system and it is not able to connect to trackers any more.

When I re-install build 21515, everything is working.

If this stays as it is, I will not be able to use any new version, and I'm not satisfied with that.

For now I'm lucky to have b.21515, because older builds are vulnerable and currently released build is not working for me.

Share this post


Link to post
Share on other sites

I have removed and re-added many times

I re-entered ports and program permissions

Here are program permissions for uTorrent in firewall:

5zllac.png

You can see ports configuration in post #86

This is Windows XP Professional SP 3 system

Share this post


Link to post
Share on other sites

Now I installed this new 2.0.4 build 21586 on My notebook with windows 7 Ultimate, connected on same router as other desktop computer, with same McAfee Total Protection, and exactly same configuration.

This latest uTorrent (21586) is working on Windows 7, it is not connecting on all trackers as 21515, but is working.

For now I will work with 21515 on XP, and with 21586 on Win 7, and see what will be with next releases.

Thanks for Your time.

Share this post


Link to post
Share on other sites

there will probably be no 'next release' in the 2.0x line... unless you find a REAL bug... :P

Share this post


Link to post
Share on other sites

21515 is completely broken. You should not use that build.

The problem is your firewall. Remove exceptions, reboot, then readd then.

Share this post


Link to post
Share on other sites

Thanks for your help,

I have transferred all torrents on notebook and now I'm using 21586 until I found what is problem with XP system.

I'll uninstall all network and internet related drivers and programs, and then reinstall them again.

If this will not work, I'll just upgrade to Win 7, I think it's time to do that anyway.

@rafi,

Nice avatar, i think it is from Win 98, it was the best one for very long time.

Thanks again.

Share this post


Link to post
Share on other sites

2.04 somehow has amazingly allowed utorrent to be able to close for me on Windows 7. I didn't think it was possible to fix that without a windows patch or changing windows settings. Please whatever you did don't change it back that was crazy annoying.

Share this post


Link to post
Share on other sites

I have founs source of My problems - uTorrent not connecting to trackers.

Yes, it is firewall related, but because of uTorrent installation behavior.

uTorrent installer is not another program different from installed program, which installs final working program, it is the same EXE file as installed one.

When executed, it checks if it is already installed and if installed EXE is same version as this being executed, if not, it runs installation process.

Installation process copies itself to installation location, by default it is C\Program Files\uTorrent\uTorrent.exe, overwriting previous version (if existed).

It is all OK until now, but here is where problem begins.

Program is not asking if I would like to run uTorrent after installation or not - I think that it should.

On first sight it looks like installer just runs newly installed program from it's installation location (as it would when started from menu or by running installd icon on desktop).

If this is true, than I would not have any problems, but it is not.

Installation program just continues running from it's installation location. as it would be this newly installed program - but it is NOT.

Since this downloaded installation instance DOES NOT have permission to connect to internet, only C\Program Files\uTorrent\uTorrent.exe does, it could not connect to trackers.

Possible solutions:

1. To grant permission for accesing internet to uTorrent from installation location - I dont consider this as very wise solution

2. To terminate program after installation, and to re-run it from its final location (C\Program Files\uTorrent\uTorrent.exe) - only logical for now

3. To modify program to NOT run after installation if EXE is not in final location, or to exit after installation and re-run from location where it is installed (C\Program Files\uTorrent\uTorrent.exe)

Share this post


Link to post
Share on other sites

You are wrong. Even IF uTorrent.exe is replaced and run from the final install location (same location as the previous exe) any descent firewall will still block it, since it's NOT the same binary (and has a different CRC).

You always have to re-define the rules (permit) in the firewall .

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.