Jump to content

Port won't open, causing slow speeds.


Recommended Posts

Hey guys,

Ever since i've bought my new computer and installed uTorrent, the download speed gotten really slow. It's downloading between 20-30 kbps instead of 300 (on torrent with 10,000+ seeds). I searched the forums and went through every guide here, but nothing helped,it still barely connects to any seeds or peers. However I think I found the problem - the port I use doesn't open!

I've tried going to portforward.com and downloaded their software that sets a static IP for my computer (I'm using a router), and than tried twice to forward the port - first using the Static IP the software produced, and later with the external IP that I found on whatismyip.com - but nothing seems to open it properly (i'm checking it with another portforward.com software). However I must say I always get the green circle with the "V" in it that tells my my connection is working as it should on uTorrent.

Anyway, i'd really appreciate your help, any details you need, just ask.

Thanks in advanced.

Link to comment
Share on other sites

Sorry, didn't see that.

1) Tried the site's speed guide, the software's speed guide (Ctrl+G, although now when I try it I get a connection timed out message), reinstalling after deleting both software and AppData, disabling firewall / re-enabling uTorrent in firewall (I use the windows firewall), checked in a list you provided that my ISP isn't throttling the application.

My current setting are:

In "Connections" - port is 62774, "Enable uPnP..." is unchecked (at the port forwarding guide it said to uncheck it), "Randomize port..." is unchecked as well, "Enable NAT.." and "Add firewall exception" are both checked.

In "Bandwidth" - Maximum upload rate is 17, "Alternate upload rate..." is unchecked.

Download limit is 0, "Apply rate limit to uTP connections" is checked, the other one isn't, Global maximum number of connection is 50, maximum number of connected peers is 30, number of upload slots is 3.

"use additional upload slots..." is cheked.

In "BitTorrent" - everything except "limit local peer bandwidth" is checked. In Protocol encryption Outgoing is enabled and "allow incoming legacy.." is checked.

on "Queueing" - Max. number of active torrents is 10, max. number of active downloads is 9, Ration is 150 or seeding time is 0. Both checkboxes are unchecked.

2) As i've said, protocol encryption is enabled, bt.tcp_rate_control is false, peer.lazy_bitfield is true.

3) Color of network status light is always green.

4) The port checker on the speed guide says the port is open.

5) The speed guide settings show that my upload speed is 139kbit/s and all the other setting are as i've written above.

6) Net.Max_halfopen is 100.

7) My OS is Windows 7 Professional.

8) For all I know, the only security software I have is Windows Firewall.

9) My Router is Siemens SL2-141, not sure how to check what my modem is but my network adapter is Intel 82578DC Gigabit (perhaps that's what you meant).

10) ISP is Bezeq International.

11)speed test results:


Hope that covers it. thanks for you help.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...