Jump to content

Possible reason for BSOD


Simbiat

Recommended Posts

Dear Support,

Since the first release of uTorrent 2.2 beta I've been experiencing frequent BSODs, complaining about csrss.exe or wininit.exe or wanarp.sys. I know, that they do not seem related to uTorrent, but I've been trying to figure out, what's the cause and that's what I've found out.

1. Some of the dumps contain "VISTA_DRIVE_FAULT". I'm using Win 7 x64 and I use only Win7 drivers for ALL of my peripherals. So, probably, it's just misleading.

2. Everytime I had a BSOD I had two "heavy-loading" applications running: AVS Video Converter and uTorrent.

3. I've tried "playing" with AVS's settings - still no result.

4. Tried using AVS WITHOUT uTorrent - no BSOD for three days. If they both are running - up to 10 (!) BSODs a day (!)

5. While I was writing this post I had a BSOD (for wanarp.sys). I had only uTorrent running.

6. Seems like th e problem is somehow related to torrents, that consist of one large (more then 4 Gbs) file. And the more such files I have - the more frequent BSODs are.

7. The HDD to which I download through uTorrent also contain pagefile.sys. I tried to move it, but still got BSOD. But... On that disk I also found a strange dump file, which I am uploading wight now. In fact I'm uploading three dumps at the moment. As soon as they are uploaded - I'll give links.

I know, that it MAY really be caused by some drivers or by some hardware failure... It's just that the occurence of those BSOD seems to be... Quite consistent. I'll upload my system info, too in a while.

The unknown dump from the root directory of the disk: http://www.megaupload.com/?d=5SFC569O

wanarp.sys crash dump: http://www.megaupload.com/?d=NCRASNEL

wininit.exe crash dump: http://www.megaupload.com/?d=U564RY6C

hijachthis reports: http://www.megaupload.com/?d=D50703NO

process explorer log: http://www.megaupload.com/?d=TPXSR6E0

Link to comment
Share on other sites

Likely either a disk overload, (from multiple things running off the same disk) or a failing disk (from the amount of work you've made it do)

uTorrent abuses drives with it random seeks, it's truly a workout on any drive. Pagefile.sys is a temp file that windows uses as backup memory to your ram, when the ram fills up it copies the background programs to the hard drive instead. That's why you couldn't move it. converting programs often need a steady input and output stream to the harddrive, much more than what's available when utorrent is running. If at all possible I would recommend working off a different drive for one of those tasks, Ideally utorrent should be on it's own drive.

Link to comment
Share on other sites

No... You did notget me... I did not try to move pagefile via Ctrl+X... I've moved through settings... Deleted from the disk in question and created on another disk. Still no go. And AVS Converter converts file to another disk also, not to the one, that is used by uTorrent. Besides, as far as I can gather, if it was really a HDD problem (or a controller problem), it would be possible to see this in the crash dump. Indeed, sometimes I get such BSODs, but since uTorrent 2.2 I had like three of such BSODs, and several dozens of BSODs about Access Denial (I've uploaded two of them). At the moment I'm using uTorrent 2.1, to check my hypothesis - I did not have a BSOD yet (it's been like 8 or 9 hours).

My guess is, that new uTorrents somehow abuses disk cache OR even processor cashe. If the developers could check the dumps, just in case, that would be great. If they come to a decision, that it's just a hardware issue - that's ok, but what if it's not?

TIA.

Link to comment
Share on other sites

Probably not, if anything it could be a Windows 7 x64 issue, which has happened before with ipv6 (and Microsoft doesn't really care to get a fix out in a timely manner). Last time I saw a variety of files appearing in BSOD messages though, it was the result of a motherboard with defective capacitors and ate several PSU's :(

Link to comment
Share on other sites

Well... I'm not using IPv6. And my motherboard is working quite well with the same PSU for like 2 years already... I perfectly understand the scepticism, but I describe the issue as I see it and with uTorrent 2.1 there is no issue (the settings are exactly the same). I'm gonna try out uTorrent 2.2 with different disk cache settings, maybe it will point out the reason. Still, I woulad really appreciate if the developers checked the dumps. I know, that they have lots of other, perhaps more important, stuff to do, but, who know, maybe the made some changes to caching\sparsing logics of uTorrent and it really is causing the issue...

Link to comment
Share on other sites

Well first of all, I work as a computer repair technician, and because it's ran two years is even more reason to check it. Make sure you're getting the proper voltages off the PSU, and look for scorch marks and expanding caps.

Also like I said before, if you run off two separate drives, it should help. Both of those applications you mentioned (AVS and uTorrent) are very bandwidth and hardware stressing.

BSOD is also a very non-descript statement. There are many types of blue screens. It's like saying you get an error message. Well what kind of blue screen. What does it list as the reason?

Link to comment
Share on other sites

I've uploaded the dumps fromt hose BSODs... Check the first post for links. The voltage seems to be fine (at least BIOS shows nothing suspicious). No burning marks. And as I sad - I DO run sepearate drives... Like 7 of them :-D With PSU on 1200 Vatts :-D

Though... I've disabled caching of disk rights in uTorrents 2.2 adn there was no BSOD for over 8 hours now... So even if it's really a HDD or controller issue - it WAS caused by uTorrent. So, if the chaching logics were changed by developers - they defenetely have to check the dumps.

Link to comment
Share on other sites

Those dumps are way too big to be useful, a mini-dump of like 500kb is all that's needed. As for what I asked, the reason listed on the bluescreen, use bluescreenview to look at all the previous crashes on your system.

If you're running 7 separate drives, then it's probably taxing your controller as well.

And I don't think you understand power supplies. 1200 watts only means that it is capable of that much more damage when it blows (although I have a hard time believing you have an actual 1200w continuous PSU). It's the voltages on each line you should be checking not the wattage. (+12, -12, +5, -5, +3.3)

Link to comment
Share on other sites

Well... I can see the file... And it's ready to be downloaded... http://www.megaupload.com/?d=KTQXRKS3

Here is the latest (just a few minutes ago) BSOD on csrss.exe:

==================================================

Dump File : 092010-80558-01.dmp

Crash Time : 20.09.2010 8:36:59

Bug Check String : CRITICAL_OBJECT_TERMINATION

Bug Check Code : 0x000000f4

Parameter 1 : 00000000`00000003

Parameter 2 : fffffa80`0a09b060

Parameter 3 : fffffa80`0a09b340

Parameter 4 : fffff800`02fe15d0

Caused By Driver : ntoskrnl.exe

Caused By Address : ntoskrnl.exe+70740

File Description : NT Kernel & System

Product Name : Microsoft® Windows® Operating System

Company : Microsoft Corporation

File Version : 6.1.7600.16617 (win7_gdr.100618-1621)

Processor : x64

Computer Name :

Full Path : C:\Windows\Minidump\092010-80558-01.dmp

Processors Count : 4

Major Version : 15

Minor Version : 7600

==================================================

All the minidumps, I have say that the crash was caused by ntoskrnl.exe

Link to comment
Share on other sites

BSOD = drivers or heat from hardware.

I tried the win7 sp1beta and can now actually play pc games and much more stable than non SP1beta version.

Install ipv6 / utp in utorrent then disable ipv6 in networking if your isp does not support it. Likely only on university lan or New Zealand should use it. ipv6 caused router wifi connection time-outs with wep / wpa.

Restore files rather Win7x64 SP1beta or use system restore to a time before you had this issues.

Speedfan should show temps, speeds, voltages in default or exotic tab.

I think you might be able to run it in xp mode in a type of a sandbox and see if utorrent does the same.

Link to comment
Share on other sites

IPv6 is disabled. It was disabled long, long ago...

I can see temps, speeds and voltages through other apps and they are fine.

XP mode is not a solution, even if it works, since all the apps I have ahve Win7 support.

How to restore the files? No matter from SP1beta or from disk... And I o not meand through sfc... I need something else..

Link to comment
Share on other sites

Just checked HDDSentinel. It says that my system drive has 52% of health. And the following: There are 88 weak sectors found on the disk surface. They may be remapped any time in the later use of the disk.

My question is: is it possible to somehow forcefully remapp those sectors? It's just this drive is IDE and I see no point in changing it... And I have noe more sots for SATA.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...