Jump to content

Utorrent 2.0.4 causing entire home network to stop working


sethiol

Recommended Posts

I have used various versions of Utorrent since 2005. I have never had this issue before and it seems to be common with 2.0.4. When its active on my computer, my wife's computer (not running Utorrent and a Win7 x64 machine wired directly to a Linksys WRT54G2 router w/ Windows firewall) and my computer (running Win7 x64; wired to same router; on Comodo firewall, no windows firewall; AV is MSE) both loose connection via any internet browser. Utorrent continues to work properly but even its own updating is interrupted by the program. I have followed the troubleshooting guides posted here. Ignored the sections about half open connections as these do not work with Win7. I have uninstalled 2.0.4 and started running 1.8. Problem disappeared.

•Color of the network status light in µTorrent's status bar (at the bottom of the µTorrent main window)

Green

•What the port checker from the Speed Guide writes

Port properly forwarded

•What the Speed Guide shows your settings to be (press Ctrl+G in µTorrent)

Current Settings: 376.83 kB/s

Upload Limit: 46.0 kB/s

Upload Slots: 4

Connections (per-torrent): 80

Connections (global): 230

Max active torrents: 3

Max active downloads: 2

•What you have net.max_halfopen set to (Preferences > Advanced in µTorrent), and if you ever modified TCPIP.sys, what you patched the limit to

Did not change

•Operating system installed (Windows XP, 2000, ME, 98, 95, NT? Something else?)

Win 7

•Security software installed (firewall, antivirus, antispyware, antiadware)

Comodo, MSE

•Exact router model(s), and exact modem model

WRT54G2

•ISP (Internet Service Provider) being used

Allegiance Communications

•Connection type (DSL, cable, dial-up), and the results obtained from the speed test (when running the Speed Guide), for both download AND upload.

Download 10Mb/s

Upload 2 Mb/s

My computer, its hardware and configuration are not at issue here. I have shown by a good working 1.8, that my system is not at fault. There is something in 2.0.4 that I need to fix and am not sure what the problem is. I appreciate you assistance in fixing this. thanks in advance.

Link to comment
Share on other sites

I tried rafi's Migration guide and it seems to have worked. But now my speed is alil slow. Alot of connections timing out. Guess its time to go back through some of the guides again and figure out which of the items I changed needs to go back or what to change. Would really like to know whats choking my home network in utorrent, to the point of not letting any of my browsers on any of my computer to connect.

Link to comment
Share on other sites

I reused the setup guide and things are "working". Browsers seem to be doing alright on both computers. But I am still having issues with trackers that I wasnt having before. I am going through threads and trying different things. Coming to the conclusion that Allegiance Communications is blocking /announce on downloads. I have a couple torrents I am seeding and the htt p://tracker.publicbt.com/announce is working on seeded torrents but not on torrents I am downloading. And its the only tracker that is working on seeded torrents.

Link to comment
Share on other sites

I reused the setup guide and things are "working".

Great! About trackers - I can just comment, that unless your ISP is messing with it, I've always noticed uT having somewhat unreliable communication to them when downloading.

The latest "incident" the uT devs handled was a serious bug with the retry mechanism that has caused them to re-release 2.04 (see the changelog). And... knowing their bad field record with testing - it wouldn't surprise me a bit to hear from you that there is still some yet-hidden issue in that area :P Sad... :(

My only suggestion is that you verify you have indeed followed my guide/tips for setting "include overhead in the rate limit". It can help with leaving some free bandwidth for tracker related communication and not flooding your connection.

Good luck :)

Link to comment
Share on other sites

After some screwing around and time, I have discovered that its not all trackers. Just a large majority of them that are not working. Furthermore, some work some of the time on a few torrents and not at all on others. Same tracker, but different connection states. Even after attempting to reconnect.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...