Jump to content

2.0.4 ignore upload speed limit


neu

Recommended Posts

If "upload limit for uTP connections" not set up then local limits for the torrent do not work.

I have "global upload limit" set to 0, but local upload limit for torrent I am setting up for example to 2, and if "upload limit for uTP connections" is set up everything is ok, but if it is not set then upload speed not limited.

Link to comment
Share on other sites

It is a bit difficult to test only on TCP connections because all my torrents have uTP seeds. But on previous versions of uTorrent local limit for upload worked. And even now if I have global limit for uTP connections local limit also work.

I think that local limit should also work with uTP connections.

Link to comment
Share on other sites

I understand, but if I set global upload limit to 50 and then local upload limit for one torrent to 10 then limit will be 10. 50 for all torrents but for one not more than 10 even if it will be the only one. But it do not work with uTP connection, you think it is logical?

Is it possible to set no limits for download (include uTP) and some limit for upload?

Link to comment
Share on other sites

But it do not work with uTP connection

It does so, if you set pref.->bandwidth->"apply rate limit to uTP connections". Did you do that ?

If I set global limit for uTP connections it works as I said, but the question was about local limit for individual torrent. My opinion was that when I set up limit for individual torrent upload speed it should include uTP connections speed.

Link to comment
Share on other sites

If I set global limit for uTP connections it works as I said, but the question was about local limit for individual torrent. My opinion was that when I set up limit for individual torrent upload speed it should include uTP connections speed.

Oh, man! but don't you see? You're saying it yourself!

The reason why uTorrent is not including uTP connections when applying the limit (globally or for individual files) is because you're telling it not to do it. If you uncheck that option, you're basically saying "hey uTorrent, when you're calculating limits turn a blind eye to any uTP connection, ignore them." Then, when uTorrent does just that, you can't complain about it.

What you're experiencing has nothing to do with global/individual limits. The only reason you're seeing this effect exclusively on individual files is that you DON'T have a global limit set. If you were to limit you're global limit somehow, you'd see that the same thing happens.

To be ultra clear about this, an example:

Case:

-limit set to 50kbps, option to include uTP uncheck, healthy torrent with both TCP and uTP connections

Result:

-the transfer speed for all TCP connections combined won't exceed 50kpbs, uTP connections are not limited so they can easily reach another 50kbps. In total, you would see you a transfer speed of 100kbps. It's not a bug, it's what you're telling to do.

Link to comment
Share on other sites

Actually, there's nothing from the above poster's information that suggests uTP would have another 50 KiloBYTES/second upload to play with. It might have more, it might have less. Considering the average speeds of many ADSL and cable lines...probably less. Most of them don't have over 1 megabit/second total upload bandwidth and are VERY lucky to have over 60 KiloBYTES/second total upload speed usable.

Link to comment
Share on other sites

Actually, there's nothing from the above poster's information that suggests uTP would have another 50 KiloBYTES/second upload to play with. It might have more, it might have less. Considering the average speeds of many ADSL and cable lines...probably less. Most of them don't have over 1 megabit/second total upload bandwidth and are VERY lucky to have over 60 KiloBYTES/second total upload speed usable.

Yeah, good call clarifying it. I probably should have used another number just to stress that it had nothing to do with the first "50" but it was the first number that popped to my head.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...