Jump to content

Cannot properly close uTorrent or remove torrents


Recommended Posts

Right now, i'm using uTorrent 2.0.4 with WINE on Ubuntu 10.04. Recently i've been having some really annoying problems with uTorrent.

First off, i cant close the program without terminating the process in the System Monitor. Right clicking on the tray icon, nor hitting File-->Exit work. Also, I cant seem to remove torrents from uTorrent at all. I can download them (and the files work properly) but i cannot take them out of my torrent list.

I haven't had this problem before, but i'm not sure what I've done differently to cause this problem. I tried redownloading the uTorrent .exe file to no avail. I even tried out the beta version but that one wouldn't even start for me.

Any help is greatly appreciated. Thanks

Link to comment
Share on other sites

I have exactly the same problem as llamas612.

I used Wine 1.3.4 and somehow I installed uTorrent, however, when I rebooted the server, I could not start utorrent. I tried in every possible way, and then I downgrade Wine to version 1.2.1, but still can not run or reinstall utorrent. I can not even start the installation with Wine loader.

Any advice is more than welcome.

Link to comment
Share on other sites

  • 2 weeks later...


I have the same problem. Glad to know it's not JUST me who has.

I am on uTorrent 2.0.4 on wine-1.3.4-1.fc13.x86_64. My OS is Fedora 13 64-bit. The OS is patched up to date.

When I start uTorrent from the command line, I notice when I click the "Remove" red X in the toolbar that the following appear in the console from which I started it:

fixme:commctrl:TaskDialogIndirect 0x7bf0ac, 0x7bf118, (nil), 0x7bf11c

If I right click a torrent and click Remove, then I get:

fixme:commctrl:TaskDialogIndirect 0x7beeec, 0x7bef58, (nil), 0x7bef5c

Incidentally: I also cannot do an "open containing folder".

I see that there are also posts on WineHQ about the same error. There is a bug logged for confirmation boxes that do not appear.


There is a workaround if you run "winetricks" and enable cc580 (commctl32 ver 5.80). Sadly this doesn't work with 64-bit.

You can download winetricks from


It's a shell script - just run it with

sh winetricks

to get a (bad) gui, or

sh winetricks --help

to get a usage message.

I hope that this will help someone ...

Link to comment
Share on other sites

Thanks a lot louisvd. It worked for me (i'm running 32-bit) and now uTorrent is working as it should.

Anyone having this problem should just download winetricks off of synaptic (or whatever you use), run it, and then install "MS Common Controls 5.80".

I should mention that when i initially tried this, uTorrent would crash immediately whenever i would click on a running torrent. It would give me an application dump file, then reopen itself, and proceed to crash again. In order to remedy this, I went into the Wine configuration, clicked libraries, chose the commctl32 library, and then changed it from "Native, then Builtin", to "Builtin, then Native". I have no idea what that did, but i just tried it and it fixed my problem.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...