Jump to content

µTorrent 2.2 released


Firon

Recommended Posts

2 days ago I updated to the new 2.2 build 23703...when it prompted me to do so. I don't like it. I liked it before. don't like the new fancy coloring or the fact that I cant customize the top bar, name, size, seeding etc. I had it how I liked it. now it's all changed. I'd like to go back to previous version. were I right clicked on that bar and and could check what I do and don't want displayed.

No offense to the designers, but for me I just liked it the way it was. Thought the update just made the program more efficient, not change the whole format.:| Can I delete it and go get the older one, or undo the update??

Link to comment
Share on other sites

  • Replies 522
  • Created
  • Last Reply

Top Posters In This Topic

Exactly Zarggg.. uTorrent is and has always been extremely customizable. A little investigation reveals that everything new/undesirable can be avoided (browser bars, etc), disabled (apps, search redirect), or hidden (find pane, and pretty much every other UI element you can imagine).

The only thing that I do find kind of vexing - and this is my only real grievance with uTorrent, ever - is the resetting of my columns setup every time they change something there.. surely there must be a future-proof way to implement the columns.

Anyway, in summary, people really need to spend a little time exploring and understanding the programs they use..

Link to comment
Share on other sites

osmosis.. thanks a bunch!!! looks normal now

one quick question. a few things changed on that bar. Name,date added etc. not sure what you call it. but some time ago I found where I could customize it, add or remove categories by checking or un-checking them.

I can't seem to figure out how to do than now. I think it was by right clicking on the bar but than isn't doing anything now.

Link to comment
Share on other sites

For me, the most annoying thing about the new µTorrent is the change of the relocate feature.

"Improved set download location/relocate feature (now moves files for you)" - please make this optional or add another command to use the old way.

See here for more details: http://forum.utorrent.com/viewtopic.php?pid=549460#p549460

Same here. It totally messes up how I manage files to different drives after I've verified the download (IE I seed the entire contents but I don't want all the stupid text files, samples, etc in the same location as the actual media I'm interested in).

Having uTorrent move the files for you is fine and in some cases would be great but it should also work when you move them manually and individually.

It seem that the new feature is buggy as well. I've found that uTorrent will often copy the files to the new location but still point to the original location.

Back to 2.0.4 for now :(

Link to comment
Share on other sites

This new "Improved set download location/relocate feature (now moves files for you)" feature has forced me too to return to v2.0.4 .

I too cross-seed many torrents.

Until now it was a simple matter to point utorrent to a pre-existing file and 're-check' to seed.

Or in some cases to point utorrent to a non-existing file and download a small piece without overwriting the different file and corrupting an already finished and seeding torrent.

Suddenly I'm finding myself unable to use a feature I've been using almost daily for a very long time.

Instead of adding another menu item to 'move' files, this reliable and needed feature has been overwritten and now all those complaints about having to move files manually and then pointing utorrent to them which brought about this new feature apply to me (with extra complications).

utorrent was very reliable in that it never moved/renamed/deleted files unexpectedly now its starting to loose that reliability not to mention that trying to use this feature seem to make it unstable and causing it to freeze.

I would love a 'move' feature for entire torrents as well as for single files especially if it can be used on a running torrent while keeping it seeding/paused without forcing a full stop/re-check.

But I'm requesting and begging of you however you choose to do it, implement it separately from the old 'relocate' feature and allow us to use newer versions.

Link to comment
Share on other sites

this version definitely broke UTP trackers with SOCKS5 proxy

I have a socks5 proxy (with authentication) running at home, and I used to bypass my uni firewall using the socks5 proxy

it worked great until I installed the latest 2.2 utorrent client, and all I got was connection timed out.

Downgraded to 2.0.4 and I'm happy with the old version

Link to comment
Share on other sites

This new version has issues, torrent speeds are slow thats if they even download at all i cant browse the internet while using uttorent and max speed is 100kB/s ocasionally it picks up to 300 for a minute but then drops back down i have a 20MB connection, the same thing is happening on my netbook . I just reinstalled windows 7 to scared to put this version on again going back to 2.04 . So to all those EXPERIENCED USERS sending people to speed issue thread dont bother its the NEW VERSION

Link to comment
Share on other sites

This new version has issues, torrent speeds are slow thats if they even download at all i cant browse the internet while using uttorent and max speed is 100kB/s ocasionally it picks up to 300 for a minute but then drops back down i have a 20MB connection, the same thing is happening on my netbook . I just reinstalled windows 7 to scared to put this version on again going back to 2.04 . So to all those EXPERIENCED USERS sending people to speed issue thread dont bother its the NEW VERSION

Ok i did like the new interface in 2.2 but their were to many bugs it was working ok for a few days, i just put 2.04 back on and speeds returned to normal torrents are actually downloading whoa!!!!!400+ kB/s and i can browse the web while downloading torrents :D

Link to comment
Share on other sites

This new version has issues, torrent speeds are slow thats if they even download at all i cant browse the internet while using uttorent and max speed is 100kB/s ocasionally it picks up to 300 for a minute but then drops back down i have a 20MB connection, the same thing is happening on my netbook . I just reinstalled windows 7 to scared to put this version on again going back to 2.04 . So to all those EXPERIENCED USERS sending people to speed issue thread dont bother its the NEW VERSION

I'm not an expert but i did notice when i gave 2.2 a chance (i stopped using it for different reasons you can see my post above) that in advanced settings "bt.transp_disposition" had been affected by the upgrade and needed to be reset to default, I'm guessing its because more values have been added.

If you upgraded without keeping your settings you might want to check for other changes.

Link to comment
Share on other sites

If the system is connected to internet, utorrent is in processes list (task manager) for a while after exit.

If the system is disconnected from internet before exiting utorrent, then it is there in processes list for ever after exit.

Link to comment
Share on other sites

Okay, I keep getting the error "Element not found", I have done force recheck several times but as soon as one piece finishes downloading of the torrent it gives me the error again. I have never had this problem with any of the old versions of uTorrent, that's why I'm posting this here, and am thinking of trying the torrent on an old version to see if it will work that way. I have looked at most if not all of the older posts about this error but they all seem to suggest that it is due to them moving/deleting the files in the torrent, but I have not touched any of the files in the torrent so I know it can't be this unless uTorrent moved the files or is trying to move them, more likely the latter as all the files are in the folder. If anyone can help with this that would be a big help, I don't like to downgrade programs, especially when I like and am used to the upgrade. On a side note, I'm just wondering if a "Semaphore time out" error can be caused by a bad cable going from the drive to the motherboard? Thanks for the help in advance. :)

Edit: uTorrent 2.2 now crashes when I try to start it and usually takes my PC down too I will go back to an older version to see if that fixes this problem and the element not found error. Also the element not found error started happening to several more of my torrents non of which I had touched since I started downloading them.

Link to comment
Share on other sites

I updated about 2 weeks ago to the latest build which was 23774. But now the download link gives an older build, 23703. Is there any reason for that, something wrong with build 23774 and was it removed?

Should I downgrade to 23703 or it's just something wrong with the download link?

Link to comment
Share on other sites

I have the following problem:

If I select the option Close to tray and then close and restart uT even once or restart it with Windows, the uT window does not appear any more.

The process is running, but the system tray icon does not appear and there is no way to activate the uT program window, except deleting settings.dat and settings.dat.old.

I use uT 2.2.0.23774 on Windows XP SP3.

P.S. It is possible that I had both Close to tray and Minimize to tray checked, but I think that did not caused problems before.

* * * * *

Regarding other issues mentioned above by other users, I have not encountered any of them, but :

a) I never Enabled bandwidth management [uTP] ( my bt.transp_disposition is 245 ) and

B) My bandwidth, connections, peers no. &c. settings are at the maximum.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.

×
×
  • Create New...