Jump to content

Error: Insufficient system resources


Recommended Posts

  • Replies 83
  • Created
  • Last Reply

I'm using XP Home. I have a new anti-virus/anti-hacker system (Kaspersky), but up until just after I downloaded the update, it didn't interfere and worked fine. I've tried restarting the program and the computer, to no avail. I don't see anything that could be hooked into the process.

Link to comment
Share on other sites

As an aside, I (not the original poster) have wdmaud.drv there as well. Am assuming this is because I clicked on one of the Easter Eggs? (the one that makes the sound) If so, shouldn't this thread be killed after the window that produces the sound goes away?

Link to comment
Share on other sites

  • 2 weeks later...

I'm having the same errors. Just out of the blue that error comes up and those torrents currently downloading get stopped... I start them again and they work for a while (10-20mins). I've never had this problem, nor anyothers before yesterday. Also, I have not started any new torrents, just the old ones, if that helps.

XP Pro

2gigs ram

120gig HD with 250gig ext. HD

if you need any other info please ask I'm happy to let you know... I'll try and send a screenshot if you want next time it happens.

Link to comment
Share on other sites

Well hi there again. I'll add my system-load releated problems here too...

As mentioned n times, since the "io code optimisation" the disk-overload messages disappeared and the situation got better. But then again, the slowdown, which I am having when uploading @1MB/s, is disastreous... Downloading dosen't stress the HD so much (yeah, HD-only, CPU usage is 4% or so...) as uploading - this is obivious becouse of the nature of access frequency, etc.

My read cache is set to 102400, so 100MBs. µTorrent proudly states, that it's 99% effective. And I agree - the HD isn't accessed very frequently (as it would be with Read Cache turned off). But the problem shows itself when another program tryes to access data on my HD, for example - I start Firefox. Man, it takes from 3 times normal to ... times to start! Thunderbird, winamp, even browsing my folders with Win Eplorer is a pain in the a**.

It isn't lagging as soon as it µTorrent starts uploading. Some minutes after that. And if there is more than one user leeching from me... Whoa, help me with my slow system...

Caching? Lot's of open handles to disk? Dunno...

Info, if needed:

W XPsp2 with all updates, blah blah

NOD32 2.51.20 with utorrent in IMON's exclude list. No fiewall (behind a linux router box)

µTorrent v. 1.5 build 137

Athlon 1600+, 512mb ddr, 80gb seagate barracuda

Process explorer shows 4 utorrent.exe threads, sometimes winsock popping up, but it isn't hd releated.

If it helps, µTorrent is the page-fault king on my system (currently 238k faults vs. 33k. of some other app.)

Damn, I would beg Ludde to see the caching/uploading/IO system again, but that's kinda stupid :D So I'll ask for it.

Thanks, have a nice morning/day/night.

Link to comment
Share on other sites

[quoting the previous post is spam - quote removed]

Yay, thanks for this stab. It's a thingy I wanted to try, but never knew it was there :D Will see what happens when some bastards try to leech from me...

EDIT: same (if not worse :D ) problems. But will try with flush_files -> false longer, too early to make some conclusions.

Link to comment
Share on other sites

First of all... Quoting previous post is spam - that's new for me, this isn't a WAP forum or anything. But oh well, now I'll know the rules.

Secondly, the situation after disabeling flush_files didn't get much (or any?) better. The time needed to close a firefox tab is ~10secs., scary.

When I'm uploading to my server ~10MBs the lag on my pc is not as big as with cached(!) µTorrent with 10x smaller speeds. Ech... well, I hope this problem will go into Ludde's "to-do" or some other list.

Thanks ;)

Link to comment
Share on other sites

TCPIP.SYS doesn't have anything to do with this. Logically thinking, increasing the max. conns could only cause a network overload or a better network performance. No disk-load decrease ;)

OK, I've set the diskio.read_cache_size to 0. This means no caching. This means my hd will be read too much. This isn't a fix, it's just a "maybe this will help decrease your load, but will hammer your hd". I would like a fine working caching system, not a workaround...

Of course, this could be my harware-releated problem, but lots of users my trackers users are having the same problems (with speeds at 1MBs), so I don't think so.

Will see what load will bring d_io.r_c_s set to 0 :)

EDIT: Frion > there is allways ~100mb available.

Link to comment
Share on other sites

OK, stupid me. Have tought this over, have watched the system memory load... True to say that my ammount of ram is at fault.

This "<...>the problem shows itself when another program tryes to access data on my HD<...>" I mentioned above is a cause of swaping the memory to disk. Burb, but why does it swap so much... The question I have now :D Will try to investigate and stuff... But, of course, adding some RAM is the best method.

Thanks for your help.

Link to comment
Share on other sites

  • 1 month later...

yesterday i suddenly started getting this error (i made a new xp installation and im sure not everything is tuned up), but its definitly not a memory problem for me. i have 3 GB ram.

what i would like to see is utorrent write to the log what resource is it unable to obtain, whether log and verbose are turned on or not.

would definitly point you in the right direction as to what actions you need to take.

Link to comment
Share on other sites

  • 2 months later...

same problem - Error: Insufficient system resources exist to complete the requested service.

i have bad feeling it has something with miranda im (only these two progs have problem when this happend) - can it be possible ? and solution ...


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...