Archived

This topic is now archived and is closed to further replies.

HellMind

Debug, No Error, It doesnt start to download the torrent

Recommended Posts

Where can I se the error :(

utserver.log just say

[09:14:34] GetNodeID failed, using /dev/random

[09:14:34] IPv6 is installed

On gui says

Error: ??

Where can I see the error?

Share this post


Link to post
Share on other sites
Where can I se the error :(

utserver.log just say

[09:14:34] GetNodeID failed, using /dev/random

[09:14:34] IPv6 is installed

On gui says

Error: ??

Where can I see the error?

Have you tried setting the logmask configuration setting to

0xffffffff

(8 F's) in the configuration file? That should generate more output, although I'm not sure it will provide more information for your problem.

Could you post the results of uname -a and ifconfig (omit the IP and MAC address if you want; if you do just let me know if the values displayed were valid or not), and specify if the version of Linux you run is 32-bit or 64-bit? The GetNodeID failed message indicates that there's something unusual about your installation. The failure indicates the program's inability to obtain information on the network interfaces on your computer.

I don't know why you see the Error: ?? in the web UI. Figuring out the GetNodeID problem may provide an answer to that question.

Share this post


Link to post
Share on other sites

I 've set

logmask: 0xffffffff

on

userver.conf

Nothing changes.

Linux downloader.com 2.6.26-2-openvz-686 #1 SMP Thu Sep 16 22:16:19 UTC 2010 i686 GNU/Linux

root@downloader:/home/utorrent/utorrent-server# ifconfig

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:1644104 errors:0 dropped:0 overruns:0 frame:0

TX packets:1644104 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:87450213 (83.3 MiB) TX bytes:87450213 (83.3 MiB)

venet0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00

UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1

RX packets:65165468 errors:0 dropped:0 overruns:0 frame:0

TX packets:81354093 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:1605547691 (1.4 GiB) TX bytes:3385737499 (3.1 GiB)

venet0:0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00

inet addr:192.168.0.4 P-t-P:192.168.0.4 Bcast:0.0.0.0 Mask:255.255.255.255

UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1

its a openvz container

32bit

Share this post


Link to post
Share on other sites
Linux downloader.com 2.6.26-2-openvz-686 #1 SMP Thu Sep 16 22:16:19 UTC 2010 i686 GNU/Linux

root@downloader:/home/utorrent/utorrent-server# ifconfig

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:1644104 errors:0 dropped:0 overruns:0 frame:0

TX packets:1644104 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:87450213 (83.3 MiB) TX bytes:87450213 (83.3 MiB)

venet0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00

UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1

RX packets:65165468 errors:0 dropped:0 overruns:0 frame:0

TX packets:81354093 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:1605547691 (1.4 GiB) TX bytes:3385737499 (3.1 GiB)

venet0:0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00

inet addr:192.168.0.4 P-t-P:192.168.0.4 Bcast:0.0.0.0 Mask:255.255.255.255

UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1

its a openvz container

32bit

Your uname -a and ifconfig output were helpful. Apparently openvz doesn't associate a MAC address with its active virtualized interfaces. That is what causes the GetNodeID failure message. However, that probably isn't associated with the Error: ?? messages you are seeing. I've added an entry to our issue tracking system to ensure an explanatory log message is generated when a torrent enters or is determined to be in the error state.

Share this post


Link to post
Share on other sites
Same problem with the last version:24118

When utorrent will be stable on an openvz container ?

There isn't any testing of uTorrent Server being done using an openvz container, so I won't be able to give you that answer.

However, the next release (undetermined date) will have code that generates a log message whenever a torrent transitions to an error state. That should help you diagnose the problem.

Share this post


Link to post
Share on other sites

I have a same error:

[08:32:47]  Using locale en_US.UTF-8
[08:32:47] GetNodeID failed, using /dev/random
[08:32:47] total physical memory -1 max disk cache 33554432

It worked till 2 days ago.

How can I fix this!?

Share this post


Link to post
Share on other sites