Archived

This topic is now archived and is closed to further replies.

The_Adventurer

µtorrent kills the internet connection

Recommended Posts

oooh don´t go there...If it is so that you think that you can blame every users modem everytime they got a problem,you better think of a better answer as a admin.I know that if im not happy with the utorrent client i should stop using it.But after all its the best client i have tried yet.But its disturbing to hear the same answer at every question at this forum.There must be some kind of problem with the client,when there is so many users that have problems with the mostly same thing?(damn my english is bad).Mikey

Share this post


Link to post
Share on other sites

That's because most modems/routers can't handle the enormous strain BitTorrent puts on them, and yes, µTorrent does stress them more than other clients...I don't know how many times I have to repeat this for it to be understood. :|

Share this post


Link to post
Share on other sites

Well, I limited all possible fields to ***1*** and still it kills the internet connection.

And it has been that way since 1.4 stable, which was the first version I used.

Listen up people, please get this topic to Luddes attention.

With setings that rediculously low, it just can't be the router anymore.

Share this post


Link to post
Share on other sites

After downloading a couple of torrents without any problems, I started getting disconnected from my wireless connection (DWL-G520 card, DI-624 router) everytime I started utorrent. This started happening as the third file I was downloading was nearing completion.

I'm running Windows XP SP2, and utorrent is on the exceptions list, but I tried turning it off to see what would happen. As soon as I turned it off, I seemed to stop getting disconnected.

I should note that I've only just installed utorrent today, and so I can't say for sure whether I was just having temporary problems, or if my solution is also temporary. I'll keep everyone posted.

Share this post


Link to post
Share on other sites

My netgear WGT624 just cant handle this utorrent upgrade. What routers do you Moderators recommend...

I've done all the options suggested in the FAQs yet it still cant handle the connections (Even before the new protocol it was acting up).

I hear the D-Link DGL-4300, Link is a good router however I need more info since reviewers often dont tell how many connections a router can take.

Share this post


Link to post
Share on other sites

Price isnt a concern :)

Just saying that upfront.

Btw i guess you have a personal experience with it?

Share this post


Link to post
Share on other sites

I have a WRT54G V3.1, works great, just replace the firmware. The WRT54GL is a rebranded WRT54G v4 (the last Linux based version)

Share this post


Link to post
Share on other sites

Christ i have never known so many people to feel affended after being told that they have bought shitty equipment.

Here is some info for u.

i have an 8Mb/768Kb ADDSL connection.

i used to use a Dlink Gamer Lounge modem/router. <<< SUX it cant handle the amount of connections that 4 users would need and dropped put all the time.

NOW i have a Linksys AG241 Gateway and a Linksys Wifi router. <<<< BRILLIANT i still let 3 other people use my line and it hasnt dropped my connection once in the 6 months i have used it.

//rant

NOW GET A GRIP PEOPLE, IF U ASK FOR AN HELP AND OPINIONS DONT MOAN AND CRY WHEN U DONT LIKE WHAT U HEAR. GO DO SOMETHING ABOUT IT, LIKE NOT BUYING SHITTY EQUIPMENT.

// end rant

hope this has been helpful and worth while :D

Share this post


Link to post
Share on other sites

I'm having the same problem here.

This only happend in ut 1.5 437, in ut 1.4 there was no problem.

The simtoms are that your browser can not load all the images or does not load

the page at all.

If you pause all torrents in ut, wait 10seconds and click Reload in your browser,

all works fine again.

It is not a router problem, in ut 1.4 this was not an issue. I use the same

ul/dl speed and my router is a 3Ghz P4 with 512/512kbps

Thanks

Oliver

Lower your net.max_halfopen and bt.connect_speed.

This is a nice tip, first technical help of the topic BTW.

I have net.max_halfopen = 8(was 50) and bt.connect_speed = 20, is that high, normal or low?

Thanks

Oliver

Share this post


Link to post
Share on other sites
I'm having the same problem here.

This only happend in ut 1.5 437, in ut 1.4 there was no problem.

The simtoms are that your browser can not load all the images or does not load

the page at all.

If you pause all torrents in ut, wait 10seconds and click Reload in your browser,

all works fine again.

It is not a router problem, in ut 1.4 this was not an issue. I use the same

ul/dl speed and my router is a 3Ghz P4 with 512/512kbps

Thanks

Oliver

that is symptoms for an unpatched tcpip.sys

BTW ur double posting again

Share this post


Link to post
Share on other sites
Christ i have never known so many people to feel affended after being told that they have bought shitty equipment.

Here is some info for u.

i have an 8Mb/768Kb ADDSL connection.

i used to use a Dlink Gamer Lounge modem/router. <<< SUX it cant handle the amount of connections that 4 users would need and dropped put all the time.

The router I mentioned is just a router no Modem feature with it. A friend I know has it she can have 3 computers running, 2 of them using utorrent with about 4 torrents each with default number of connections. Maybe you could tell me the model number of the one you had?

Share this post


Link to post
Share on other sites

oliversl: 8 and 20 are the defaults. Many routers/modems can't handle higher than that. And raising them with an unpatched tcpip.sys will cause severe problems.

Share this post


Link to post
Share on other sites
oliversl: 8 and 20 are the defaults. Many routers/modems can't handle higher than that. And raising them with an unpatched tcpip.sys will cause severe problems.

Hi Firon, I patched my tcpip.sys to 50, thats why I was using 50 in ut 1.4, but using 50 in ut 1.5 seems to kill my WinXP conection.

My Linux router is a 3Ghz P4 Linux box, so, is not a problem of my router.

There is something in ut 1.5 that changed from 1.4 and that indeed saturate your WinXP conection/tcpip stack/or something else.

Now at 8, it seems to be fixed now. Will keep posting updates about my results

Thanks

Oliver

And that's why there are several BitTorrent clients to choose from. ;) If µTorrent ain't working for you, try Azureus, it also has the same Encryption scheme.

People report here because they want to use ut, and they want ut to be "fixed".

There are crappy hardware, but there are also bugs in software.

If all other clients works on other pleople's PC and ut don't, then, there is a problem

in ut. Don't take it personal when people says that ut has a bug. Bugs are normal,

they are not an insult.

that is symptoms for an unpatched tcpip.sys

BTW ur double posting again

It is patched to 50 ;)

BTW, show me(only one) 1 big forum that was that "double post" rule ...

I have done everything that matched my configuration, that is deactivated DHT in all ways, deactivated peer exchange etc etc.

I do not change values manually, but rather let the speed guide selection do it's magic.

And as I've told, lowering it to xx/128 even didn't do the trick.

And it can't be Torrent alone, why does Azureus then work?...

What are your values in:

net.max_halfopen

bt.connect_speed

Oliver

Share this post


Link to post
Share on other sites
Hi Firon, I patched my tcpip.sys to 50, thats why I was using 50 in ut 1.4, but using 50 in ut 1.5 seems to kill my WinXP conection.

you should never use ur max half open the same to utorrent, you should use less than those, see how normally unpatched windows has half-open to 10 and utorrent uses 8? that's so it wont use all of them and leave somethen for other apps, so using 50 as my windows half-open, i set utorrent to use just 20 and everything goes just well, i've even tried 38 and perfect.

People report here because they want to use ut, and they want ut to be "fixed".

nah, i've normally seen as many "i'd like utorrent was like this or that" as "i'm not using utorrent until it's the way i like it"

BTW, show me(only one) 1 big forum that was that "double post" rule ...

i believe u meant a big forum that HAS that rule

well, now that u mention it, i dont recall any forum that doesnt use that rule :/

Share this post


Link to post
Share on other sites
you should never use ur max half open the same to utorrent, you should use less than those, see how normally unpatched windows has half-open to 10 and utorrent uses 8?

thanks for the info. I'm on 8 right now and will try 20 and 30 next time. Will post the results

nah, i've normally seen as many "i'd like utorrent was like this or that" as "i'm not using utorrent until it's the way i like it"

I had net.max_halfopen=50 in 1.4, it seems that ut 1.5 uses better the net.max_halfopen, thats why this problem appears in 1.5 and people think its a bug.

Before telling people that they have a bad router, we should ask for their net.max_halfopen setting, I think there is the problem. A FAQ candidate ...

well, now that u mention it, i dont recall any forum that doesnt use that rule :/

link ? ;)

Share this post


Link to post
Share on other sites

Just about every forum I've seen has a no double post rule. Some forum softwares prevent you from double posting at all.

oliversl: it's possible your NIC is the one with issues. This CAN happen.

Share this post


Link to post
Share on other sites
Just about every forum I've seen has a no double post rule. Some forum softwares prevent you from double posting at all.

I just need *one* link to the rules of a big forum

oliversl: it's possible your NIC is the one with issues. This CAN happen.

It can be, I don't discard that.

My questions are:

- why net.max_halfopen=50 was wokring fine in 1.4, I never used a beta until 1.5. I have this problem only in ut 1.5

- how do I detect that the driver of my Nvidia Nforce2 onboard NIC is the problem? Also, I only have 512kbps internet conection, so, that won't saturate 100mbps of my NIC.

BTW, with net.max_halfopen=25 seems to be working fine ;)

Share this post


Link to post
Share on other sites

http://forum.ebaumsworld.com/showthread.php?t=67013

http://castlecops.com/t49434-The_Rules.html <-- first rule there

http://forums.ngemu.com/751350-post2.html <-- listed under Spam Policy

http://oink.me.uk/rules.php <-- I don't use OiNK, but I happened to see it there, so... =P

Heh I know you wanted one, but I didn't know what you meant by "big," so I found a few I consider to fit that description (not sure about OiNK, but I think it's a big community, considering how a lot of people complained when they first banned µTorrent).

Share this post


Link to post
Share on other sites

oliversl: 1.4 didn't use your net.max_halfopen, it used a lower, random value. 1.5 does.

You can always try updating your nforce drivers, or getting some NIC from a store and see if you get the same problem.

Share this post


Link to post
Share on other sites
oliversl: 1.4 didn't use your net.max_halfopen, it used a lower, random value. 1.5 does.

Wow, this solved the case for me. Thanks for the info!

I wonder if The_Adventurer can comment on this. Maybe he has net.max_halfopen too high.

You can always try updating your nforce drivers, or getting some NIC from a store and see if you get the same problem.

I don't know if I will buy a new card, I sometime trust Nvidia. Also, knowing that net.max_halfopen was not used in 1.4 answered my question and I never had any problems in the other 5 P2P application that I used in the past.

So, I was my fault to have net.max_halfopen too high, problem solved ;)

Thanks Firon

@Ultima,

thanks for the links.

indeed, they are big time forums.

I understand why they use that rule, but still, I don't understand why 3 consecutive posts that are totally different *and* have small quoted text are considered double post.

I agree that if a user post 3 *new* messages, it should be considered bad/double post/spam. But if the user post 3 replies, it should not be considered bad/double post/spam.

Share this post


Link to post
Share on other sites