Jump to content

can't start utserver on FreeNAS


Recommended Posts

freebsd != linux.

That's true. However, FreeBSD does have a Linux ABI layer - OP, were you using that? Maybe FreeNAS doesn't provide that option?

Maybe more of a problem is the 64-bit OS. I run FreeBSD on AMD64 at home, I've built a FreeBSD build of the product on that machine, but I can't run it there since the OS is 64-bit and problems show up quickly. I build the product occasionally on FreeBSD on an Intel CPU (32-bit FreeBSD in this case) at work and it is usable, but there doesn't seem to be nearly the demand for FreeBSD as there is for Linux.

Link to comment
Share on other sites

This topic seems to come up every few weeks. May want to have a sticky for FreeNAS/FreeBSD/*BSD. I wrote this last month.


FreeNAS OS its a linux based OS.

FreeNAS is a "distribution based on FreeBSD' date='" not Linux. Looking at the FreeNAS website, it does have a Bittorrent client, but its 'Transmission'.

It also have a function to install packages

I couldn't find this function in the documentation of FreeNAS, but you would know more about FreeNAS. If this 'install packages' function connects to the FreeBSD Package System, then maybe you might have access to the FreeBSD Ports Collection. Its in the Ports Collection that you would need to install linux_base (the Linux binary compatibility emulator). You're really going to have to read the FreeBSD documentation to get this to work.

Note: You could just install Wine and the Windows version of uTorrent, instead of the Linux binary compatibility emulator with the Linux version of uTorrent; since the Linux version of uTorrent is still an alpha release and its basically on the surface (without actually trying it personally) would be the same amount of effort.

Link to comment
Share on other sites

freenas doesnt have the linux module in the kernel

and i need to have that in order to load linux_base

Linux mode is not enabled.

Loading linux kernel module now...

kldload: can't load linux: No such file or directory

The linux kernel module could not be loaded.

Please enable linux mode manually and retry.

pkg_add: install script returned error status

its stripped down to the bone :(

Link to comment
Share on other sites

  • 3 months later...

I am also having the same problem as Typhoon-NL

i ran the command $ uname -a and received...

FreeBSD freenas.workgroup 7.3-RELEASE-p3 FreeBSD 7.3-RELEASE-p3 #0: Tue Nov 2 22:42:55 CET 2010 root@dev.freenas.org:/usr/obj/freenas/usr/src/sys/FREENAS-i386 i386

then i ran the command freebsd != linux, rebooted FreeNAS and still cannot get the µTorrent service to appear.

does anyone know if µTorrent will ever be supported on FreeNas, as it far more robust than Transmission

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...