Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 2.2.1 released

Recommended Posts

@ osmosis, rafi

Ок. edited :)

What should I do to the link no longer appear? - http://img34.imageshack.us/i/95265302.png/

Again ? Amatures... :P Bug the devs... again... they will never learn that getting it out of the code is much better than some complicated if statement that never works... for them...

Share this post


Link to post
Share on other sites

Sorry, new user here.

As for the discussion about the bad-tracker warnings, it does seem to me to make sense to create another colored arrow for tracker down but peers still connected. Orange or Yellow would be my suggestions. This would take care of warning users who want to know if their trackers are down, without scaring people who don't care so long as they are still downloading. Perhaps use both: Yellow for all trackers down but seeds still present, Orange for trackers down and no seeds but peers are still present (or when seeding, if you're the only seed). Or, if it makes more sense to experienced users then perhaps orange to mean that it's been down for more than two or three scrapes. As a new user, I didn't notice if you can detect percentage complete when the tracker is down. Use red, of course, for a complete torrent failure.

I don't know why when it was suggested to add another color nobody seemed to have followed up on the suggestion.

Share this post


Link to post
Share on other sites
Sorry, new user here....

I don't know why when it was suggested to add another color nobody seemed to have followed up on the suggestion.

That's cause you are new ... ;) No one ever REALLY listens to us here ... :P

Share this post


Link to post
Share on other sites

Because that's how it works for most other applications. It's not that it's just a thing of some minutes. µTorrent often seems to need several days for it ...

Share this post


Link to post
Share on other sites
Again ? Amatures... :P Bug the devs... again...

After deleting files settings (settings.dat, settings.dat.old) link "Take Our Survey" still remains. She will hide only if you click on the link. Pls fix it.

Share this post


Link to post
Share on other sites

w000t, I've never seen that link before on my setup and I've been using uTorrent for years.. Try gui.bypass_search_redirect in Advanced.. or emptying out the Search Engines list under UI Extras (makes the search box go away). Any change?

Share this post


Link to post
Share on other sites

And what is it good for ? Annoying people ? ... Giving

BT inc "good" reputation ? :(

Share this post


Link to post
Share on other sites
Try gui.bypass_search_redirect in Advanced.. or emptying out the Search Engines list under UI Extras (makes the search box go away). Any change?

Thanks I will try next time when again will appear

Share this post


Link to post
Share on other sites
Unfortunately version 2.2.x introduced again "Disk overloaded 100%" which is ridiculous since my new hard disk supports SATA 3 (6 Gb/sec hyper transfer) and in practice I have achieved about 200 MB/sec. Back to 2.0.4 and everything is OK. Tested with three blu-rays simultaneously (~45 GB) and runs smoothly. No options changed.

Same issue here on latest version... Max speed around 7MB/s and disk overload 100% - Back to version 2.0.4 = max speed 14MB/s same torrent and no overload.

No options changed, tried all settings on the new version but nothing seems to work please fix this, running latest version is no option for me (and others).

Share this post


Link to post
Share on other sites

Build 25130 couple of small things..

Priority is now a submenu and extra click, used to be fast and easy and nothing much else on the tab for it to be a space issue.

Color of downloading and complete progress bars are the same, icons are different maybe use the darker green of completed icon for completed progress bar too.

Share this post


Link to post
Share on other sites
Unfortunately version 2.2.x introduced again "Disk overloaded 100%" which is ridiculous since my new hard disk supports SATA 3 (6 Gb/sec hyper transfer) and in practice I have achieved about 200 MB/sec. Back to 2.0.4 and everything is OK. Tested with three blu-rays simultaneously (~45 GB) and runs smoothly. No options changed.

Same issue here on latest version... Max speed around 7MB/s and disk overload 100% - Back to version 2.0.4 = max speed 14MB/s same torrent and no overload.

No options changed' date=' tried all settings on the new version but nothing seems to work please fix this, running latest version is no option for me (and others).[/quote']

I am not experiencing any "Disk Overloaded 100%" notices. However, Yes, the download speed seems to be capped at around 5 to 7 MB/s. Highest it has gone is 10 MB/s. Don't know whats up with that. I have tried turning of Disk Cache but problem still persists. I have not made any changes to my preferences for the past 6 guild releases.

Share this post


Link to post
Share on other sites
Unfortunately version 2.2.x introduced again "Disk overloaded 100%" which is ridiculous since my new hard disk supports SATA 3 (6 Gb/sec hyper transfer) and in practice I have achieved about 200 MB/sec. Back to 2.0.4 and everything is OK. Tested with three blu-rays simultaneously (~45 GB) and runs smoothly. No options changed.

Same issue here on latest version... Max speed around 7MB/s and disk overload 100% - Back to version 2.0.4 = max speed 14MB/s same torrent and no overload.

No options changed' date=' tried all settings on the new version but nothing seems to work please fix this, running latest version is no option for me (and others).[/quote']

I am not experiencing any "Disk Overloaded 100%" notices. However, Yes, the download speed seems to be capped at around 5 to 7 MB/s. Highest it has gone is 10 MB/s. Don't know whats up with that. I have tried turning of Disk Cache but problem still persists. I have not made any changes to my preferences for the past 6 guild releases.

Same here, tried all kind of cache settings which i found on google and worked for other user on previous version but i can't fix it.. but then again, I do get the overload message so we could face different problems... none of this on 2.0.4 tho.

Even when i download to a network shared drive i get the 100% overload message on the latest version, no idea how that's even possible. All worked perfectly fine before.

No changes here either, never had any speed or disk issues, the upgrade to the lastes version introduced this problem, no more no less.

Share this post


Link to post
Share on other sites

^ try to disable uTP (pref->BitTorrent->bandwidth management = unchecked) and see if some of the speed issues are resolved. More tips in my sig-guide :)

Share this post


Link to post
Share on other sites

diskio.no_zero still doesn't work since 2.0.4! On file write it tries to write zeros to each byte! Imagine downloading a 20 GB file, you start downloading till you cache fills, then it utorrent starts writing the whole file with zeros, overloading HDD and freezing download. I could take a good few munutes, depending on an HDD you are using.

It was reported multiple times about this issue.

http://forum.utorrent.com/viewtopic.php?id=89780

http://forum.utorrent.com/viewtopic.php?id=91348

Please fix it. I'm downgrading again to the 2.0.4, where diskio.no_zero flag works exactly as it should.

Share this post


Link to post
Share on other sites

These sound pretty interesting. I'm interested in this SOCKS proxy support. Is there a guide on how to enable this?

I had heard to avoid proxies since they could often slow things down, but as it is I've had to cap my speeds due to usage-based billing so it doesn't really make a difference anymore.

Share this post


Link to post
Share on other sites
diskio.no_zero still doesn't work since 2.0.4!

Thanks for the report! It's on the backlog now and should be fixed within 2 weeks. At least in 3.0, we might back-port it as well, but we're getting close to 3.0 beta.

Share this post


Link to post
Share on other sites
These sound pretty interesting. I'm interested in this SOCKS proxy support. Is there a guide on how to enable this?

I had heard to avoid proxies since they could often slow things down, but as it is I've had to cap my speeds due to usage-based billing so it doesn't really make a difference anymore.

Once you have a proxy somewhere, you just open the preferences and add the proxy there. The user manual (press F1) details all the proxy options.

Share this post


Link to post
Share on other sites
Rubberkitty' date=' clear your settings and i think it'll work better. old settings and files sometimes get things messed up with the new versions.[/quote']

Who would have thought that updating would have caused so many problems?

Thanks osmosis.

I guess I should uninstall, reboot, install update from scratch from now on.

I still get get the cpu spike and program freeze when removing (large sized files ~2GB<) torrent and data though.

Manually deleting these files does not do this.

wow, terrible release. first some of the torrents from different sources I downloaded gave back a file not found error and had to update tracker manually to resume, second when finished the .!ut wouldn't go away until i shut down utorrent completly and did a force recheck, and third what is with the cpu spike and program freeze when I delete the torrent and data from within utorrent.

reverting back to 2.2 for now :(

I thought clearing the settings fixed the problems but, it is happening again.:(

Share this post


Link to post
Share on other sites

Some trackers still working when stopped the torrent ,i tried delete all setting and re-add the torrent again but the problem still.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.