Archived

This topic is now archived and is closed to further replies.

Khundire

"Invalid Request" Only in Firefox, IE8 Works Great

Recommended Posts

I am having a little (very annoying) problem with the WebUI. I have my home PC behind an ADSL modem/router and I have everything well configured. All the ports open and so on, so don't bother asking if it is a firewall problem or a port problem. I know that everything is ok (for sure!).

I am also using Dynamic DNS from DynDns and No-IP, just to make sure the problem is not in the forwarding of the IP.

This is what happens:

- I have full access of the WebUI from inside my local network, using the 192.168.x.x IPs (with both browsers Firefox and Internet Explorer);

- When I try to use the DDNS to access my PC (doesn't matter if I am inside my network or on another location) it all works fine with Internet Explorer 8 and not with FireFox. With FireFox I get the "Invalid Request" page.

Sometimes if I do the "http://YourIP:UTport/gui/?action=setsetting&s=webui.cookie&v={}" first, in the next try it works well but if I close the Firefox and try again there comes back the "Invalid Request" page. When this happens, if I use the IP number (x.x.x.x) instead of the DDNS (mypc.com) it works great all the time. But that is only sometimes...

I am pretty sure the problem is on the FireFox side (don't know if it is an option with a bad setting) since it works great with Internet Explorer 8 all the times whenever I am.

I have been messing around with the cookies options on FireFox and a little few but no results.

I do love using firefox and I was hopping not to have to use Internet Explorer only to access the utorrent WebUI, so if any of you guys (and girls :)) have any suggestion I would appreciate.

Versions:

- Firefox (3.6.13)

- Internet Explorer 8

- WebUI (0.380)

- uTorrent (2.2.1beta)

- Tried to access from 3 different PCs in 4 different locations with 3 different operating systems

Share this post


Link to post
Share on other sites

Until now it has been working without any problem... maybe the case-sensitive was one of the problems. Still have no clue on the other... let's see if it happens again.

Share this post


Link to post
Share on other sites