Jump to content

uTorrent (2.2) starting but main window not visible or in system tray


jock2734

Recommended Posts

When I start uTorrent (2.2) sometimes it does not appear to start, however checking the task manager I can see that there is a process for uTorrent running. The uTorrent main window does not show.

My torrents are located on my network drive and I find that if there is a lot of network activity on that drive then the user interface for uTorrent does not appear.

I run a SyncToy from my computer to my network drive each time my computer starts (to backup important documents). While this job is running if I then start uTorrent the main screen does not appear until my SyncToy backup has finished or I abort the SyncToy job.

Why is this happening? Can this issue be resolved in some way? What is the next step to fix this problem?

This problem has only become an issue since version 2.2 I believe.

Link to comment
Share on other sites

  • 1 month later...

Any news with this bug? I'm having the same problem... Started only recently when I upgraded to uTorrent 2.2. The weird thing is that the problem doesn't occur always, and when it does, it occurs only after system startup (Win7 x64). The program itself works fine (dl/ul of torrents), but the main window is nowhere to be found (even the icon in systray)... When i "kill" the process in task manager and start up uT again, everything works fine.

Thanks in advance

Link to comment
Share on other sites

I'm having this prob too. :(

It started after the last update - and it's kinda annoying.

uTorrent however works fine, but I'm not able to "exit"

the program for a short time (e.g. when I start a defrag

of the HDD). I also have to exit the program sometimes

when the other users on my router get too much lag.

PLEASE - a fix is needed

Thanks in advance!!

Link to comment
Share on other sites

Hello all I just want to say I'm having the exact same issue. Utorrent is running in task manager but not in the taskbar or system tray. So I can't open the window or close the program traditionally, I have to end the task. This only occurs if uTorrent is starting at windows startup.

Thanks,

Link to comment
Share on other sites

I am also having this same problem. When I start up my computer the icon appears briefly in the system tray and then disappears. The main window does not open up but the program is running, DL'g, UL'g etc. in the background. In order to open the window, I have to click on the icon in the taskbar. When the window is open, and I minimize it, there is no icon in the system tray. This just started today.

Link to comment
Share on other sites

Have had the same problem for months. have possible bug-fix or complete coincidence, Cleared my icon cache and thumbnail cache and now icon displays fine.

Open the task manager (Right click on taskbar> Start task manager)

Right click on the process "explorer.exe" Click "End Process"

Click File then "New Task (Run..)" then type "CMD" and Click ok

Then enter these commands..

CD /d %userprofile%\AppData\Local
DEL IconCache.db /a
CD /d %LocalAppData%\Microsoft\Windows\Explorer
DEL thumbcache* /a
EXIT

Then on the task manager click File > New task > type explorer then click ok

Hopefully fix it for vista/win 7

Link to comment
Share on other sites

Have had the same problem for months. have possible bug-fix or complete coincidence, Cleared my icon cache and thumbnail cache and now icon displays fine.

Open the task manager (Right click on taskbar> Start task manager)

Right click on the process "explorer.exe" Click "End Process"

Click File then "New Task (Run..)" then type "CMD" and Click ok

Then enter these commands..

CD /d %userprofile%\AppData\Local
DEL IconCache.db /a
CD /d %LocalAppData%\Microsoft\Windows\Explorer
DEL thumbcache* /a
EXIT

Then on the task manager click File > New task > type explorer then click ok

Hopefully fix it for vista/win 7

This worked for me! Thank you!

Link to comment
Share on other sites

When I start uTorrent (2.2) sometimes it does not appear to start, however checking the task manager I can see that there is a process for uTorrent running. The uTorrent main window does not show.

My torrents are located on my network drive and I find that if there is a lot of network activity on that drive then the user interface for uTorrent does not appear.

I run a SyncToy from my computer to my network drive each time my computer starts (to backup important documents). While this job is running if I then start uTorrent the main screen does not appear until my SyncToy backup has finished or I abort the SyncToy job.

Why is this happening? Can this issue be resolved in some way? What is the next step to fix this problem?

It sounds like uTorrent is doing some disk I/O on start-up which gets severely delayed by the other disk activity. You (or anyone with this same problem) might want to run process explorer to log disk access made by uTorrent. If I remember correctly, we might have some issues with part-files stat-ing files a lot, it might also be related to the .!ut extension, which requires uT to scan torrents that start to sync. its understanding of the filenames (this has been greatly improved in 3.0 btw).

This problem has only become an issue since version 2.2 I believe.

The plan now is to try to turn 2.2.1 stable early next week, if the coming RC seems to do well over the weekend. The main regressions seems to have been introduced in 2.2, so I'm quite certain 2.2.1 is a strict improvement over that. We'll address the remaining regressions in a separate branch or potentially a 2.2.2.

Link to comment
Share on other sites

  • 1 year later...

Hi All

I have started experiencing this in the past day. I am using the latest beta, however I removed that and downloaded the latest stable version from the website. That installed (it seems) but the problem persists.

I tried clicking one of the utorrent part files, which started the program running in the background - but no main window or system icon, so I have no idea what it is doing.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...