Jump to content

Need help with libssl


Beretta92

Recommended Posts

Hi all,

With the latest revision I'm having a very hard time with my PKGBUILD on ArchLinux with the new OpenSSL dependency.

The default OpenSSL package on ArchLinux is 1.0.0, that did not work. So I installed openssl-compatibility wich provides libssl.so.0.9.8 and libcrypto.so.0.9.8. But I still get:

/usr/bin/utserver: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory

ldd output:

[root@Serveur bin]# ldd utserver

linux-gate.so.1 => (0xf76f1000)

libssl.so.0.9.8 => not found

libpthread.so.0 => /usr/lib32/libpthread.so.0 (0xf769f000)

libm.so.6 => /usr/lib32/libm.so.6 (0xf767a000)

librt.so.1 => /usr/lib32/librt.so.1 (0xf7671000)

libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf7656000)

libc.so.6 => /usr/lib32/libc.so.6 (0xf750a000)

/lib/ld-linux.so.2 (0xf76f2000)

libcrypto.so.0.9.8 => not found

even after running manually ldconfig.

The /usr/lib/libcrypto.so.0.9.8 and /usr.lib/libssl.so.0.9.8 both exists..... Any Ideas?

Here is my PKGBUILD:

https://aur.archlinux.org/packages.php?ID=43253

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...