Jump to content

Issue with port frwarding

Recommended Posts

Hello everybody, this is my first time to these forums.


Windows 7 x64 pro

utorrent 2.2.1

some kind of pathetic belkin router

I have been using utorrent for years now, and have never really had an issue i couldnt resolve. a couple days ago i noticed that my download speeds had declined very drastically. with 6 active torrents i had about a 60kbs average through the night (usually its in the range of 500-800 depending on seeds and whatnot).

So anyways, i began troubleshooting and i came to find that i may have a port issue. My port is 57575 and i have it set to that on my router and utorrent. i have utorrent's upnp disabled and thats where the problem is. The utrrent setup guides port checker says its diabled. whats going on there? i dont want it enabled, i want to forward a port on my static ip address.

now here i ran into some confusing things. i used several different port checking tools, as well as online websites through this step. If i enable upnp in ut (with 57575) the port test succedds with fying colors (except of course utorrents port checker that still tells me upnp is disabled) However if i disable upnp in utorrent,then every port tests fails.

so i am lost, utterly and completely. I would like to continue using a static ip address, so if anybody could help me out here i would greatly appreciate it

Link to comment
Share on other sites

My windows firewall has tcp/udp in exceptions (default configuration)


and my router's firewall is disabled


I would also like to add that certain upnp tests i have tried do not work. i am not entirely sure on how upnp works but i would assume you do not need it if you have set a static ip andforwarded the port properly. Could somebody confirm this assumption?

Link to comment
Share on other sites

thank you for the confirmation moogly.

it seems my problem has been solved as well. I was reading this thread http://forum.utorrent.com/viewtopic.php?id=97718. specifaclly elton75's comment -

For me, it seems that the problem has been solved by unchecking the "ip flood detection" option on my router's settings. The browsers work again !

Stangely, when I run the test in utorrent (CTRL-G) , it tells me my port is not open, can't figure why, it is forwarded in the router's setting though. Any idea ?

based off what i read i decided to uncheck rate limit to utp connections in utorrent and lo and behold the port tests work! ALL OF THEM! so now im just waiting to see if the dl speeds improve :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...