Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 3.0 (32-bit) Stable Release

Recommended Posts

hey guys

is it me' date=' or the download speed label is quite odd

seems it updates once in a while (like 30 seconds for me)

same think in the download speed label in the grid and in the footer as well as in the one from the status (when you hover the mouse over the tray icon)[/quote']

Does it update more often if you pass your mouse cursor over it?

nope

same reaction every time

noticed that when I pause the torrent (you know it keeps sending a bit of data like 1-5kb/s) it updates like every 2 seconds or so

Edit:

correction

it does update more often (every second but in my case the torrent needs to be selected)

Edit #2:

seems that is not doing so every time

sometimes it does update, sometimes it doesn't

Share this post


Link to post
Share on other sites

As I wrote earlier I didn't like the new status icons in the latest build (25274).

Here's the comparison:

1282a8f7cae5b0c4867b2b1ecc901a08.jpeg

Can you at least export old icons as skin?

For those, who shares my opinion and prefers the old icons (as do I) I made two versions of transparent tstatus.bmp with old icons (19 icons set). Unfortunately I don't know what icons from original uTorrent iconset should be on positions 15,16,17 and 18. So I took them from one of not numerous 19-icon skin called "Tango" by Nighted. I hope the author wouldn't mind.

The first version is compiled from transparent PNG-icons from uTorrent help, saved as PNG and converted to 32-bit BMP with AlphaConv.

pngpreview.jpg

The second is a simple copy-paste from the screenshot of uTorrent Beta 3.0 build 25252. The transparency is achieved by coloring the "transparent" background with magenta.

bmppreview.jpg

As you see, there is some difference in colors of the following icons: "DL error", "UL error", "critical error", "stopped unfinished" and 2 rss-icons.

Also I didn't find the way to insert the "labels" icon (labels.png) and don't know the right place for the "rss-clock" icon (rssclock.png), which means "the release is less than 24 hours old" - it seemes that uTorrent doesn't use it (or I can't catch it).

Download both versions

It would be great if the developers could share the real iconset from the previous build of uTorrent (25252) or return to the old icons.

Share this post


Link to post
Share on other sites
As I wrote earlier I didn't like the new status icons in the latest build (25274).

For those, who shares my opinion and prefers the old icons (as do I) I made two versions of transparent tstatus.bmp with old icons (19 icons set). Unfortunately I don't know what icons from original uTorrent iconset should be on positions 15,16,17 and 18. So I took them from one of not numerous 19-icon skin called "Tango" by Nighted. I hope the author wouldn't mind.

The first version is compiled from transparent PNG-icons from uTorrent help, saved as PNG and converted to 32-bit BMP with AlphaConv.

http://img194.imageshack.us/img194/6048/pngpreview.jpg

The second is a simple copy-paste from the screenshot of uTorrent Beta 3.0 build 25252. The transparency is achieved by coloring the "transparent" background with magenta.

http://img269.imageshack.us/img269/5382/bmppreview.jpg

As you see, there is some difference in colors of the following icons: "DL error", "UL error", "critical error", "stopped unfinished" and 2 rss-icons.

Also I didn't find the way to insert the "labels" icon (http://img171.imageshack.us/img171/3350/labels.png) and don't know the right place for the "rss-clock" icon (http://img508.imageshack.us/img508/1222/rssclock.png), which means "the release is less than 24 hours old" - it seemes that uTorrent doesn't use it (or I can't catch it).

Download both versions

It would be great if the developers could share the real iconset from the previous build of uTorrent (25252) or return to the old icons.

http://download.utorrent.com/old30icons.rar

Here's the PSDs of the older icons that we use to generate the icons in the client. It may require a little work to get a useful BMP out of it, but here you go.

Share this post


Link to post
Share on other sites
As I wrote earlier I didn't like the new status icons in the latest build (25274).
Here's the comparison:

http://i11.fastpic.ru/thumb/2011/0511/08/1282a8f7cae5b0c4867b2b1ecc901a08.jpeg

Can you at least export old icons as skin?

For those, who shares my opinion and prefers the old icons (as do I) I made two versions of transparent tstatus.bmp with old icons (19 icons set). Unfortunately I don't know what icons from original uTorrent iconset should be on positions 15,16,17 and 18. So I took them from one of not numerous 19-icon skin called "Tango" by Nighted. I hope the author wouldn't mind.

The first version is compiled from transparent PNG-icons from uTorrent help, saved as PNG and converted to 32-bit BMP with AlphaConv.

http://img194.imageshack.us/img194/6048/pngpreview.jpg

The second is a simple copy-paste from the screenshot of uTorrent Beta 3.0 build 25252. The transparency is achieved by coloring the "transparent" background with magenta.

http://img269.imageshack.us/img269/5382/bmppreview.jpg

As you see, there is some difference in colors of the following icons: "DL error", "UL error", "critical error", "stopped unfinished" and 2 rss-icons.

Also I didn't find the way to insert the "labels" icon (http://img171.imageshack.us/img171/3350/labels.png) and don't know the right place for the "rss-clock" icon (http://img508.imageshack.us/img508/1222/rssclock.png), which means "the release is less than 24 hours old" - it seemes that uTorrent doesn't use it (or I can't catch it).

Download both versions

It would be great if the developers could share the real iconset from the previous build of uTorrent (25252) or return to the old icons.

Hi Meddio,

If you consider The download arrow to be position 0, the "labels" icon is #25

The rss area of the status icons is a little confusing:

13,14,15 are the status icons that utorrent uses to animate the rss items when there is activity

13 is the icon that the rss feed settles on when there is no activity

16 is rss error

17 is the icon with the star and rss lines you describe as rss clock

18 is the small green box with the rss lines.

Adam

Share this post


Link to post
Share on other sites
Here's the PSDs of the older icons that we use to generate the icons in the client. It may require a little work to get a useful BMP out of it, but here you go.

Firon, thank you very much. But i meant the other version - the one with these icons:

version1z.jpg

or

version2h.jpg

But thanks anyway. This PSD files show me the correct order of icons and it will be easy to replace them with the needed ones. And most importantly the iconsets are full (e.g. "tstatus" has 49 positions). Thanks again.

Share this post


Link to post
Share on other sites
If you consider The download arrow to be position 0, the "labels" icon is #25

The rss area of the status icons is a little confusing...

Thanks, Adam. I've already matched available icons to the PSD-set given by Firon:

tstatuscustom.png

I improvised with rss icons. later I will make all the red icons less saturated.

icon with the star and rss lines you describe as rss clock

"rss clock" is the image filename from uTorrent CHM-file :)

So as for now i have filled the full 19-icons set (this is maximum, present in uTorrent skins library), but to reach the "labels" icon I need to fill all the blanks:

Unfortunately I have no idea where to find these icons (19, 22, 23, 24) in uTorrent 25252 and what do they mean :(

22 was Playback if I am not mistaken.

Share this post


Link to post
Share on other sites

Moved from beta 2x to 3x...

Have separate "incomplete" and "completed" downloads folders. Torrents that complete get moved to the custom "completed" folder.

Since moving to 3.x beta, the Last Modified date for all folders in the "completed" downloads folder are being updated every time the torrent gets an active peer client.

This is W R O N G behavior. The timestamp should not change after the torrent is completed.

Apologies if this is not the correct forum to address this.

[edit: typos]

Share this post


Link to post
Share on other sites

I have my columns sorted so the # column is the primary sort and the Added column is the secondary sort. After updating to the newest build, the secondary sort is all out of order and there's no way to fix it. I noticed that the times are sorted for each date but not the dates themselves. It used to be sorted by date, then time.

I hope this is not just me because my settings.dat is messed up. I think I might have to redo my settings soon if that's the case.

EDIT: OK I just tried it with fresh settings.dat and still having the same problem.

Share this post


Link to post
Share on other sites

Streaming is broken once again in last two builds at least (streaming button not clickable and invisible when torrent is selected). Also torrents sorting is broken is latest build (you can only sort by one column).

Share this post


Link to post
Share on other sites

the labels on the "Tranfer history" graph enable and disable on their own after a few secs without even clicking on them....

was this intentional or is it a bug???

pls reply even nobody replied on my previous posts on the same thread.....

utorrent ppl listen the users

bld is: 25277

os; win 7 32

Share this post


Link to post
Share on other sites
I have my columns sorted so the # column is the primary sort and the Added column is the secondary sort. After updating to the newest build, the secondary sort is all out of order and there's no way to fix it. I noticed that the times are sorted for each date but not the dates themselves. It used to be sorted by date, then time.

Same to me, secondary sort don't works.

the labels on the "Tranfer history" graph enable and disable on their own after a few secs without even clicking on them....

was this intentional or is it a bug???

I hope it's not intentional, but I see this already a few build ago.

bye

Share this post


Link to post
Share on other sites
Moved from beta 2x to 3x...

Have separate "incomplete" and "completed" downloads folders. Torrents that complete get moved to the custom "completed" folder.

Since moving to 3.x beta, the Last Modified date for all folders in the "completed" downloads folder are being updated every time the torrent gets an active peer client.

This is W R O N G behavior. The timestamp should not change after the torrent is completed.

Apologies if this is not the correct forum to address this.

[edit: typos]

That was fixed already in the last build.

Share this post


Link to post
Share on other sites
Thanks for the dump. What were you doing when it crashed?

I removed the old resume.dat, resume.dat.old (from ver. 2.2.1) and created a new empty file resume.dat

Share this post


Link to post
Share on other sites

With the latest beta I'm getting errors on some torrents. It will be in the middle of downloading and then an error will appear that says:

Error: The data is invalid

If I do a "Force Re-Check" and restart the torrent it will eventually finish. On some torrents I've had to do this several times in order for it to finish.

Share this post


Link to post
Share on other sites

Hello...I have a problem with testing new uTorrent 3.0 beta....My "torrents site"

(tracker) block all uTorrent alpha/beta version. Only pass final version....Could you add in advanced setup some value like "version change" to 2.2.1....or version emulator...

Thanks

Adam

Share this post


Link to post
Share on other sites
With the latest beta I'm getting errors on some torrents. It will be in the middle of downloading and then an error will appear that says:

Error: The data is invalid

If I do a "Force Re-Check" and restart the torrent it will eventually finish. On some torrents I've had to do this several times in order for it to finish.

I have had this happen also as I have said before 3 or 4 times on this forum.

This has been reported by many others and still no reply by any one from utorrent. :mad:

I can not upgrade from 2.2 until some one figures this out.

Share this post


Link to post
Share on other sites

Hm... some strange issue:

As I mentioned earlier I have two versions of uTorrent both configured as portable (standalone). Each has its own resume.dat, settigns.fat, rss.dat, each has its own folders for added and finished torrents. Each is being started with the shortcut with "/recover" key. Both versions can work simultaniously without any problems. But usually I use each version in different time. I've mentiond this meaning that both versions are configured similarly: they use different ports and folders, but all the other conditions are equal.

So, back to the problem. The first version was autoupdated from 25252 to 25277 successfully and works perfectly. I use it to download from RSS. But when I autoupdated the other one today it hung up after starting. I monitored it with Process Monitor for several minutes. The CPU load as straight 50% all the time, but the I/O activity was at 0. I've tried to kill it and restart few times. The result was the same - just loads CPU to 50%, doesn't read any data from HDD, and the window is grayed and unclickable (this is the way of Windows 7 showing that the application is busy) - the only thing I was able to do is to kill the process.

I replaced the utorrent.exe (build 25277) with build 25252 and it started normally as allways. Replaced it back to 25277 it hung up on start. Then I've tried to find the reason (I killed the process after each try):

1) renamed my "settings.dat" and created the blank one. It didn't help.

2) removed all the unnecessary stuff (the App folder, dlimagecache and so on) - no changes again.

3) then I renamed my "resume.dat" and created the blank one - tada, utorrent started successfully.

4) but then I made a mistake: after killing the process again I removed the blank resume.dat and replaced it with the original one. Then started uTorrent. It hung up again after starting and also has rewritten the original resume.dat and resume.dat.old - erased my torrent list :(

So (not to mention the loss of my torrents list) the problem was somewhere in resume.dat. uTorrent 25277 didn't like something that was left there by uTorrent 25252. Unfortunately this file was overwritten, so I cannot examine it with BEncode Editor and find the exact reason.

I am having a problem with the dl speeds not updating right. along with the graph. i had posted about this in the last thread. here is my msg from there: and a response that i tried and it didnt help.

And unfortunately I have to confirm mentioned complaints about the delayed speed values.

I monitor the speed with Bandwidth Meter Pro and even when I start downloading the torrent and Bandwidth Meter shows the evenly growing graph from 0 up to 30+ Mbits per second and then the straight line at this rate, uTorrent still shows something around 600 KB/s for several minutes. When I click the torrent the speed value updates immediately to 3-4 MB/s for instance. The CPU load and disk write speed (and buffer) are normal. I tried setting gui.update_speed to 1000 and to 500.

I noticed such behavior in several latest builds.

Share this post


Link to post
Share on other sites

I can reconfirm Meddio's post about misreporting speeds, I had noticed it but thought it was just the difference with overhead. I since rechecked.

In the latest build my actual download speed issues have cleared up. Torrents are coming down at their expected rates, so I'm removing my previous report (not that I think you guys take speed reports seriously :\)

@ MacGyverek - Wow.. Just wow :\

Share this post


Link to post
Share on other sites
So (not to mention the loss of my torrents list) the problem was somewhere in resume.dat. uTorrent 25277 didn't like something that was left there by uTorrent 25252. Unfortunately this file was overwritten, so I cannot examine it with BEncode Editor and find the exact reason.

Funny. I managed to find the real reason of uTorrent 25277 hanging.

It had nothing to do to "resume.dat".

The problem happened only when I tried to download one specific torrent file.

uTorrent 3.0.0.25234 downloads it perfectly.

uTorrent 3.0.0.25277 hangs and stops responding.

Link to the file:

http://rutracker.org/forum/viewtopic.php?t=3553880

(it is huge private russian tracker - registration is needed)

I compared the torrent-files from this tracker that work normally with this file.

The difference is in tracker list:

The working ones have the following tracker links (torrent contents example):

http://bt2.rutracker.org/ann?uk=**********

http://ix2.rutracker.net/ann?uk=**********

or

http://bt3.rutracker.org/ann?uk=**********

http://ix3.rutracker.net/ann?uk=**********

or

http://bt4.rutracker.org/ann?uk=**********

http://ix4.rutracker.net/ann?uk=**********

The torrent, that killes uTorrent (torrent contents):

http://bt.rutracker.org/ann?uk=**********

http://ix.rutracker.net/ann?uk=**********

where ********** is my passkey.

I don't know what changes where made to the build 25277 since the build 25234, but 25234 manages the downloading of this torrent file, and 25277 does not. To find this out and to compare these versions I didn't reinstall anything or make any changes at all, I just replaced the EXE-file.

In the meantime I downgrade to 25234.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.