Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 3.0 (32-bit) Stable Release

Recommended Posts

Please let us know if you see problems other than these, or have figured out more information about one of the active bugs. (Or if I've missed an issue)

From 25327 changelog: "- Fix: µTorrent can hang if checking thousands of torrents"

Not fixed for me in 25327. When I upgrade from 25154, after setup has run, utorrent starts, it runs some time and at some time the window gets unresponsive and suddenly is all white. The process still uses around 5-10% CPU (on a quadcore Phenom). After some time it has gobbled up 400MByte RAM and same amount of swap, CPU is the same as before. 25154 is at 170/300 after several hours.

WinXP, SP3; quadcore Phenom, 4GByte RAM.11700+ torrents, 5700+ finished.

Share this post


Link to post
Share on other sites

I'm sorry but at least the last issue I describe (#6) should not be postponed! v3.0 is actually unusable since I cannot run it for a second time and I end up with the setup dialog which does nothing. Follow the steps I describe and you should reproduce the issue. If not let me know what else you need.

Oh and btw, #4 and $5 should be easy to fix so why postpone them? At least the help file.

Share this post


Link to post
Share on other sites

"Queued Seed" torrents arn't showing in the new "Seeding" torrents slelection. Queued Downloads show in Downloading. So Queued Seeds should be no different.

Also, the Associate with magnet URis and .btsearch files buttons are missing. are the functionality for magnet and .btsearch removed? or are the buttons just gone?

And has anyone ever suggested a random port range for "Randomize port each start" option like BitTornado has?

also gui.transparrent_graph_legend is defaulted to false. but with it this way the legend text is white and the background text is white... setting to true makes it readable.

Share this post


Link to post
Share on other sites

Labels for "Download", "Upload", "Upload & Download" graphs randomly apper/disapper on "Resolution" change.

//edit:

1) Can the tray icon behavior change? I have asked for this in one of my previous posts but the developers missed it.

It would make sense to put μTorrent in the tray if one single clicks on it and it's already restored. Maybe make it happen only if the "Single click on tray icon to open" option is enabled. But, please, implement this as it's very handy. Most of the programs do this...

UI Settings -> uncheck: "Always activate when clicked"

Share this post


Link to post
Share on other sites

I'm sorry but at least the last issue I describe (#6) should not be postponed! v3.0 is actually unusable since I cannot run it for a second time and I end up with the setup dialog which does nothing. Follow the steps I describe and you should reproduce the issue. If not let me know what else you need.

Oh and btw' date=' #4 and $5 should be easy to fix so why postpone them? At least the help file.[/quote']

They are in the "undecided" list, not the postponed list.

Share this post


Link to post
Share on other sites

hi Adam' date=' I still got a minor issue about the health bar. In the latest changelog it has been fixed to green, but mine is still orange. Can you look into that? Thank you.[/quote']

Hmm. Look for a file called "default_skin", and delete it. Also, which build #?

Hi Adam, where is this file located? I checked uTorrent folder in Users/username/appdata/local & Users/username/appdata/roaming but I could not find a file called default_skin. None in the Program Files too. Also tried searching the whole computer for that keyword with no result. I'm using build 25327.

Thanks.

Share this post


Link to post
Share on other sites

hi Adam' date=' I still got a minor issue about the health bar. In the latest changelog it has been fixed to green, but mine is still orange. Can you look into that? Thank you.[/quote']

Hmm. Look for a file called "default_skin", and delete it. Also, which build #?

Hi Adam, where is this file located? I checked uTorrent folder in Users/username/appdata/local & Users/username/appdata/roaming but I could not find a file called default_skin. None in the Program Files too. Also tried searching the whole computer for that keyword with no result. I'm using build 25327.

Thanks.

Okay. In that case, I'm going to have to look into it further.

Share this post


Link to post
Share on other sites

I d/l the program but I prefer 2.2.1. The problems I found with it were when I have to reboot my computer it takes forever for the checking process to finish. I also get disk overload a lot more and it never goes away (this has an effect on my d/l speed, normally d/l speed is over 1M but with disk overload it is never over 25kb.

Share this post


Link to post
Share on other sites
The upcoming 3.0 update won't be mandatory, or will it?

Hi rrrrrrrrG - what do you mean by mandatory? You are always welcome to NOT upgrade to the latest version - we have no desire to dictate which version you use (though we aim to make new versions that you WANT to upgrade to). :)

Share this post


Link to post
Share on other sites

hi Adam' date=' I still got a minor issue about the health bar. In the latest changelog it has been fixed to green, but mine is still orange. Can you look into that? Thank you.[/quote']

Same here ... :(

It's a bit confusing why this setting would stick. Let me know if you still have the problem after the RC today.

I will. And no rush, it does not have to be "today"... Just make sure the RC is up to my minimal standards, ... No flatlines please ;)

Share this post


Link to post
Share on other sites

I will. And no rush, it does not have to be "today"... Just make sure the RC is up to my minimal standards, ... No flatlines please ;)

We have already fixed the flatline speed graphs problem. Look for the fix in the next RC. :)

Share this post


Link to post
Share on other sites
Hi, bigfalls! Thanks for your response.

How long are you planning to support 2.2?

All development has stopped on 2.2. It will receive no further updates.

Share this post


Link to post
Share on other sites

A few questions that remain unanswered in your post: Will the potential CPU fix also fix the sluggish torrent list horizontal scrolling? Will there be an updated 2.0.4 skin? Also, I don't see mention of the ongoing tray icon issues or any plans for completing the comment disabling feature. Thanks again for all the hard work! :)

I really doubt that we'll be able to get the sluggish torrent list scrolling before 3.0 stable.

BTW, until we get to 3.0 stable, I am updating this post with issue status as I notice them:

http://forum.utorrent.com/viewtopic.php?pid=588848#p588848

Thanks.

Share this post


Link to post
Share on other sites
You can't code for user stupidity :\ Otherwise you will have to pop 50 pop up boxes.. "Are you sure you want to keep downloading this torrent?" "How about now?"

Firefox handles this quite nicely. If you use the "Open All in Tabs" function, once you get past a certain threshold it asks you "This action will open X new tabs. Are you sure you want to do this?"

Share this post


Link to post
Share on other sites
When I try to download a torrent using a magnet URL from certain trackers, I consistently get an error about the directory begin invalid:

[2011-06-01 06:43:57] Error opening "C:\Users\LCR\Downloads\magnet:?xt=urn:btih:50381241BEBCD5E3FE59B833A7FCAB7CBC4DD0B2&tr=http://www.mvgroup.org:2710/announce\National.Geographic.Can.the.Gulf.Survive.XviD.AC3.MVGroup.org.avi":

The actual magnet URL was:

magnet:?xt=urn:btih:50381241BEBCD5E3FE59B833A7FCAB7CBC4DD0B2&tr=http://www.mvgroup.org:2710/announce

This has occurred with magnet URLs from several websites (the above is from eztv) which used to work fine with the previous (pre-3.0) stable release of utorrent. If I download the same torrent using a non-magnet URL, it also works fine.

Can someone else verify this? I think magnet links are broken in 3.0.

Share this post


Link to post
Share on other sites

Please let us know if you see problems other than these, or have figured out more information about one of the active bugs. (Or if I've missed an issue)

Can someone else verify this? I think magnet links are broken in 3.0.

Verified... the whole magnet link is entered as the file name by mistake :P

33722688.th.png

55102265.th.png

Share this post


Link to post
Share on other sites

µTorrent 3.0 RC is only using 10% of my bandwidth at most. 150-350 KByte/s with a 25/30 Mbit/s fibre connection. With 2.2.1 I could upload at 3 MByte/s stable for days and deliver 0.8 - 2 MByte/s to every peer. Now peers only get at 80 KByte/s at most.

After upgrading to 3.0 settings remained the same. I see many people who have posted here have the same experience as me.

Now, how do I downgrade to 2.2.1 without having to download all the torrents that I'm seeding at the moment? Is there a feature that enables you to "import" torrent files and data files that have already been downloaded, to a fresh install of 2.2.1?

Windows XP SP3 btw.

Share this post


Link to post
Share on other sites

I should say this that utorrent 3.0 has been providing with better speeds and also i have noticed is that it takes less overhead as compared to 2.2.1. :D

BUT 2.2.1 used to reduce its speed while i used to access the internet (one of the reasons for which the utp protocol was developed i suppose).

This behaviour is not seen in 3.0 thus i have to manually pause the torrents before using the internet..

is the behavior for utp been changed?????

Share this post


Link to post
Share on other sites

@articuno1au :

my line speeds as assigned my ISP is 320 kbps i.e 40 KBPS

in utorrent 3.0 speeds touch till 34-35 KBPS which is full considerring the overheads...

Share this post


Link to post
Share on other sites

i have found an minor GUI bug ...

the playback button lags when the horizontal scroll bars are moved....

this only happens when the columns are large and only for the selected torrent

heres the screenshot where i managed to catch the bug in action :

playbackbuttonbug.th.png

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.