Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 3.0 (32-bit) Stable Release

Recommended Posts

It appears to work fine.

No, it doesn't work fine. It's broken... The use case is this:

- Minimize (or close) uT to tray

- Now, exit uT (from the tray)

- Activate uT again

It should open as minimized to the tray now, but it opens fully :(

Hope this was helpful to you

Share this post


Link to post
Share on other sites
Just curious, it's fixed maybe in RC8 ?

If not, you really should fix it before releasing a stable version.

CRITICAL BUG in µTorrent 3.0.25327

It delete permanently torrent with all files from disc, instead of using trash, even if gui.default.del_action and gui.delete.to_trash have default values (0 and true)

RC4, line 10

http://forum.utorrent.com/viewtopic.php?pid=579920#p579920

Line 1

http://forum.utorrent.com/viewtopic.php?pid=588848#p588848

Last line

http://forum.utorrent.com/viewtopic.php?pid=588830#p588830

Please try RC 8 and let us know if this problem still happens for you.

Share this post


Link to post
Share on other sites
uT build 25395 x32, Win XP SP3. I have noticed many red torrents with error in status column: "An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full." uT logs shows next:
[2011-06-20 03:48:00]  Error: data.mkv - Not enough quota is available to process this command. 

[2011-06-20 03:49:05] File failed verification: C:\Program Files\uTorrent\resume.dat.new

[2011-06-20 03:49:05] Unable to save the resume file. Another program might have the file open, or the disk is full.

[2011-06-20 03:49:24] Error opening "k:\tor\data2\data2.mkv":

[2011-06-20 03:49:24] Error: data2 - Not enough quota is available to process this command.

[2011-06-20 03:51:06] Failed file save: C:\Program Files\uTorrent\resume.dat.new

[2011-06-20 03:51:06] Unable to save the resume file. Another program might have the file open, or the disk is full.

[2011-06-20 03:53:07] File failed verification: C:\Program Files\uTorrent\resume.dat.new

[2011-06-20 03:53:07] Unable to save the resume file. Another program might have the file open, or the disk is full.

[2011-06-20 03:55:08] Failed file save: C:\Program Files\uTorrent\resume.dat.new

[2011-06-20 03:55:08] Unable to save the resume file. Another program might have the file open, or the disk is full.

[2011-06-20 03:57:09] Failed file save: C:\Program Files\uTorrent\resume.dat.new

[2011-06-20 03:57:09] Unable to save the resume file. Another program might have the file open, or the disk is full.

[2011-06-20 03:59:10] File failed verification: C:\Program Files\uTorrent\resume.dat.new

[2011-06-20 03:59:10] Unable to save the resume file. Another program might have the file open, or the disk is full.

[2011-06-20 04:01:11] Failed file save: C:\Program Files\uTorrent\resume.dat.new

[2011-06-20 04:01:11] Unable to save the resume file. Another program might have the file open, or the disk is full.

[2011-06-20 04:03:12] Failed file save: C:\Program Files\uTorrent\resume.dat.new

[2011-06-20 04:03:12] Unable to save the resume file. Another program might have the file open, or the disk is full.

[2011-06-20 04:05:13] Unable to save the resume file. Another program might have the file open, or the disk is full.

[2011-06-20 04:06:11] Failed file save: C:\Program Files\uTorrent\settings.dat.new

[2011-06-20 04:07:14] File failed verification: C:\Program Files\uTorrent\resume.dat.new

[2011-06-20 04:07:14] Unable to save the resume file. Another program might have the file open, or the disk is full.

[2011-06-20 04:09:15] Failed file save: C:\Program Files\uTorrent\resume.dat.new

Disks C and K are not full. Each has more than 16 GB of free space. resume.dat.new and settings.dat.new are absent in uT folder. resume.dat and settings.dat exist and they are being updated normally - their modification data is being changed all the time. Using Unlocker on these files shows, that these files are not locked by any program. Also those log records repeat constantly. uT is uploading good torrents (without that error) with speed around 5% from maximum. uT doesn't use uTP. Its cache is 32 MB. Using task manager I see that its virtual memory usage is around 91 MB and I have plenty of free memory. Average number of active connections is ~40.

Googling I can assume that operation system is running out of non-paged pool. Windows event viewer doesn't tell any error. I do not use PAE nor /3GB switch in boot.ini.

Restarting uT and starting error torrents makes uT work normally (no error message about dat files in log). I didn't restart OS. It makes me think that bug is inside uT. It is first time I see this issue.

This is a very good bug report. Which ut version were you using, and which version did you upgrade from? (Help | About uTorrent)

We may need to contact you for more information, because this is the only report of this problem so far.

Share this post


Link to post
Share on other sites
The UI opens fully and does not close to the tray unless you manually close it. Version 2.2.1 does not have this flaw.

It appears to work fine. In your "Preferences->UI Settings" make sure you are setting "Minimize to tray" and "Close to tray" to meet your requirements. The "X" button at the top right of the ut window performs "Close" and the button one over' date=' on its left, which looks like a simple bar performs the 'minimize' operation.[/quote']

No it does not work fine. It should open with the UI closed and minminizedc to the tray. This has been an issue with this release since it came out. I filed a bug report on it but it seems no one reads them. If you look at the image below you can see that the settings are correct.

ut.png

Share this post


Link to post
Share on other sites
The UI opens fully and does not close to the tray unless you manually close it. Version 2.2.1 does not have this flaw.

It appears to work fine. In your "Preferences->UI Settings" make sure you are setting "Minimize to tray" and "Close to tray" to meet your requirements. The "X" button at the top right of the ut window performs "Close" and the button one over' date=' on its left, which looks like a simple bar performs the 'minimize' operation.[/quote']

No it does not work fine. It should open with the UI closed and minminizedc to the tray. This has been an issue with this release since it came out. I filed a bug report on it but it seems no one reads them. If you look at the image below you can see that the settings are correct.

http://i20.photobucket.com/albums/b243/TK-1913/ut.png

To Act on your bug report, we have to understand it first. If I'm counting correctly there were at least 3 separate issues with the tray icon. Perhaps the developer dealing with this problem fixed a different issue than the one your were trying to report.

Thank you for your more complete bug report.

Share this post


Link to post
Share on other sites
The UI opens fully and does not close to the tray unless you manually close it. Version 2.2.1 does not have this flaw.

You seem to be missing some key details.

Share this post


Link to post
Share on other sites
This is a very good bug report. Which ut version were you using, and which version did you upgrade from? (Help | About uTorrent)

We may need to contact you for more information, because this is the only report of this problem so far.

Version upgrade history was next: 2.2.1 (using for some months), 3.0 RC4 (used for some days, installed via autoupdater for beta versions), 3.0 RC5 (installed via autoupdater), 3.0 RC6 build 25395 (installed manually, because it was unavailable in autoupdater) and such issue appeared in this version (RC6 build 25395) ~4 hours after update. Some torrents were green and were seeding, just with slow speed and some torrents were red with mentioned error status, which really looks like OS issue. Later I updated to RC7 and RC8 via autoupdater, but before I used RC6 for about another 10 hours and there was no such issue again. If such info has any sense for you I do not use uTP (bt.transp_disposition=5), allow same IP (bt.allow_same_ip=true), changed just appeared new option (diskio.cache_stripe=64, yea, it appeared in RC6 and I was actively testing this option changing it to 16 - 128 values watching disk cache statistics before finally leaving it to 64 and mentioned issue was with such value), net.max_halfopen=30 (with patched tcpip.sys for halfopened set to 500). Other non-default values for advanced options are related to GUI, and are not important from my view.

Share this post


Link to post
Share on other sites
The UI opens fully and does not close to the tray unless you manually close it. Version 2.2.1 does not have this flaw.

You seem to be missing some key details.

I provided a picture what more do you want. When I start version 2.2 1 it goes directly to the tray as it is supposed to. When I start v 3.0 this does NOT happen. The UI opens and it should not with the options I have checked. (see image) See where minimize at system start is checked. This does NOT happen. Does it take a frickin video to understand what closing to the tray means? This is not rocket science, the program is NOT working as designed!~

Share this post


Link to post
Share on other sites
I provided a picture what more do you want. When I start version 2.2 1 it goes directly to the tray as it is supposed to. When I start v 3.0 this does NOT happen. The UI opens and it should not with the options I have checked. (see image) See where minimize at system start is checked. This does NOT happen. Does it take a frickin video to understand what closing to the tray means? This is not rocket science, the program is NOT working as designed!~

Hey hey, be easier, please. AdamK just mentioned that you missed details in your original message. Probably he didn't notice your later message, because he was writing a message to your original message and naiduv's response to it. At that time, your later message was not yet posted, because it takes time to write a message. First he posted message #680. Then he started writing his message #682 to response to #677. You posted your 2nd message #681, but he was still busy with #682, so he didn't see your message. Right after he finished it, he wrote his new message #683 missing your #681. Then he just left forum and hasn't yet seen your #681. Your bug report is appreciated.

Share this post


Link to post
Share on other sites
I provided a picture what more do you want. When I start version 2.2 1 it goes directly to the tray as it is supposed to. When I start v 3.0 this does NOT happen. The UI opens and it should not with the options I have checked. (see image) See where minimize at system start is checked. This does NOT happen. Does it take a frickin video to understand what closing to the tray means? This is not rocket science' date=' the program is NOT working as designed!~[/quote']

Hey hey, be easier, please. AdamK just mentioned that you missed details in your original message. Probably he didn't notice your later message, because he was writing a message to your original message and naiduv's response to it. At that time, your later message was not yet posted, because it takes time to write a message. First he posted message #680. Then he started writing his message #682 to response to #677. You posted your 2nd message #681, but he was still busy with #682, so he didn't see your message. Right after he finished it, he wrote his new message #683 missing your #681. Then he just left forum and hasn't yet seen your #681. Your bug report is appreciated.

What you say is all well and good but I filed that bug report over three weeks ago, and it still is not fixed and now there is a dev that denies it even exists?? I will wait until this version goes final.

Share this post


Link to post
Share on other sites

I am using RC8 and Remove and Delete .torrent + Data does not appear to be working, after the command is issued both the .torrent and the data exist and must be removed manually. If it helps at all I am only seeing this happen on non-finished torrents.

Share this post


Link to post
Share on other sites

@GTK66: it seems to be just a new design/behaviour here (with the /MINIMIZED flag to frorce it to run minimized). Personally I don't know if I mind...

Share this post


Link to post
Share on other sites
What you say is all well and good but I filed that bug report over three weeks ago, and it still is not fixed and now there is a dev that denies it even exists?? I will wait until this version goes final.

Your indignation is understandable. Well, some bugs have higher priority, than others. Those bugs, which crash uT, make HDD overload, highly increase CPU usage or damage settings usually have higher priority than GUI issues like yours. Of course, every bug report is appreciated and will be fixed one day, just developers are not magicians and each has only one brain and hopefully 2 hands, so every bug fix requires own time. From other side, you may use old stable version and wait when uT 3.0 becomes gold. Nobody pushes you to use beta. I think 3.0 will become gold, when developers are satisfied with current state and feel, that there are no major bugs. Probably your bug will be fixed too till release. And I think developers don't deny that this bug exist: rafi admitted it in http://forum.utorrent.com/viewtopic.php?pid=592418#p592418 and told how to reproduce it.

Share this post


Link to post
Share on other sites

Thank you, its fixed, sorry for not testing it first...

EDIT: is NOT FIXED ;p

still removing "torrent and data" don't use trash

only removing same torrent works properly, didn't test only data

Just curious' date=' it's fixed maybe in RC8 ?

If not, you really should fix it before releasing a stable version.

CRITICAL BUG in µTorrent 3.0.25327

It delete permanently torrent with all files from disc, instead of using trash, even if gui.default.del_action and gui.delete.to_trash have default values (0 and true)

RC4, line 10

http://forum.utorrent.com/viewtopic.php?pid=579920#p579920

Line 1

http://forum.utorrent.com/viewtopic.php?pid=588848#p588848

Last line

http://forum.utorrent.com/viewtopic.php?pid=588830#p588830

Please try RC 8 and let us know if this problem still happens for you.

Share this post


Link to post
Share on other sites
EDIT: is NOT FIXED ;p

still removing "torrent and data" don't use trash

only removing same torrent works properly, didn't test only data

I tested it with data and torrent+data and it is fine... Sort your recycle bin by date-deleted... :P

Share this post


Link to post
Share on other sites
The UI opens fully and does not close to the tray unless you manually close it. Version 2.2.1 does not have this flaw.

You seem to be missing some key details.

I think what GTK66 wanted to say was similar to my problem mentioned at http://forum.utorrent.com/viewtopic.php?pid=592204#p592204' date=' although I haven't got any response yet. I think what he meant was the uT window open up on Windows startup, eventhough it is set to minimize on startup [Windows startup that is'].

edit: Anyway, I just installed the latest release, and the problem seems to be fixed :).

On a sidenote, why can't I click on the legend of the speed graph to disable/enable what to be shown on the graph anymore? Can anyone enlighten me...

Share this post


Link to post
Share on other sites

Because this feature was broken, and removed. I hope they will re-instate it in 3.1 ... :)

Share this post


Link to post
Share on other sites

I better wait for 3.1... ;) Anyways, it's not that different than 2.x in many aspects... So maybe just changing the title will do for you ? ... :P

Plus, you can already take and use my great looking 2.2.1-like 3.0 color's template ... (tip # k) :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.