Jump to content

µTorrent 3.0 (32-bit) Stable Release


Recommended Posts

-- 2011-05-02: Version 3.0 beta (build 25234)

- Fix: torrent renaming (F2) was broken

Thanks for all the hard work !

Several issues:

1. When relocate individual files (Tab Files > Relocate...) and enable checkbox Append .!ut to incomplete files. In this case, the files are not relocate, files will be copied.

2. The latest build of overloading the CPU usage to 60-90%, with one active downloading. When disable checkbox Enable bandwidth managment (bt.transp_disposition=*21) CPU usage to 4-15%. Why??

3. Sometimes when start the µT freeze gui and tab peers (gui.update_rate=1000) - http://img12.imageshack.us/img12/8526/freezeg.png

4. After clicking the Manage Search Providers to open the menu Advanced, rather than not a sub-menu UI Extras - http://img716.imageshack.us/img716/9260/unled2kw.png

5. Advanced > Show Download Bar.. Height.. - http://img222.imageshack.us/img222/6669/unled1ky.png

6. There's another issue on XP SP3 - http://img839.imageshack.us/img839/7913/28875996.png

7. Main menu Apps on XP SP3 - http://img819.imageshack.us/img819/8494/appsq.png

8. Tab Speed > Transfer History > don't work correctly. Graph flickers

9. After adding the torrent date is not displayed correctly - http://img121.imageshack.us/img121/7712/unledzf.png

w7 x86, x64 build 25234

XP SP3 x86 build 25234

sorry for my bad English.

Link to comment
Share on other sites

  • Replies 1.4k
  • Created
  • Last Reply

Top Posters In This Topic

I finally uninstalled build 25234 today and went back to 2.2.1. All the crashing/data issues and new UI design were too much for me. My columns got all all jacked up and I couldn't quite get them back. Removing the ability to double-click on an unfinished torrent to play it was uncool; I used that heavily. Streaming is okay, though it is more cumbersome than just letting me open a file when I want to preview it in VLC. The last straw was all the broken torrents. Force-recheck on a terabyte of data is something my box doesn't need to be doing several times a day.

While I understand that this is a relatively early beta, it is just too painful for me to keep using. Thanks for all the work, I'll be back in 6 months to see how 3.x progressed.

Link to comment
Share on other sites

3.0: 25234: Windows 7 x64.

uTorrent: 50% cpu usage. Download pathetic (8kbs).

Icons awful. They are pretty, but the 4 pane gray window (the b/w windows icon from 1989) turns every button into a piece of art, not an icon I can recognise at a glance.

The Pause button takes a universally recognised symbol and makes it unrecognisable. That takes real talent.

utorrent is turning into vuze. Used to be good, then it turned into a program that wasn't verygood.

Tip to utorrent: ALWAYS remember a large % of yours users have *NO* brand loyalty. If you fuck up utorrent we'll move on, just like we did from wherever we were before.

We don't want cute features, we just want to download stuff.

(eg show me a single app that's actually useful in the context of a torrent application).

EDIT: downgraded to 2.2.1. Download shot up to 500 kbps which is pretty good for where I am. CPU usage normal.

Stop/pause/play Icons are instantly recognisable.

However, lameness of apparent utorrent direction has me surfing for alternative applications.

(Serously, WTF do I want crapware installed with uTorrent? Uncheck those by default in the installer and you might earn some kudos).

Good luck making money :-)

Link to comment
Share on other sites

utorrent is turning into vuze. Used to be good, then it turned into a program that wasn't verygood.

We don't want cute features, we just want to download stuff.

So true. I used Azureus up until the Vuze fiasco. The second I heard the phrase "content delivery platform", I ditched it and never looked back. I'm using a BT client to transfer torrents and, to a lesser extent, to manage those torrents while downloading or seeding them. That's all. Fortunately, µTorrent 2.2.1 still does that well for me. I'll stick with that, for now.

Link to comment
Share on other sites

I remain hopeful that the uTorrent team won't make the same mistake >.<

I am having significant issues with this build, but that has happened to me before during beta phases. Benefit of the doubt for now :)

I, too will yield them the benefit of the doubt. Don't misinterpret my statement to indicate that I consider this anything like the scale and scope of the Vuze idiocy. While the current problems and decisions are not something I choose to live with at the moment, I haven't turned my back on µTorrent just yet. As I said, 2.2.1 remains my preferred client.

Link to comment
Share on other sites

I used to be able to open a partially video file by simply double clicking on the file in the bottom panel of the interface, zhere you actually see the files, now I can not anymore, and the streaming button is not helping me at all. Can you get the "open" command back to available, it is currently greyed... :(

Link to comment
Share on other sites

the only 2 things that are bothering me with this new version are:

- waay too much cpu used (compared to version 2)

- about half way through a large torrent (~5g) my memory gets FULL and just stays like that until the torrent finishes downloading. speed is about 2-3 MB/s and i've tried several disk cache settings (manual cache size, automatic size.. etc..)

Link to comment
Share on other sites

Well I haven't faced this error from last couple of days so I dunno if the problem exists anymore (in the new builds). v v

For everyone with "Error: The Data is Invalid", open the download folder of the particular torrent. Notice anything different? It seemed that somehow, ".1" (dot one) extension was getting added to one of files in the torrent. And then I used to get "Error: The Data is Invalid". I removed the .1 extension and started the torrent, it had gone on fine :) , until unless, same happened again. Had happened to 2 different torrents for total 3 times. Hope this helps anyone. :)

I installed 25234 and immediatly the "Error: The Data is Invalid" came up on a torrent that I am only seeding. So, it isnt just torrents that are being downloaded. I do not have the ".1" extension on any of the torrents that have this error. Going to revert back to 2.2 until some one can figure out wtf is going on.

Link to comment
Share on other sites

I think it's much too early for the public testing in the current condition.

It's obviously in alpha stage, not beta.

Went back to 2.2.1

Also cheeseISgood is correct much. Some of the new changes are more than redundant for my bit torrent client.

I don't want any redundancy in that kind of software, so I will change the application the very day I see some money-making features in it.

Thanks for your work guys, but be careful in what you're planning.

Link to comment
Share on other sites

The Beta version is really cool! But what I have observed that while disabling the "Playback" column, the gray bar of "Playback" column expands to the entire row. It remains like that until you switch on the "Playback" again. Else, yeah the Beta version is cooler and want more from it! Thanks for the release!



Link to comment
Share on other sites

I just tried to install over 2.2.1 and had the following two issues:

1) The new version did not load all the completed torrents from AppData. I have 40 torrents there -- all "completed" and seeding -- but the program only loaded 15. I cannot see an apparent pattern to describe the ones it picked. (previously reported)

2) While trying to load the missing torrents back into the program, I was hit by the dreaded graphics corruption bug (dialog windows randomly turn black and the menu bar randomly vanishes). This bug also affects all other applications until I close uTorrent. (previously reported)

Until #2 is fixed, there's not going to be much I can do, as it renders Windows nearly unusable while uTorrent is running. Once that has been isolated and fixed, I will be happy to test this beta more. I regret that I can't really contribute much to that bug, as I have no idea what causes this sort of thing.

Link to comment
Share on other sites

What the ... happens when selecting torrent?


Same here

updated to build 25252 from 25234

and the whole OS goes into a fit. Context menu's goes black, Start menu goes blank,

This is utter crap of a build on my system.

After shutting it down somehow, OS slowly returns back to normal some 20 sec or so later(although i killed then started explorer.exe manually as well once to restore everything back to normal)

Reverted back to build 25234, everything fine with that.

Using Win 7 SP1 64-bit

µTorrent 3.0 (32-bit) beta 25252

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.

  • Create New...