Archived

This topic is now archived and is closed to further replies.

azdps

Program to remove or stop finished downloads

Recommended Posts

uTorrent Helper is a program which which can periodically remove or stop finished torrent downloads in uTorrent. It's designed to be lightweight, and use very little system resources while running.

 

Note: Currently uTorrent Helper does not work with RSS feed added torrents. Having any RSS feed torrents in uTorrent could potentially cause the program to crash or freeze.

uTorrent Helper 4.0 (October 3rd, 2015)
http://www.datafilehost.com/d/16d31911

uTorrent Helper 4.0 source code
http://www.datafilehost.com/d/a682906e


10onz1g.jpg


Example usage

==========================================================================name: admin <--- uTorrents webui user namepassword: 9Gu80 <--- uTorrents webui passwordip address: localhost <--- your computer ip address (try localhost)port: 8080 <--- uTorrents webui alternate listening porttime: 15 <--- how often in minutes program will remove or stop torrentsaction: stop torrents <--- choice of what exactly you want to happenauto start: yes <--- option to automatically startup with windows==========================================================================

Share this post


Link to post
Share on other sites

Hi!

I am trying to get this to work. I'm using the version 2.2.1 of uTorrent, and WebUI 3.81.

Your program says it connects, I set the action to "remove torrent" and timer on 1 or 2 or 5 or 15 minutes, makes no difference.

No matter what the status of the torrent (I tried Finished, Seeding..) it won't get removed.

I'm running the whole setup on Windows 2008 R2.

Cheers

Share this post


Link to post
Share on other sites

illum1na thanks for the input. i've only tested this on XP so far so i'm not sure if there might be an issue with server 2008. the only suggestion right now that i have is to make sure you have an alternative listening port set under uTorrent's webui settings and to make sure you use that port. i will try to test it on server 2008 when i get the chance.

Share this post


Link to post
Share on other sites

I set the alt port to 4444. I can connect using IE9, and your program says it's connected. I know that part of the program works fine, since it says it can't connect if I change the IP or the port.

If you need anymore information, or any testing whatsoever, just let me know..

Cheers

Share this post


Link to post
Share on other sites

Some more tests done:

I set the timer to 1 minute, kill the uTorrent process and your program's status says "Connection Failed" after about 1 minute, so the timer is not the problem either it seems.

If I connect to the WebUI and manually enter the following url in the same IE9 session (so I remain authenticated): "http://ip:port/gui/?action=remove&hash=<torrent's hash>" I get an error in IE9.

Not sure if that's supposed to happen though?

Share this post


Link to post
Share on other sites

hey

gave utorrent helper a try yesterday, works fine during runtime, but if i restart it, it doesn't remember the settings. none of them.

i'm on win7 x86 running utorrent 2.2.1

any clue what could be the issue? otherwise i really love and need your tool :)

cheers

Share this post


Link to post
Share on other sites
uTorrent Helper doesn't retain the settings because I did not program that feature into it. When I originally posted my program here I didn't receive much feedback as to whether or not it was working well for others. Just illum1na indicated he/she was having issues that I could not reproduce. For me filling in the info each time I started uTorrent Helper wasn't an issue since I could fill in the blanks quickly. Since you want to retain your settings, I will try to get working on it and submit an updated version when I get a chance. Also for others who may want to use this program. I don't think it works with uTorrent 3.0+ and I haven't recently verified that.

wow! that's so awesome!

looking forward to it.

i've been testing it for two days and it worked without any problems. did what it's supposed to be doing :)

Share this post


Link to post
Share on other sites
I've updated uTorrent Helper to version 1.1.

http://www.datafilehost.com/download-ba365ea8.html

11/22/2011 - uTorrent Helper 1.1 Change Log

- settings are now retained

Let me know if you encounter any bugs or suggestions for future additions.

Hey there,

thank you so much!

Works and retains settings :)

Indeed I have another suggestion: what about a checkbox or commandline option, so uTorrent helper starts/connects on startup? So it can be executed on startup ...

would be awesome!

thanks

Share this post


Link to post
Share on other sites
I've updated uTorrent Helper to version 1.2.

http://www.datafilehost.com/download-afebb3a6.html

11/25/2011 - uTorrent Helper 1.2 Change Log

- option to automatically start with windows added

- minimize to tray on startup

Let me know if you encounter any bugs or suggestions for future additions.

Hey there,

did a few restarts do test the autostart feature. Program started as expected and minimized to tray. What it didn't do: it didn't connect automatically to the former saved IP adress of my webinterface.

Is it supposed to connect on program launch or not? I'm not sure ... would be nice if uTorrent Helper could do that, because then it could be run absolutely unattended :)

cheers

Share this post


Link to post
Share on other sites
I've updated uTorrent Helper to version 1.3.

http://www.smallfiles.org/download/111/uTorrent_Helper_1.3.zip.html

12/05/2011 - uTorrent Helper 1.3 Change Log

- uTorrent 1.6.1 - uTorrent 3+ now supported

- changed button names to enable / disable from start / stop

- uTorrent Helper now checks to see if uTorrent is running

- fixed auto start bug

- retains enable or disable settings even after restart

Let me know if you encounter any bugs or suggestions for future additions.

hmm uTorrent helper 1.3 tells me uTorrent is not running (version 2.2.1) if i click the enable button - so i can't connect. never had connection problems with earlier versions.

Share this post


Link to post
Share on other sites

nope same here and ive tried both 2.04 and 2.2.1 utorrent shows utorrent not running :/

you ought to fix this bro we all wanna endorse youre file but like this its hard to do so ;)

and yes utorrent is running :rolleyes:

Share this post


Link to post
Share on other sites

oh noess!!! look what ya dun goofed now my entire pc exploded thanks to that update :P

just kidding but wohoooooooooo!!!!! you done it bro it works magic , now you get youre well deserved 3 thumbs up there you go enjoy and keep up the good work this is a must have program tbh somebody else already did this in a media center program but wanted money for its function to be enabled now i can slap this into his face and laugh heartily all day long :D

keep up the developing of this program if theres improvements to be made , suggestions? id say anything that improves on it ey? btw love da handicap icon lolz ;) ,keep up the good work and rock on !!!

Share this post


Link to post
Share on other sites

Hi there,

Thanks, version 1.4 works for me! I've been looking for something like this.

Perhaps a feature request would be to be able to run uTorrent Helper with a command line parameter that allows it to run once, remove items, and then quit. Specifically, this could then be run each time uTorrent completes a torrent, as there is a field in the preferences that allows this.

Share this post


Link to post
Share on other sites

wilmee, I know this is kind of late but thanks for the feedback. I tested uTorrent's ability to trigger a program, script etc when a torrent's done downloading but uTorrent doesn't seem to send a trigger right away. It first goes into a seeding mode and doesn't send a trigger to execute an external program. Once it actually go into finished mode does it actually send a trigger which is too late if you ask me. Let me know if I'm wrong.

Share this post


Link to post
Share on other sites

need to fix magnet link support since all my added magnet links get autoremoved at least most of them that dont immediately go to 1% the ones at 0% for a little while get autoremoved, and the rest that work dont get removed once finished and another thing is that when i select autostart yes and i reboot my pc it will not autostart utorrent helper, these must be fixed thank you alot

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.