Jump to content

µTorrent Memory Usage increases till max and crashes.


Recommended Posts

See title. It was working fine just yesterday, and day before that and so on .. First time this problem has happened and as it is, I can hardly download anything.

Basically what happens is that the faster I download, the faster my available memory is depleted by µTorrent till there is 0 available, and then the client crashes. Should this happen, sometimes when I restart the client it shows all torrents at 0% as if I hadn't even downloaded anything.

From the disk cache settings, if the first option is disabled, I keep getting Disk Overload errors so as per some instructions I read, I enabled it and set it to max, which was 9999. And It has been at 9999 for months now, no problems whatsoever until now. If I now disable that setting, the memory problem isn't happening. Hard to tell if it's because of that setting or the fact that I can't even download faster than 2MB/s because of the Disk Overload error. Any lower setting than 9999 in the means much slower downloads.

Example : It's at 9999 and I open four new torrents on private tracker. The speed skyrockets to near the max, around ~16MB/s (Max 20MB/s), but the memory available is depleted by around 500MB per minute. Needless to say, in just four minutes the client crashes.

I set it to 1800, and the download speed is only around 3MB/s. The speed slowly builds up, and after a while it's around 8MB/s but will not go past this speed. Even at 8MB, my memory usage keeps increasing even though much slower. Even at this much slower speed, when I am downloading 4 torrents which each are 20GB+, I would reach my maximum memory usage before they are completed. Besides, I'm not paying for 200M connection so that it works at 80M -_-.

I've tried switching HDD's to download to = No effect. I'm using µTorrent 2.2. I've even tried different client, BitTorrent, and it still happens. (The interface was exactly same as uTorrent though so makes me wonder if it's the same client..). I also tried Vuze but ran into different problems so I don't know if it happens with Vuze or not.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...