Jump to content

Win 7 x64 Locks Computer up - A Possible Fix for some of you ...


Recommended Posts

Hi there!

I am a long time user of uTorrent and everything was fine until I upgraded my PC; I am running a Phenom 6 on an ASRock 890FX Deluxe 3 motherboard, 8 Gb DDR3 Ram, Radeon HD 5670 and approx 2.6 Tb of Hard Disk (4 separate drives) - Windows 7 Ultimate X64.

Since the upgrade, uTorrent will start off fine, and I was able to download files, but if left for a while I would usually come back to find that the computer was completely locked up; the only way to get things going again was a hard reset :(

Did the usual stuff - searched the forums here and the internet, and tried many of the suggested things, but always with the same result; after a while the computer would just go "sulky" and not want to work at all.

I was using uTorrent 3 alpha, so downgraded to 2.2 but that made no difference, disabled AVG (no difference) adjusted a multitude of settings as suggested on the forums - still no joy...

I noticed on the forums that a lot of people are having similar issues with RaLink drivers - the gist of those posts being that some network drivers are, erm... "a bit flakey" to put it politely. My motherboard has a Realtek PCIe GBE Family Controller - NOT RaLink (which I believe is mainly wireless network) - I'm using the RJ45 cable to my Netgear Router for the connection, but I thought in desperation that I might as well look into the network drivers.

The stock drivers for the LAN were version 7.17.304.2010 and worked well with everything else (as far as I'm aware), but a visit to the Realtek site (http://www.realtek.com.tw) showed that there was a much newer version, 7.45.516.2011 so I downloaded and installed them instead. As a test, I ran uTorrent and left it overnight downloading a torrent of over 13Gb - a lot of people seem to be having problems with larger downloads, so I thought if it was going to break that should do it!

I'm really happy to say that (crossed fingers ;) ) uTorrent has not locked the machine and all is going well...

Maybe it's too early to say for sure, but I am pretty confident that this has sorted the problem which has been bugging me for over three months; I will post again in a week or so if all is still working - or before if not - and give you all an update on what's happening.

In summary, if you are having problems with uTorrent crashing / freezing etc, I strongly recommend that you make sure that you have the latest available drivers for your hardware - especially your network drivers.

In case you are not sure of the chipset used for your network, can I suggest a small utility called SIV (System Information Viewer) from http://rh-software.com/, which can give you loads of information about the chips being used in your computer. When you run it, look on the tab marked "PCI Bus" and you can identify the chipset used for your network card (Listed as Ethernet). To get the driver version on your machine, look in Device Manager under Network Adapters - expand that item and double-click on the adapter you are using. A window will pop up - you want to select the tab marked "Driver" - this gives info on the actual version of driver installed, including it's date and exact version number. Alternatively, another freeware program I've found useful is called "Unknown Device Identifier" which you can get from http://www.zhangduo.com/udi.html . Using this information, go to the chipset manufacturer's website (in some cases you might need to go to your computer, motherboard or network card manufacturers site) and check the version number of the latest available driver for your particular rig (e.g. exact chipset, operating system and whether you are running 32 or 64 bit OS) - if it's newer than the one you are using, download it and use it to update your system. Hopefully, those crashes will be a thing of the past.

Apologies for the waffling in this post, but I feel that if it saves even just one of you from the headaches I've had tracking this problem down, it is well worth it!

Good Luck!! :D

Link to comment
Share on other sites

  • 2 weeks later...

OK - so I said that I would report back in a few days ...

Just a quick note to anyone thats interested - it works! After updating to the latest available network drivers, no more lock ups; I ran uTorrent for 3 days continuously with no problems. I've now updated to version 3 and it's running like a dream - decent download speeds too.

If you find this useful, please post a reply and let me know!!!

Happy torrenting !


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...