Jump to content

Unable to Upload/Not able to connect to peers&seeds MAC


Recommended Posts

For months now I have been only able to download from my private trackers and unable to upload. This effecting my ratio greatly and I'd love to remedy it.


-I'm a bit of a luddite in these realms and don't understand how to go about rerouting my router (which up until a few months ago worked perfectly).

-Mac OS X 10.6.7

-Utorrent 1.0.2

-Using private torrent tracker

-Router NetGear WGR614v9

-When I check canyouseeme.com is says it can't see my port and the "connection has timed out"

My partner, who is directly hooked into the router (I'm wireless), can download and seed just fine and has no problems. I tried setting up some sort of port forwarding that has both the same starting port and ending port but I don't know if that's right, regardless it didn't work.

Is it my computer? The router? Utorrent?

Link to comment
Share on other sites

  • 5 weeks later...

Hello all,

I'm having exactly the same problem.

Downloading all fine on mac.

(could down and upload on pc with no probs)

Ports 25 and 80 giving same error message on canyouseeme -

Error: I could not see your service on xxx on port (80)

Reason: Connection timed out

Would also be most grateful for suggestions / help.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...