Jump to content

Utorrent Slow Download and Causing Internet Timeouts [Tried FAQ Guide]


Recommended Posts




- What Happens

This all started about a week ago (maybe even less). When I dl/start up a torrent it will connect like normal (though it seems to take longer than usual). The torrent will slow to a near halt or just halt completely within 3 - 5 seconds regardless of what speed it was going or the seed/peer connections. I have tried multiple torrents (about 17) each with the same result. During each test I ran a ping tracer to my router, it was showing multiple timeouts and very high latency responses (800+). As soon as I stopped the torrent, the tracert went back to normal.

-EVERYTHING you've tried so far, including ANYTHING listed above (please be as explicit and specific as you can). Tell us what your changed settings are.

The FAQs listed above, among a giant list of crap. I have tried direct connection to my modem, no fix. Factory Default reset to router (probably wasn't a reason to try that). Switching out the Ethernet cords in the router ports. Uninstalling Utorrent + Config files. AMD CPU fix.

Both Bittornado and Qbitorrent work perfectly fine. Utorrent will work on two other computers on the same network on both WLAN and LAN.

-What the port checker from the Speed Guide writes

Port is open (I run as DMZ anyway)

-What the Speed Guide shows your settings to be (press Ctrl+G in µTorrent)


-Operating system installed (Windows XP, 2000, ME, 98, 95, NT? Something else?)


-Security software installed (firewall, antivirus, antispyware, antiadware)


-Exact router model(s), and exact modem model

Cisco E3200 Firmware Version: 1.0.01 build 3 Apr 21, 2011 (will open the wall box for model # if needed)

-ISP (Internet Service Provider) being used

Cox Cable. No signs of P2P throttling.

Hopefully I've provided a good amount of info to go on. Will provide computer specs, etc if necessary.

Link to comment
Share on other sites

I would have thought disabling it or uninstalling it would have had the same effect, guess not. Uninstalling it got rid of my high latency problems, and I can actually download faster than 200kbps. The problem now is it will throttle between 3mbps - 700kbps (have tried 4 torrents) and occasionally timeout, Qbitorrent and Bittornado does not show this behavior. Hopefully "if" this is fixable, I can run Peerblock with it. Otherwise I'll sadly have to switch to a different client : /

Edit: Thanks for your assistance

Unsurprisingly, it seems like an issue with having AMD Dual Core Optimization installed, my last reformat it was causing my computer to lockup at desktop load. Though I'm still getting the random speed throttles with ping timeouts with just Utorrent, I'll try reinstalling MS hotfix and the driver later to see if that fixes things.

Edit 2: Sadly, reinstalling the hotfix and amd driver did not solve the issue.

Link to comment
Share on other sites

It would seem even after reformatting to XP64 the problem still persists.

Problem solved, switched Ethernet cord to my nforce network port and it was working normally. Never had a problem with my marvell yukon port other than now, though after reading about my mobo there seems to be a lot of forums with issues for the MY. Feel free to close this.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...