Jump to content

Not Valid Bencoding errors with 3.0


Recommended Posts

Dunno why my post was deleted instead of answered

Recap again

upgraded from utorrent 2.2.1 to 3.0 and get nothing but "Not Valid Bencoding" errors on any torrent site I try, ka/demon/etc.

I wasn't getting these errors with version 2.2.1

running Windows XP got 12 megabit down/ 768k up dsl

I tried uninstalling, using a registry cleaner app to fully remove, I reinstalled it, and at first accidentally installed the toolbar addons so uninstalled again and reinstalled.

Still got "Not Valid Bencoding" when clicking on a torrent on any torrent site.

To get things working again I came looking for the 2.2.1 version to reinstall since 3.0 wasn't working for me and the only solution I found on google search was a link to these forums of an admin mentioning to someone in the past to downgrade.

So I looked for a link to downgrade since it the only post I could find about "not valid bencoding" by an admin here was to downgrade, luckily I came across old apps site on google after searching it.

So temporarily I've been able to downgrade back to 2.2.1 and it works perfectly!

I was wondering if there was a patch or what would I need to do to get version 3.0 working with windows XP?

I noticed if you google utorrent not valid bencoding there are hundreds of pages, and most the recommendation has been to downgrade, for XP users at least. Is there any info on this situation how to fix this problem on XP ?

Any help would be appreciated instead of post deleting.

Link to comment
Share on other sites

since it the only post I could find about "not valid bencoding" by an admin here was to downgrade

Citation needed.

first page of google when you search for not valid bencoding, it was an old issue for the older 2.0 client

I was trying to find how to fix it with 3.0 since that solution of downgrading although it does fix the problem does not help with the new 3.0 client.

why does 3.0 give this error?

Link to comment
Share on other sites

yea, they do, I dont understand the difference.

When I installed 3.0 any try to download any torrents for example demonoid or ka.ph under 2.2.1 id choose where to save and then click ok and it would go to work.

with 3.0 it would give error not valid bencoding

if I used magnet link it would work but normal torrent link wouldn't

I tried searching google for utorrent 3.0 specifically

as you will see with the results


there is no solutions to any of the results for 3.0, except try reinstalling. So it's not making a lot of sense why 3.0 on my system and few others from google I guess we had odd systems causing this.

I wasn't sure if there was a checkbox somewhere to uncheck to turn that off or what. Magnet urls work, and downloaded the text file option on demonoid then manually loading the text file into utorrent works, but clicking the download the .torrent gives bencoding errors for me in 3.0 but not in previous version.

it's really odd, and not sure why or what, and from that google search I can't find any solution to the multitude of similar issues

but if i go into firefox and change file associations so that a bencode editor opens instead of utorrent it shows the torrent is correct and it loads just fine automatically in 2.2.1, but 3.0 when it tries to load it just errors out as "not valid bencoding"

it's really odd

Link to comment
Share on other sites

  • 1 year later...


This topic is now archived and is closed to further replies.

  • Create New...