Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 3.1 Release Candidate 11

Recommended Posts

Mm yeah, I take it all back, just had 3 torrents get stuck at 99%, 512kB piece size. Then when I stopped them and hit Force Recheck for all 3 µTorrent froze with Disk Overloaded 100%. Had to kill it in Task Manager... Reopened and it still has the crash bug of forgetting window width and torrent list height.. So yeah, reopening it started to redownload all 3 again, and of course Disk Overloaded 100% again.. 192/32mb on the Disk Statistics tab... not good, not good.

"Stuck" peices in Disk Cache + Force recheck = Hang.

Hang + Kill process = Forgotten window width and torrent list height.

Disk overload is definitely a µTorrent problem since I have paused all torrents except one and watched the write cache fill up to Disk Overloaded 100%, then I pause that torrent too. The Pieces tab stays full of completed pieces (32/32 blocks completed on many pieces) for ages, then, even though there is 0 other activitiy on this disk, it slowly writes them out, showing as sawteeth (from 0 to 128kB) on the right write graph (currently showing from 0 to 1). Is this a hashing issue? Why aren't these "finished pieces" getting written immediately as the Disk Cache options state? Looks like they're being written out as "untouched blocks" every 2 minutes instead, no?

You sure?

Doing a force recheck takes forever, but I haven't had a hang happen...

I often get messages about disk overloaded, but doesn't cause me a problem - I justr fugire the amount of data being dealt with is high?

Share this post


Link to post
Share on other sites
I often get messages about disk overloaded, but doesn't cause me a problem - I justr fugire the amount of data being dealt with is high?

I means the cache (defined in advanced->cache) was filled up, and uTorrent is limited by the HD speed. This is when you have a slow system, a fast connection or a bug... :P How un/efficient and wisely it handles this situation will determine the overload message. For example it can try to reduce DL speed (incoming data).

Share this post


Link to post
Share on other sites

Doesn't run, period. Lots of dumps sent. The window does pop up before several of the crashes and I can see that the icons in the Name column are gone even though I know I set that in Advanced. Still crashed after I removed my settings.dat ... How did this get rolled out to the Autoupdater?

Luckily the old 26419 exe was still under Program Files\uTorrent as a .tmp file so I rolled back.

Share this post


Link to post
Share on other sites

:/ I guess '99,9% issue' is still alive in build 26462, however, it occurs more seldom. On the other hand, tried re-check several times - no use, then it suddenly as if downloaded the missing piece. Maybe the problem was just with the tracker/file itself, but I felt it would be better to write it here, just in case you know :)

P.s. Downloading a number of other torrents at the moment - gonna know soon if 99,9% issue is an exception or the rule for the current build :)

Share this post


Link to post
Share on other sites

Let me try to have a guess here on that 99.9% issue... Since uTorrent tries to rename files at that point, why don't you try to set a "full control" security privileged to "everyone" on your download directory ?... Who knows...

Share this post


Link to post
Share on other sites
Let me try to have a guess here on that 99.9% issue... Since uTorrent tries to rename files at that point, why don't you try to set a "full control" security privileged to "everyone" on your download directory ?... Who knows...

If you mean the hashfails, and the last few getting stuck, no. The only reason it hits 99.9% is because a dozen hashfails are left behind at the end, which makes for about 99.9%. Until the recheck clears the hashes, its going nowhere, and you could just as easily do the recheck at 90%, have no more fails, and it finish without further issue.

Share this post


Link to post
Share on other sites

It also sticks at 99% until the "stuck" completed pieces get written out of the disk cache too, which can take awhile depending how overloaded it got - which is why my money is still on a problem with it not writing out completed pieces immediately; could also be related to hashing since it might be having trouble realizing the pieces are completed if it's checking them wrong.

Share this post


Link to post
Share on other sites
my money is still on a problem with it not writing out completed pieces immediately;

Maybe. I did noticed many complete pieces in there. In my test (over LAN) with no hash checks it just took time for them to be written and complete. I'm glad it is YOUR money , tho... I wouldn't bet any of my money on any uT related issue. The chaos is very unexpected ... :P

Share this post


Link to post
Share on other sites

Some torrents still get stuck on 99%-ish. Furthermore - when you try to force re-check them - uTorrent freezes and needs to be killed from task manager.

Share this post


Link to post
Share on other sites
Some torrents still get stuck on 99%-ish. Furthermore - when you try to force re-check them - uTorrent freezes and needs to be killed from task manager.

"Stuck" peices in Disk Cache + Force recheck = Hang.

Share this post


Link to post
Share on other sites
Doesn't run, period. Lots of dumps sent. The window does pop up before several of the crashes and I can see that the icons in the Name column are gone even though I know I set that in Advanced.

I figured it out, my dummy "apps" blank file (to prevent uTorrent downloading all the garbage in that folder that I don't use) was crashing it. This didn't happen in 26419, and I prefer it that way. Dummy files for "cache" and "dlimagecache" don't seem to cause any problem.

The torrent list icons (gui.show_status_icon_in_dl_list = *true) don't show, but will once you disable and reenable that setting. When the program is restarted it goes back to not showing them though.

Share this post


Link to post
Share on other sites
The torrent list icons (gui.show_status_icon_in_dl_list = *true) don't show, but will once you disable and reenable that setting. When the program is restarted it goes back to not showing them though.

Same here, Win7 (64bit).

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.