Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 3.1 stable (build 26671)

Recommended Posts

I can provide the example feed, but it's from a private tracker and it contains all my data inside. I could provide it to a support e-mail if the devs want to. The feed is correct.

Share this post


Link to post
Share on other sites

I wonder, is there still an issue with hash-checks? Here is what I've noticed:

On a single file, 6.5G torrent while I was trying to transfer it over my LAN -

0. set diskio.use_partfile to false (but I think 'true' gives similar results )

1. Started the download

2. Manually stopped the download

3. made sure there is one part-piece left (look in the pieces tab & mark it's #)

4. tried to start-resume the torrent again

-> It immediately reported in the logger tab - HASH FAIL for that piece and banned the single seed I had (download stopped in my case)

Logger reported:

[2011-12-23 20:46:27] *** (test_torrent): PIECE 1613 FAILED HASH CHECK <- after manual stop & resume

[2011-12-23 20:46:27] Banned 192.168.137.1:53 until forever <- DL stops (my single seed - banned)

[2011-12-23 20:47:28] Unbanned 192.168.137.1:53 <- manually reset of the bans (right-click->advanced->reset bans)

[2011-12-23 20:47:28] Unbanned 192.168.137.233:0

[2011-12-23 20:47:32] *** (test_torrent): PIECE 1613 FAILED HASH CHECK <- torrent tries to resumes and fails

[2011-12-23 20:47:32] Banned 192.168.137.1:53 until forever <- Download holds again

^… and repeated forever

5. Also, when trying to force-recheck the torrent, it resets to 0% :(

Some times, I've also noticed that this piece is staying in the cache and (still) failing forever :(

Can someone confirm this ?

Share this post


Link to post
Share on other sites

Some times, I've also noticed that this piece is staying in the cache and (still) failing forever :(

Can someone confirm this ?

I just updated to 3.1 latest build. I've have not been having any problems until I starte up one of the large MAME torrents to refresh my outdated set that is stored on NAS. Their seems to be some issues still and I wonder if NAS has something to do with it.

I noticed multiple torrents that after the "Checking" finished, it reset to zero and restarted the torrent.

I have not dug into it any more as most of the items seem to be working fine. I just wish the whole cache and disk IO problem would become a priority as it is very annoying for the ones that experience it!

Thaniks,

cyberfix

Share this post


Link to post
Share on other sites
I wonder, is there still an issue with hash-checks? Here is what I've noticed:

On a single file, 6.5G torrent while I was trying to transfer it over my LAN -

0. set diskio.use_partfile to false (but I think 'true' gives similar results )

1. Started the download

2. Manually stopped the download

3. made sure there is one part-piece left (look in the pieces tab & mark it's #)

4. tried to start-resume the torrent again

-> It immediately reported in the logger tab - HASH FAIL for that piece and banned the single seed I had (download stopped in my case)

Some times, I've also noticed that this piece is staying in the cache and (still) failing forever :(

Can someone confirm this ?

same problem here

3c4f72166124957.jpg

diskio.smart.hash at Options>Preferences>Advanced (it may already be enabled - I am not sure of the default setting)

When you are downloading a torrent like I said not all of them have that issue

the torrents that are making the problem have multiple large files

for ex :

1GB

2GB

500MB

1.5GB

1.1GB

total capacity around 5.1 GB if down high speed uploading slow down.......I have called my ISP provider and everything it's ok

tested with utorrent 3.0 last build

this problem need to be fixed

Share this post


Link to post
Share on other sites
I noticed multiple torrents that after the "Checking" finished, it reset to zero and restarted the torrent.

I also have had this issue since v3.0.

As far as I can remember, it did not occur in previous versions.

Share this post


Link to post
Share on other sites

I had some renaming issues too, but I thought it was just the behavior of the software. For instance, I might rename a torrent called "trailer" to a torrent called "August Movie Trailers" and that works fine. While battling disk IO issues on one torrent, I noticed that the path on the torrent with an issues was a different case than the other one working. ("W:\downloads\Trailers" worked but "W:\downloads\trailers" was causing disk overload). I know Windows doesn't care about case in the file system, so I thought there might have been some weirdness with my Thecus NAS unit being on a Linux based OS. I went to Advanced on that torrent, reselected the path above and it changed the path to it plus a directory with the name of the torrent (w:\downloads\Trailers\August Movie Trailers\). It did seem like the caching may had been better for that brief moment, but I immediately corrected the directory problem (had to rename torrent temporarily to fix). The paths match now, but the one torrent caused all kinds of grief to get it to finish because of the disk overload. Also, my cache kept going up to 1.6 GB of memory for writing and then the software would hang. It does not always write out the cache for some time (5 to 10 minutes?).

Is there any chance this disk overload is a false positive? Why not put a tools section into uTorrent and include a read/write speed tester, so that we can prove to you it is not our external, NAS, or other device with the issue or prove that we have a bad setup?

This is just reporting on awkward items that may or may not be a bug.

Thanks,

cyberfix

Share this post


Link to post
Share on other sites

"Good" to see that a lot of people have some disk overloaded issues...

For me, about "Disk overloaded 100%", it's too random to do some consistent tests ! :/

Are the devs in vacation ? (Not seen one of them since one week).

Cheers.

PS: Did anyone test these disk cache settings (or can test or use these settings) ? :

What can you say about these "advices" ? :

http://www.tribalmixes.com/forums.php?action=viewtopic&topicid=6531&page=p40649#f40649

Same here with updated version :

diskcache.png

Share this post


Link to post
Share on other sites
Are the devs in vacation ? (Not seen one of them since one week).

Apparently, yes :)

My settings (including general->preallocate = true) Tested at high speeds. See if this helps:

cacheoptimizedsettings.png

54551952.png

Share this post


Link to post
Share on other sites

Hello there, happy Xmass ...

Today I experienced this.

One torrent downloading and after finishing it disappears from Downloading list

but there continue to appear Peers in the list.

Probably from the last torrent but I haven't looked further.

utorrent2t.png

Share this post


Link to post
Share on other sites

last vers of utorrent 3.1 build 26616 has big problem with disk cache...tested at high speeds uploading downloading at same time

c578fa166196237.jpg

back to 3.0 everything when back to normal

36352a166196814.jpg

please fix this problem

Share this post


Link to post
Share on other sites
last vers of utorrent 3.1 build 26616 has big problem with disk cache

I see twice the upload speed in V 3.1 . Is that the problem ? ... :P

Seriously - try to use my above settings (the two changes in advanced) . I have a feeling you'll get the exact same results... :)

Share this post


Link to post
Share on other sites
last vers of utorrent 3.1 build 26616 has big problem with disk cache

I see twice the upload speed in V 3.1 . Is that the problem ? ... :P

Seriously - try to use my above settings (the two changes in advanced) . I have a feeling you'll get the exact same results... :)

Your settings from pos t#238 Yesterday 19:24:54 seems to unleashed new problems to this ut ver 3.1 when uploading' date=' downloading speed drops, from this disk flushing,disk cashing settings bug that need to be fixed

When only uploading with ut 3.1 26616 with your settings disk write is writing to disk

with utorrent 3.0 no write to disk

1c36c1166335476.jpg

From admin Ultima :

Well, the less often you write data out to disk, the higher risk you run in potentially losing unwritten data to some kind of instability/crash.

http://forum.utorrent.com/viewtopic.php?id=48238

Please fix this disk writing bug

Share this post


Link to post
Share on other sites
Sorry, but it is very hard to understand what you mean

read my post again , hope you understand that utorrent 3.1 26616 has a big problem with disk write,of course only when you are uploading an downloading at the same time at high speeds

Share this post


Link to post
Share on other sites
When only uploading with ut 3.1 26616 with your settings disk write is writing to disk

I see 3.0 screenshot with (0) in the downloading category.

Maybe you want to show also a 3.1 screenshot with (0) (zero) downloads that is still writing to disk?

Share this post


Link to post
Share on other sites
When only uploading with ut 3.1 26616 with your settings disk write is writing to disk

I see 3.0 screenshot with (0) in the downloading category.

Maybe you want to show also a 3.1 screenshot with (0) (zero) downloads that is still writing to disk?

When only uploading with ut 3.1 26616 with your settings disk write is writing to disk

with utorrent 3.0 no write to disk

Share this post


Link to post
Share on other sites
Maybe you want to show also a 3.1 screenshot with (0) (zero) downloads that is still writing to disk?

A 3.1 screenshot please would be nice...

Share this post


Link to post
Share on other sites

Auto shutdown problem, It's do nothing after countdown to 1 second.

I believe this stable release is most very ugly.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.