Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 3.1 stable (build 26671)

Recommended Posts

The file padding issue is a known issue with the developers. This happens frequently on large torrents with hundreds of small files. It usually can be fixed with the recommended setting adjustments, but this does not work for everyone. I think it is tied in with the cache issue and wish they would make all of this IO issues a top priority and put them to rest once and for all. Other message boards have discussed the issue too.

From what I have read, it seems like it must be extrememly difficult to fix. Can't you look at what other software does to fix it and base your fix off of the same technique?

I am just a long term frustrated user like others that are having issues with newer version of uTorrrent.

Share this post


Link to post
Share on other sites
The problem is in tbdev, because tbdev does not accept negative values inside a torrent file. File-media sometimes contain negative values, like here:

So, the trackers should fix this. Post on their forums. I did the same and they fixed the problem on the trackers I use.

You can point the tracker admins to this forum/post:

http://www.tbdev.net/topic/25020-utorrents-v31-fix/page__view__findpost__p__186589

Share this post


Link to post
Share on other sites

Cyberfix: Please understand that I am just a user like you. I do not have anything to do with uTorrent development. What I am trying to understand is where and if this problem actually exists withing uTorrent. As I have said, I do not have any problems with viewing, listening, reading, or installing any data file I have downloaded using uTorrent. I do NOT get any errors on any player or reader because of an issue with "padded files".

That being said, I have seen torrents that were created with BitComet 1.1, that contained the following in the file list "____padding_file_<number>_if you see this file, please update to BitComet 0.85 or above ____". This would seem to be an issue of the creator of the torrent - not uTorrent. In the two years I have been using uTorrent, I have never seen a torrent that was "Created By: uTorrent" have these extra files.

If you are trying to talk about the "part" files that are created as a result of deselecting specific files within a multi-file torrent, then that is a different issue. I would think that uTorrent (or any torrent client) would need those files to support the hash verification to insure the data has not been modified. (I have not researched this ->.) But it would seem the hashing part of the protocol is based on a continous set of bytes of a Torrent, not on each specific file within a Torrent. So the "part" files data must be there to help support the hash verification. If you want to get rid of the "part" files then the protocol must be changed and that is a much bigger issue then "uTorrent".

Share this post


Link to post
Share on other sites
Cyberfix: Please understand that I am just a user like you. I do not have anything to do with uTorrent development. What I am trying to understand is where and if this problem actually exists withing uTorrent.

If you are trying to talk about the "part" files that are created as a result of deselecting specific files within a multi-file torrent, then that is a different issue. I would think that uTorrent (or any torrent client) would need those files to support the hash verification to insure the data has not been modified.

@ibebad: This has nothing to do with the part files. I have used uTorrent for several years with no issues at all. I decided to update a torrent and when I enabled it, I had the infamous 100% disk write cache problem. Also, my cache was set to 128MB and it would use up 1to 1.6GB before the software would hang or quit responde (i let it sit for hours). It seemed to be with this one torrent with many files. Others have succesfully transferred the same torrent.

Anyway, to get my thoughts back on track to the other issue with files being padded when there are a lot of small files. I will paraphrase and copy a post from another site on test that were done.

--Start of other post---

A site did extensive testing and they uncovered a flaw in uTorrent's caching system for writes, which can be reproduced.

To be precise, the "Disable Windows caching of disk writes" option, which is enabled by default. (at least in older versions)

Enabling this option bypasses the Windows caching system for writes.

A torrent was downloaded that contains over 6000 small files (not zipped).

First they used uTorrent v2.0.2 with default settings.

Saved the files in e.g. "d:\myfolder\pics"

Using a checksum program, it was verified that some of the files were bad even through the torrent was reported at 100% completed. More investigation uncovered that some of the files are getting padded with extra bytes. This happens to random files after deleting and downloadin the torrent again.

---end of other post---

I hope this clarifies my frustration as it seems like this issue needs some attention.

Share this post


Link to post
Share on other sites
Have you tested at 10MB down/11MB upload' date=' with 128 MB override cache ???? or at this speeds you need more cache????[/quote']

Not yet... But I intend to.

I believe that if there are no bugs, the user defined cache is useful only for temporarily "smoothing" things and letting other apps work better. If you run uT alone (for testing), it should work well also with practically minimal cache (long term). It should not affect it's *average* speed. If not - it is buggy...

Well, after checking it up - my conclusion is that unfortunately there seems to be bugs, that cause downloads to effect the uploads. It CAN do 10MB both ways (128M cache) , and I've seen it. It just does not sustain it for long in many cases, due to bad interaction of the download with the upload.

1. Setting a download limit seems to sometimes decrease the upload rate t0 close to zero

2. When two torrents are active - one downloading and the other uploading - it seems that once the download starts to increase and fill up the write cache - the read cache does not maintain the preset size and is being reduced to close to 0.

Well, I guess it is back to the cache drawing board after the holidays :P No sense to test anything till they fix the root bugs.

http://img585.imageshack.us/img585/8871/readcachecorrupted.png

http://thumbnails20.imagebam.com/16644/c98af6166430915.jpg

hope that some moderators/admin will update this client version 3.1 26616.....a bring a new fix for this bug disk write thing

everyone has this problem

Share this post


Link to post
Share on other sites
@ibebad: This has nothing to do with the part files. I have used uTorrent for several years with no issues at all. I decided to update a torrent and when I enabled it, I had the infamous 100% disk write cache problem. Also, my cache was set to 128MB and it would use up 1to 1.6GB before the software would hang or quit responde (i let it sit for hours). It seemed to be with this one torrent with many files. Others have succesfully transferred the same torrent.

Anyway, to get my thoughts back on track to the other issue with files being padded when there are a lot of small files. I will paraphrase and copy a post from another site on test that were done.

--Start of other post---

A site did extensive testing and they uncovered a flaw in uTorrent's caching system for writes, which can be reproduced.

To be precise, the "Disable Windows caching of disk writes" option, which is enabled by default. (at least in older versions)

Enabling this option bypasses the Windows caching system for writes.

A torrent was downloaded that contains over 6000 small files (not zipped).

First they used uTorrent v2.0.2 with default settings.

Saved the files in e.g. "d:\myfolder\pics"

Using a checksum program, it was verified that some of the files were bad even through the torrent was reported at 100% completed. More investigation uncovered that some of the files are getting padded with extra bytes. This happens to random files after deleting and downloadin the torrent again.

---end of other post---

I hope this clarifies my frustration as it seems like this issue needs some attention.

Could you send us your settings.dat? This might help us see what combination of settings you have that could be the problem.

Share this post


Link to post
Share on other sites

Could you send us your settings.dat? This might help us see what combination of settings you have that could be the problem.

http://uploading.com/files/a424ec2m/Desktop.rar/

now I have utorrent 3.0 and it's ok........

Well, after checking it up - my conclusion is that unfortunately there seems to be bugs, that cause downloads to effect the uploads. It CAN do 10MB both ways (128M cache) , and I've seen it. It just does not sustain it for long in many cases, due to bad interaction of the download with the upload.

1. Setting a download limit seems to sometimes decrease the upload rate t0 close to zero

2. When two torrents are active - one downloading and the other uploading - it seems that once the download starts to increase and fill up the write cache - the read cache does not maintain the preset size and is being reduced to close to 0.

Well, I guess it is back to the cache drawing board after the holidays tongue No sense to test anything till they fix the root bugs.

http://img585.imageshack.us/img585/8871/readcachecorrupted.png

this is the proof from rafi

my proof

http://www.imagebam.com/image/c98af6166430915

you can read the problem from

http://forum.utorrent.com/viewtopic.php?id=109914&p=10

from page 10 -to this page

hope you fix this bug

tried all kind of settings and nothing worked well.......

Share this post


Link to post
Share on other sites

Could you send us your settings.dat? This might help us see what combination of settings you have that could be the problem.

there is nothing wrong with the settings dat

the problem with the files occurs even with clean 3.0 or 3.1 utorrent with clean settings

even with checking or unchecking disable windows cashing

the problem does not occur in 1.7.7

the problem exists for quite awhile see my previous post with technical details

Share this post


Link to post
Share on other sites

When a new download is being added to the top of the main view, sorted by time by RSS downloader - a previously selected torrent is not in sync any more with the details tabs. They seem to show details of the previous item on the main list

selectdoesnotshowcorrec.th.png

Share this post


Link to post
Share on other sites

Could you send us your settings.dat? This might help us see what combination of settings you have that could be the problem.

http://uploading.com/files/a424ec2m/Desktop.rar/

now I have utorrent 3.0 and it's ok........

Well, after checking it up - my conclusion is that unfortunately there seems to be bugs, that cause downloads to effect the uploads. It CAN do 10MB both ways (128M cache) , and I've seen it. It just does not sustain it for long in many cases, due to bad interaction of the download with the upload.

1. Setting a download limit seems to sometimes decrease the upload rate t0 close to zero

2. When two torrents are active - one downloading and the other uploading - it seems that once the download starts to increase and fill up the write cache - the read cache does not maintain the preset size and is being reduced to close to 0.

Well, I guess it is back to the cache drawing board after the holidays tongue No sense to test anything till they fix the root bugs.

http://img585.imageshack.us/img585/8871/readcachecorrupted.png

this is the proof from rafi

my proof

http://www.imagebam.com/image/c98af6166430915

you can read the problem from

http://forum.utorrent.com/viewtopic.php?id=109914&p=10

from page 10 -to this page

hope you fix this bug

tried all kind of settings and nothing worked well.......

Share this post


Link to post
Share on other sites

Devs, I have such a bug.

Firstly, you can find settings here: http://zalil.ru/32437717

When I try to add torrent file with, i.e., 35 GB. I select 1 file from the list. Start torrent. It starts, but stucks after 1-2 minute, because of overloaded cache. When I restart UT, it goes normal.

Cache - 256 MB. Max speed ~4 MB.Default write cache size on downloading: 30-100.

I think it's bug.. Maybe it tryes to allocate cache for all files?

I saw these bug 2 or 3 month before, but it still not solved. :)

Share this post


Link to post
Share on other sites

µTP/uTP keeps disabling itself at random. If I enable it and shut down µTorrent, it's still on the next time. But after some time it's off again. It happens in a timespan of 5 minutes, it just happened again.

Share this post


Link to post
Share on other sites
When a new download is being added to the top of the main view, sorted by time by RSS downloader - a previously selected torrent is not in sync any more with the details tabs. They seem to show details of the previous item on the main list

http://img171.imageshack.us/img171/9033/selectdoesnotshowcorrec.th.png

I see something similar.

I select a torrent (in the detailed view), then switch to a different item in the left pane tree (from "Downloading" to some label, for example). After the switch the tabs at the bottom show data from some other torrent. Even if the old torrent is still show as selected in the list.

Share this post


Link to post
Share on other sites

Should µTorrent really be having so many PEX message related bans with itself? Generally 3.0/3.1 are the majority of ones banned; you'd think the newer versions since the addition of the "5 message limit" ban code would be smart enough to avoid this so as to remain a viable peer.

Share this post


Link to post
Share on other sites

Again... no changelog, why is this so hard for a company like this when uTorrent is one of the most used torrent client in the world? Seems like unorganization and laziness to me. I really hope this is the last time a new version comes out without us having any clue as to what the changes are because this reflects very badly on the company.

Share this post


Link to post
Share on other sites
Was prompted to update by the auto-updater to build 26650.

Any Changelog???

ya the link in the updater point to this thread. would like most recent release notes,

also dunno where to post this butthe device section is awesome but what about support for Windows Phone 7 devices?

Share this post


Link to post
Share on other sites

Don't know if it's been reported. The window which displays the files inside the torrents when you add a torrent, used to save its position and size on the desktop. You could move it around and resize then close it, and the window would save the position and size next time you add a torrent.

But since version 3.0, I think, the position of the window is not saved anymore. The size is saved. But the position always resets back to a default.

Is that a bug?

btw, I am using the latest stable version 3.1 build 26650 32 bit.

Share this post


Link to post
Share on other sites

After updating to 3.1.26650 some strange Chinese unclickable link

appeared in the toolbar next to the search field:

1067m.png

What the heck is this?

Share this post


Link to post
Share on other sites
What the heck is this?

See my tips/guide tip # F 3. ... :)

rafi, thanks, works perfectly.

s_url = http://forum.utorrent.com/viewtopic.php?id=109914

stitle = µTorrent Stable

These values add the link to this forum thread.

s_url = 

stitle =

And these ones (empty values) hide the link completely.

BTW, is there a variable for coordinates (e.g. to move this link 50-100px right)?

Share this post


Link to post
Share on other sites

Very sad thing happened to me when I am try to upgrade from build 26616 to 26650: as always, I close uT and uninstall it from ControlPanel with not active checkbox for removing profile. But when I opened executable of new uT build it ask me to select language and I am very scared and check %appdata%\uTorrent but it already was blank :(.

I lost my profile — how his happened, wtf?

Share this post


Link to post
Share on other sites
What the heck is this?

See my tips/guide tip # F 3. ... :)

Rafi have you tested this new version 3.1 stable (build 26650) with the 10MB down /11MB upload ??? did they fix that old problem ???

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.